summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-04-03 12:32:07 +0000
committerJustin Lecher <jlec@gentoo.org>2015-04-03 12:32:07 +0000
commitefee2d68893c6dcd5b9da34dc0f4784e797fe887 (patch)
treeaa858b02cc4dbbfde15e45b0a8875c3e5aab1520 /sci-libs/armadillo
parentVersion Bump, fixes https://github.com/gentoo/gentoo-portage-rsync-mirror/pul... (diff)
downloadgentoo-2-efee2d68893c6dcd5b9da34dc0f4784e797fe887.tar.gz
gentoo-2-efee2d68893c6dcd5b9da34dc0f4784e797fe887.tar.bz2
gentoo-2-efee2d68893c6dcd5b9da34dc0f4784e797fe887.zip
Version Bump, fixes https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/79; thanks Marius Brehler for the bump
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/armadillo')
-rw-r--r--sci-libs/armadillo/ChangeLog9
-rw-r--r--sci-libs/armadillo/armadillo-4.650.4.ebuild112
-rw-r--r--sci-libs/armadillo/metadata.xml24
3 files changed, 133 insertions, 12 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index 1ff60b301d83..03c30c318700 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/armadillo
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.31 2015/02/27 14:41:26 dilfridge Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.32 2015/04/03 12:32:07 jlec Exp $
+
+*armadillo-4.650.4 (03 Apr 2015)
+
+ 03 Apr 2015; Justin Lecher <jlec@gentoo.org> +armadillo-4.650.4.ebuild,
+ metadata.xml:
+ Version Bump, fixes https://github.com/gentoo/gentoo-portage-rsync-
+ mirror/pull/79; thanks Marius Brehler for the bump
*armadillo-4.650.2 (27 Feb 2015)
diff --git a/sci-libs/armadillo/armadillo-4.650.4.ebuild b/sci-libs/armadillo/armadillo-4.650.4.ebuild
new file mode 100644
index 000000000000..8d63e069bbae
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-4.650.4.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-4.650.4.ebuild,v 1.1 2015/04/03 12:32:07 jlec Exp $
+
+EAPI=5
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils toolchain-funcs multilib eutils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="MPL-2.0"
+SLOT="0/4"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="arpack atlas blas debug doc examples hdf5 lapack mkl tbb test"
+REQUIRED_USE="test? ( lapack )"
+
+RDEPEND="
+ dev-libs/boost
+ arpack? ( sci-libs/arpack )
+ atlas? ( sci-libs/atlas[lapack] )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )"
+DEPEND="${RDEPEND}
+ arpack? ( virtual/pkgconfig )
+ atlas? ( virtual/pkgconfig )
+ blas? ( virtual/pkgconfig )
+ hdf5? ( sci-libs/hdf5 )
+ lapack? ( virtual/pkgconfig )
+ mkl? ( sci-libs/mkl )
+ tbb? ( dev-cpp/tbb )"
+PDEPEND="${RDEPEND}
+ hdf5? ( sci-libs/hdf5 )
+ mkl? ( sci-libs/mkl )
+ tbb? ( dev-cpp/tbb )"
+
+src_prepare() {
+ # avoid the automagic cmake macros
+ sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DINSTALL_LIB_DIR="${EPREFIX}/usr/$(get_libdir)"
+ $(cmake-utils_use debug ARMA_EXTRA_DEBUG)
+ $(cmake-utils_use mkl ARMA_USE_MKL_ALLOC)
+ $(cmake-utils_use tbb ARMA_USE_TBB_ALLOC)
+ )
+ if use arpack; then
+ mycmakeargs+=(
+ -DARPACK_FOUND=ON
+ -DARPACK_LIBRARY="$($(tc-getPKG_CONFIG) --libs arpack)"
+ )
+ fi
+ if use atlas; then
+ local c=atlas-cblas l=atlas-clapack
+ $(tc-getPKG_CONFIG) --exists ${c}-threads && c+=-threads
+ $(tc-getPKG_CONFIG) --exists ${l}-threads && l+=-threads
+ mycmakeargs+=(
+ -DCBLAS_FOUND=ON
+ -DCBLAS_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${c} | sed 's/-I//')"
+ -DCBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${c})"
+ -DCLAPACK_FOUND=ON
+ -DCLAPACK_INCLUDE_DIR="$($(tc-getPKG_CONFIG) --cflags-only-I ${l} | sed 's/-I//')"
+ -DCLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs ${l})"
+ )
+ fi
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$($(tc-getPKG_CONFIG) --libs blas)"
+ )
+ fi
+ if use hdf5; then
+ mycmakeargs+=(
+ -DHDF5_FOUND=ON
+ -DHDF5_LIBRARIES="-lhdf5"
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$($(tc-getPKG_CONFIG) --libs lapack)"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_test() {
+ pushd examples > /dev/null
+ emake \
+ CXXFLAGS="-I../include ${CXXFLAGS} -DARMA_USE_BLAS -DARMA_USE_LAPACK" \
+ EXTRA_LIB_FLAGS="-L.. $($(tc-getPKG_CONFIG) --libs blas lapack)"
+ LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example1 || die
+ LD_LIBRARY_PATH="..:${LD_LIBRARY_PATH}" ./example2 || die
+ emake clean
+ popd > /dev/null
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc README.txt
+ use doc && dodoc *pdf && dohtml *html
+ if use examples; then
+ insinto /usr/share/examples/${PF}
+ doins -r examples/*
+ fi
+}
diff --git a/sci-libs/armadillo/metadata.xml b/sci-libs/armadillo/metadata.xml
index 95877e7a0397..8d0aed7cc2f6 100644
--- a/sci-libs/armadillo/metadata.xml
+++ b/sci-libs/armadillo/metadata.xml
@@ -1,9 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>sci</herd>
-<maintainer><email>dilfridge@gentoo.org</email></maintainer>
-<longdescription lang="en">
+ <herd>sci</herd>
+ <maintainer>
+ <email>dilfridge@gentoo.org</email>
+ </maintainer>
+ <longdescription lang="en">
Armadillo is a C++ linear algebra library (matrix maths) aiming
towards a good balance between speed and ease of use. Integer,
floating point and complex numbers are supported, as well as a
@@ -15,20 +17,20 @@
need for temporaries. This is accomplished through recursive
templates and template meta-programming.
</longdescription>
-<use>
- <flag name="atlas">
+ <use>
+ <flag name="atlas">
Link with <pkg>sci-libs/atlas</pkg> libraries for cblas and
clapack
</flag>
- <flag name="arpack">
+ <flag name="arpack">
Link with <pkg>sci-libs/arpack</pkg> libraries for eigen decomposition
</flag>
- <flag name='mkl'>
+ <flag name="mkl">
Use matrix allocation from the Intel MKL <pkg>sci-libs/mkl</pkg>
- </flag>
- <flag name='tbb'>
+ </flag>
+ <flag name="tbb">
Use matrix allocation from the Threads Building Blocks
<pkg>dev-cpp/tbb</pkg>
- </flag>
-</use>
+ </flag>
+ </use>
</pkgmetadata>