summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-02-23 19:47:09 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-02-23 19:47:09 +0000
commitb18fc664fe4f5ac20341656e83450b512ed7ee05 (patch)
tree20cc3f67013949db84a5fc985d61f4642ff71e60 /sci-libs/camd
parentBump (diff)
downloadgentoo-2-b18fc664fe4f5ac20341656e83450b512ed7ee05.tar.gz
gentoo-2-b18fc664fe4f5ac20341656e83450b512ed7ee05.tar.bz2
gentoo-2-b18fc664fe4f5ac20341656e83450b512ed7ee05.zip
Bump
(Portage version: 2.1.9.40/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/camd')
-rw-r--r--sci-libs/camd/ChangeLog12
-rw-r--r--sci-libs/camd/camd-2.2.2.ebuild34
2 files changed, 44 insertions, 2 deletions
diff --git a/sci-libs/camd/ChangeLog b/sci-libs/camd/ChangeLog
index 58d373c8d552..afe2d7c39dbc 100644
--- a/sci-libs/camd/ChangeLog
+++ b/sci-libs/camd/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sci-libs/camd
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/camd/ChangeLog,v 1.17 2010/07/09 10:05:40 ssuominen Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/camd/ChangeLog,v 1.18 2011/02/23 19:47:09 bicatali Exp $
+
+ 23 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> +camd-2.2.2.ebuild:
+ Bump
+
+*camd-2.2.2 (23 Feb 2011)
+
+ 23 Feb 2011; Sébastien Fabbro <bicatali@gentoo.org> +camd-2.2.2.ebuild:
+ Bump
09 Jul 2010; Samuli Suominen <ssuominen@gentoo.org> camd-2.2.0.ebuild:
ppc64 stable wrt #318649
diff --git a/sci-libs/camd/camd-2.2.2.ebuild b/sci-libs/camd/camd-2.2.2.ebuild
new file mode 100644
index 000000000000..c2a1606c826c
--- /dev/null
+++ b/sci-libs/camd/camd-2.2.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/camd/camd-2.2.2.ebuild,v 1.1 2011/02/23 19:47:09 bicatali Exp $
+
+inherit autotools eutils
+
+MY_PN=CAMD
+DESCRIPTION="Library to order a sparse matrix prior to Cholesky factorization"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/camd"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE="doc"
+DEPEND="sci-libs/ufconfig"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-2.2.0-autotools.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins Doc/CAMD_UserGuide.pdf || die "pdf install failed"
+ fi
+}