summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Kahle <tomka@gentoo.org>2010-11-08 23:19:56 +0000
committerThomas Kahle <tomka@gentoo.org>2010-11-08 23:19:56 +0000
commitf481a7223d4cfa855eb1c32f8a4399366c6a824c (patch)
treeef176cd81edf48fd72cd8e240386f0b8ebd36184 /sci-libs/cddlib/cddlib-094f-r2.ebuild
parentchange jpeg dep to virtual/jpeg (diff)
downloadgentoo-2-f481a7223d4cfa855eb1c32f8a4399366c6a824c.tar.gz
gentoo-2-f481a7223d4cfa855eb1c32f8a4399366c6a824c.tar.bz2
gentoo-2-f481a7223d4cfa855eb1c32f8a4399366c6a824c.zip
new package: sci-libs/cddlib imported from science overlay. Fixes bug #230423.
(Portage version: 2.1.9.24/cvs/Linux i686)
Diffstat (limited to 'sci-libs/cddlib/cddlib-094f-r2.ebuild')
-rw-r--r--sci-libs/cddlib/cddlib-094f-r2.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sci-libs/cddlib/cddlib-094f-r2.ebuild b/sci-libs/cddlib/cddlib-094f-r2.ebuild
new file mode 100644
index 000000000000..d4172763308f
--- /dev/null
+++ b/sci-libs/cddlib/cddlib-094f-r2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cddlib/cddlib-094f-r2.ebuild,v 1.1 2010/11/08 23:19:56 tomka Exp $
+
+EAPI="3"
+
+inherit autotools-utils
+
+DESCRIPTION="C implementation of the Double Description Method of Motzkin et al."
+HOMEPAGE="http://www.ifor.math.ethz.ch/~fukuda/cdd_home/"
+SRC_URI="ftp://ftp.ifor.math.ethz.ch/pub/fukuda/cdd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc static-libs"
+
+DEPEND=">=dev-libs/gmp-4.2.2"
+RDEPEND="${DEPEND}"
+
+AUTOTOOLS_IN_SOURCE_BUILD="1"
+DOCS=( ChangeLog README )
+PATCHES=(
+ "${FILESDIR}"/${PN}-094f-use-libtool.patch
+ "${FILESDIR}"/${PN}-094f-add-cdd_both_reps-binary.patch
+)
+
+src_prepare() {
+ autotools-utils_src_prepare
+ eautoreconf
+
+ cp "${FILESDIR}"/cdd_both_reps.c "${S}"/src/ \
+ || die "failed to copy source file"
+ ln -s "${S}"/src/cdd_both_reps.c "${S}"/src-gmp/cdd_both_reps.c \
+ || die "failed to make symbolic link to source file"
+}
+
+src_install() {
+ if use doc ; then
+ DOCS=( ${DOCS[@]} doc/cddlibman.pdf doc/cddlibman.ps )
+ fi
+
+ autotools-utils_src_install
+}