summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-12-03 08:14:34 +0000
committerJustin Lecher <jlec@gentoo.org>2014-12-03 08:14:34 +0000
commitb9a630723043a3e138237e724c1baab1b2112bef (patch)
tree5a1f5dd710ca080353bcb3f94dd4447e64afd37c /sci-libs/clapack
parentVersion bump (bug #516012). (diff)
downloadgentoo-2-b9a630723043a3e138237e724c1baab1b2112bef.tar.gz
gentoo-2-b9a630723043a3e138237e724c1baab1b2112bef.tar.bz2
gentoo-2-b9a630723043a3e138237e724c1baab1b2112bef.zip
sci-libs/clapack: Use system f2c.h instead of bundled one, #531442
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs/clapack')
-rw-r--r--sci-libs/clapack/ChangeLog7
-rw-r--r--sci-libs/clapack/clapack-3.2.1-r8.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/sci-libs/clapack/ChangeLog b/sci-libs/clapack/ChangeLog
index 990cdf4b784c..a78531a5932b 100644
--- a/sci-libs/clapack/ChangeLog
+++ b/sci-libs/clapack/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/clapack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/ChangeLog,v 1.24 2014/01/06 14:41:18 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/ChangeLog,v 1.25 2014/12/03 08:14:34 jlec Exp $
+
+*clapack-3.2.1-r8 (03 Dec 2014)
+
+ 03 Dec 2014; Justin Lecher <jlec@gentoo.org> +clapack-3.2.1-r8.ebuild:
+ Use system f2c.h instead of bundled one, #531442
06 Jan 2014; Justin Lecher <jlec@gentoo.org> clapack-3.2.1-r6.ebuild,
clapack-3.2.1-r7.ebuild:
diff --git a/sci-libs/clapack/clapack-3.2.1-r8.ebuild b/sci-libs/clapack/clapack-3.2.1-r8.ebuild
new file mode 100644
index 000000000000..41947ba69021
--- /dev/null
+++ b/sci-libs/clapack/clapack-3.2.1-r8.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/clapack/clapack-3.2.1-r8.ebuild,v 1.1 2014/12/03 08:14:34 jlec Exp $
+
+EAPI=5
+
+inherit flag-o-matic cmake-utils
+
+DESCRIPTION="f2c'ed version of LAPACK"
+HOMEPAGE="http://www.netlib.org/clapack/"
+SRC_URI="http://www.netlib.org/${PN}/${P}-CMAKE.tgz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-libs/libf2c-20090407-r1
+ virtual/blas"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-CMAKE
+
+PATCHES=(
+ "${FILESDIR}/${P}-fix_include_file.patch"
+ "${FILESDIR}/${P}-noblasf2c.patch"
+ "${FILESDIR}/${P}-hang.patch"
+ "${FILESDIR}/${P}-findblas-r7.patch"
+)
+
+src_prepare() {
+ rm INCLUDE/f2c.h F2CLIBS/libf2c/f2c.h || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ filter-flags -ftree-vectorize
+ # causes an internal compiler error with gcc-4.6.2
+
+ local mycmakeargs=( $(cmake-utils_use_enable test TESTS) )
+ cmake-utils_src_configure
+}