summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-04-01 12:05:53 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-04-01 12:05:53 +0000
commit2721439b2a058ee405a092dbdb8e996212f6d24a (patch)
tree8cf6677c1aa2e9ac06de2258fd8a45fcb9f70fc2 /sci-libs/cln
parentVersion bump and set all to SLOT=0 with blockers because of collisions. (diff)
downloadgentoo-2-2721439b2a058ee405a092dbdb8e996212f6d24a.tar.gz
gentoo-2-2721439b2a058ee405a092dbdb8e996212f6d24a.tar.bz2
gentoo-2-2721439b2a058ee405a092dbdb8e996212f6d24a.zip
Filtered CFLAGS=-fdirectives-only and minor QA fixes, switch to EAPI=2
(Portage version: 2.2_rc27/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/cln')
-rw-r--r--sci-libs/cln/ChangeLog5
-rw-r--r--sci-libs/cln/cln-1.2.2.ebuild40
2 files changed, 26 insertions, 19 deletions
diff --git a/sci-libs/cln/ChangeLog b/sci-libs/cln/ChangeLog
index 9715eb3b7138..8ef3474f2591 100644
--- a/sci-libs/cln/ChangeLog
+++ b/sci-libs/cln/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/cln
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/ChangeLog,v 1.31 2009/03/11 18:02:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/ChangeLog,v 1.32 2009/04/01 12:05:53 bicatali Exp $
+
+ 01 Apr 2009; Sébastien Fabbro <bicatali@gentoo.org> cln-1.2.2.ebuild:
+ Filtered CFLAGS=-fdirectives-only and minor QA fixes, switch to EAPI=2
11 Mar 2009; Jeroen Roovers <jer@gentoo.org> cln-1.2.2.ebuild:
Marked ~hppa (bug #260777). Do not use deprecated hppa1.1 asm.
diff --git a/sci-libs/cln/cln-1.2.2.ebuild b/sci-libs/cln/cln-1.2.2.ebuild
index 8dc43c21a7b1..949b89672faa 100644
--- a/sci-libs/cln/cln-1.2.2.ebuild
+++ b/sci-libs/cln/cln-1.2.2.ebuild
@@ -1,8 +1,9 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.2.2.ebuild,v 1.8 2009/03/11 18:02:00 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.2.2.ebuild,v 1.9 2009/04/01 12:05:53 bicatali Exp $
-inherit eutils flag-o-matic multilib
+EAPI=2
+inherit eutils flag-o-matic
DESCRIPTION="Class library (C++) for numbers"
HOMEPAGE="http://www.ginac.de/CLN/"
@@ -16,29 +17,32 @@ KEYWORDS="amd64 ~hppa ppc ~ppc64 sparc x86"
IUSE="doc examples"
DEPEND="dev-libs/gmp"
+RDEPEND="${DEPEND}"
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # avoid building tests and examples by default
- epatch "${FILESDIR}"/${P}-examples.patch
- # avoid installing dvi and html docs by default
- epatch "${FILESDIR}"/${P}-docs.patch
-}
-
-src_compile () {
+pkg_setup() {
# -Os causes segmentation faults (see bug #174576)
- # checked for 1.2.1, gcc-4.2.3
+ # checked for 1.2.2, gcc-4.3.3
replace-flags -Os -O2
# ftracer buggy bug #237451
filter-flags -ftracer
+ # -fdirectives-only also buggy bug #263257
+ filter-flags -fdirectives-only
use sparc && append-cppflags "-DNO_ASM"
use hppa && append-cppflags "-DNO_ASM"
+}
+
+
+src_prepare() {
+ # avoid building tests and examples by default
+ epatch "${FILESDIR}"/${P}-examples.patch
+ # avoid installing dvi and html docs by default
+ epatch "${FILESDIR}"/${P}-docs.patch
+}
+
+src_configure () {
econf \
--libdir=/usr/$(get_libdir) \
- --datadir=/usr/share/doc/${PF} \
- || die "econf failed"
- emake || die "emake failed"
+ --datadir=/usr/share/doc/${PF}
}
src_install () {
@@ -46,10 +50,10 @@ src_install () {
dodoc README ChangeLog TODO* NEWS
if use doc; then
dodoc doc/cln.ps
- dohtml doc/cln/*
+ dohtml doc/cln/* || die
fi
if use examples; then
insinto /usr/share/doc/${PF}
- doins -r examples
+ doins -r examples || die
fi
}