summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-06-29 13:39:55 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-06-29 13:39:55 +0000
commit8486046465be75bb4bbafcc0e9eb78e99eb1101f (patch)
treee7ebab57bbe03c3c5ff3f82817c5d5af9033e912 /sci-libs/cln
parentAdd another patch from upstream. Don't show tabs in the subject as question ... (diff)
downloadgentoo-2-8486046465be75bb4bbafcc0e9eb78e99eb1101f.tar.gz
gentoo-2-8486046465be75bb4bbafcc0e9eb78e99eb1101f.tar.bz2
gentoo-2-8486046465be75bb4bbafcc0e9eb78e99eb1101f.zip
Add gcc 4.4 patch per bug #269254.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/cln')
-rw-r--r--sci-libs/cln/ChangeLog6
-rw-r--r--sci-libs/cln/cln-1.2.2.ebuild4
-rw-r--r--sci-libs/cln/files/cln-1.2.2-gcc-4.4.patch11
3 files changed, 19 insertions, 2 deletions
diff --git a/sci-libs/cln/ChangeLog b/sci-libs/cln/ChangeLog
index 9ce07cff242a..8d70b87363b1 100644
--- a/sci-libs/cln/ChangeLog
+++ b/sci-libs/cln/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/cln
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/ChangeLog,v 1.33 2009/04/11 15:53:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/ChangeLog,v 1.34 2009/06/29 13:39:55 scarabeus Exp $
+
+ 29 Jun 2009; Tomáš Chvátal <scarabeus@gentoo.org> cln-1.2.2.ebuild,
+ +files/cln-1.2.2-gcc-4.4.patch:
+ Add gcc 4.4 patch per bug #269254.
11 Apr 2009; Raúl Porcel <armin76@gentoo.org> cln-1.2.2.ebuild:
Add ~alpha/~ia64 wrt #260777
diff --git a/sci-libs/cln/cln-1.2.2.ebuild b/sci-libs/cln/cln-1.2.2.ebuild
index b09849eb99d0..aec83f55c48c 100644
--- a/sci-libs/cln/cln-1.2.2.ebuild
+++ b/sci-libs/cln/cln-1.2.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.2.2.ebuild,v 1.11 2009/04/11 15:53:42 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.2.2.ebuild,v 1.12 2009/06/29 13:39:55 scarabeus Exp $
EAPI=2
inherit eutils flag-o-matic
@@ -36,6 +36,8 @@ src_prepare() {
epatch "${FILESDIR}"/${P}-examples.patch
# avoid installing dvi and html docs by default
epatch "${FILESDIR}"/${P}-docs.patch
+ # fix compilation under gcc 4.4
+ epatch "${FILESDIR}"/${P}-gcc-4.4.patch
}
src_configure () {
diff --git a/sci-libs/cln/files/cln-1.2.2-gcc-4.4.patch b/sci-libs/cln/files/cln-1.2.2-gcc-4.4.patch
new file mode 100644
index 000000000000..b874d46c87b4
--- /dev/null
+++ b/sci-libs/cln/files/cln-1.2.2-gcc-4.4.patch
@@ -0,0 +1,11 @@
+--- include/cln/io.h
++++ include/cln/io.h
+@@ -16,6 +16,8 @@
+ #include <iostream>
+ #endif
+
++#include <cstdio>
++
+ namespace cln {
+
+ // compatibility: