summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-06-09 20:52:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-06-09 20:52:31 +0000
commit667410316609563a3de8ee269c04336d88932386 (patch)
tree2307b145a6f45cc9b4622600895f6eb376b81e17 /sci-libs/cminpack
parentFixed to build against linux-3.x, bug #370857 (diff)
downloadgentoo-2-667410316609563a3de8ee269c04336d88932386.tar.gz
gentoo-2-667410316609563a3de8ee269c04336d88932386.tar.bz2
gentoo-2-667410316609563a3de8ee269c04336d88932386.zip
Initial import
(Portage version: 2.1.10/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/cminpack')
-rw-r--r--sci-libs/cminpack/ChangeLog10
-rw-r--r--sci-libs/cminpack/cminpack-1.1.3.ebuild30
-rw-r--r--sci-libs/cminpack/metadata.xml17
3 files changed, 57 insertions, 0 deletions
diff --git a/sci-libs/cminpack/ChangeLog b/sci-libs/cminpack/ChangeLog
new file mode 100644
index 000000000000..1a62328bf344
--- /dev/null
+++ b/sci-libs/cminpack/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-libs/cminpack
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cminpack/ChangeLog,v 1.1 2011/06/09 20:52:31 bicatali Exp $
+
+*cminpack-1.1.3 (09 Jun 2011)
+
+ 09 Jun 2011; Sébastien Fabbro <bicatali@gentoo.org> +cminpack-1.1.3.ebuild,
+ +metadata.xml:
+ Initial import
+
diff --git a/sci-libs/cminpack/cminpack-1.1.3.ebuild b/sci-libs/cminpack/cminpack-1.1.3.ebuild
new file mode 100644
index 000000000000..e2cb8e60aff7
--- /dev/null
+++ b/sci-libs/cminpack/cminpack-1.1.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cminpack/cminpack-1.1.3.ebuild,v 1.1 2011/06/09 20:52:31 bicatali Exp $
+
+EAPI=4
+
+inherit cmake-utils
+
+DESCRIPTION="C implementation of the MINPACK nonlinear optimization library"
+HOMEPAGE="http://devernay.free.fr/hacks/cminpack/cminpack.html"
+SRC_URI="http://devernay.free.fr/hacks/cminpack/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+src_configure() {
+ mycmakeargs+=(
+ -DSHARED_LIBS=ON
+ $(cmake-utils_use_build test examples)
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ dodoc readme*
+ use doc && dohtml -A .txt doc/*
+}
diff --git a/sci-libs/cminpack/metadata.xml b/sci-libs/cminpack/metadata.xml
new file mode 100644
index 000000000000..7f432fd0dc55
--- /dev/null
+++ b/sci-libs/cminpack/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>sci</herd>
+<longdescription lang="en">
+ Minpack includes software for solving nonlinear equations and
+ nonlinear least squares problems. Five algorithmic paths each
+ include a core subroutine and an easy-to-use driver. The algorithms
+ proceed either from an analytic specification of the Jacobian matrix
+ or directly from the problem functions. The paths include facilities
+ for systems of equations with a banded Jacobian matrix, for least
+ squares problems with a large amount of data, and for checking the
+ consistency of the Jacobian matrix with the functions.
+ This is the C re-write of the original fortran minpack
+ implementation.
+</longdescription>
+</pkgmetadata>