summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-03-09 16:45:31 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-03-09 16:45:31 +0000
commit5ede04f72ab36753b1893fb8eac088adeeb6d6a2 (patch)
tree6552c06a15d163f544b8c69764aba2b7df2f6752 /sci-libs/csparse/csparse-2.2.2.ebuild
parentAdd live cvs version (diff)
downloadgentoo-2-5ede04f72ab36753b1893fb8eac088adeeb6d6a2.tar.gz
gentoo-2-5ede04f72ab36753b1893fb8eac088adeeb6d6a2.tar.bz2
gentoo-2-5ede04f72ab36753b1893fb8eac088adeeb6d6a2.zip
Version bump. Fixed collision with cxsparse, rse, fixing bug #246589
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/csparse/csparse-2.2.2.ebuild')
-rw-r--r--sci-libs/csparse/csparse-2.2.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sci-libs/csparse/csparse-2.2.2.ebuild b/sci-libs/csparse/csparse-2.2.2.ebuild
new file mode 100644
index 000000000000..6f45cc77748e
--- /dev/null
+++ b/sci-libs/csparse/csparse-2.2.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/csparse/csparse-2.2.2.ebuild,v 1.1 2009/03/09 16:45:31 bicatali Exp $
+
+EAPI=2
+inherit autotools eutils
+
+MY_PN=CSparse
+DESCRIPTION="Concise sparse matrix package."
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/CSparse"
+SRC_URI="http://www.cise.ufl.edu/research/sparse/${MY_PN}/versions/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+S="${WORKDIR}/${MY_PN}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_configure() {
+ # avoid collision with cxsparse
+ econf --includedir="/usr/include/csparse"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README.txt Doc/ChangeLog || die "dodoc failed"
+}