summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-07-29 22:07:37 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-07-29 22:07:37 +0000
commit8e03e1e4f8adc980fa6dae10b6ff5fc462d6c971 (patch)
treeaf5865b14a1ac710463feb89ca2b4effa30afbed /sci-libs/fftw
parentMarked ~hppa (bug #428248). (diff)
downloadgentoo-2-8e03e1e4f8adc980fa6dae10b6ff5fc462d6c971.tar.gz
gentoo-2-8e03e1e4f8adc980fa6dae10b6ff5fc462d6c971.tar.bz2
gentoo-2-8e03e1e4f8adc980fa6dae10b6ff5fc462d6c971.zip
Add static-libs flag, switch to EAPI 4
(Portage version: 2.2.0_alpha120/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/fftw')
-rw-r--r--sci-libs/fftw/ChangeLog6
-rw-r--r--sci-libs/fftw/fftw-2.1.5-r8.ebuild23
-rw-r--r--sci-libs/fftw/fftw-3.3.2.ebuild143
3 files changed, 16 insertions, 156 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index ee1a67e24d34..59743aae7074 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/fftw
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.126 2012/07/20 20:30:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.127 2012/07/29 22:07:37 bicatali Exp $
+
+ 29 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> -fftw-3.3.2.ebuild,
+ fftw-2.1.5-r8.ebuild:
+ Add static-libs flag, switch to EAPI 4
20 Jul 2012; Sébastien Fabbro <bicatali@gentoo.org> -fftw-2.1.5-r5.ebuild,
-fftw-3.2.2-r1.ebuild, -fftw-3.3-r1.ebuild, -fftw-3.3-r2.ebuild,
diff --git a/sci-libs/fftw/fftw-2.1.5-r8.ebuild b/sci-libs/fftw/fftw-2.1.5-r8.ebuild
index 2b315f642a9e..069df8407842 100644
--- a/sci-libs/fftw/fftw-2.1.5-r8.ebuild
+++ b/sci-libs/fftw/fftw-2.1.5-r8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-2.1.5-r8.ebuild,v 1.11 2011/06/24 10:58:37 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-2.1.5-r8.ebuild,v 1.12 2012/07/29 22:07:37 bicatali Exp $
-EAPI="3"
+EAPI=4
inherit autotools eutils flag-o-matic fortran-2 toolchain-funcs
@@ -17,7 +17,7 @@ RDEPEND="${DEPEND}"
SLOT="2.1"
LICENSE="GPL-2"
-IUSE="doc float fortran mpi openmp threads"
+IUSE="doc float fortran mpi openmp threads static-libs"
KEYWORDS="alpha amd64 ~arm hppa ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
@@ -68,6 +68,7 @@ src_prepare() {
cd "${WORKDIR}"
cp -R ${P} ${P}-double
mv ${P} ${P}-single
+ ln -s ${P}-single ${P}
}
src_configure() {
@@ -77,6 +78,7 @@ src_configure() {
--enable-vec-recurse
$(use_enable fortran)
$(use_enable mpi)
+ $(use_enable static-libs static)
$(use_enable x86 i386-hacks)"
if use openmp; then
myconf="${myconf}
@@ -106,8 +108,7 @@ src_compile() {
for dir in "${S}-single" "${S}-double"
do
einfo "Running compilation in ${dir}"
- cd ${dir}
- emake || die "emake failed in ${dir}"
+ emake -C ${dir}
done
}
@@ -116,8 +117,7 @@ src_test() {
for dir in "${S}-single" "${S}-double"
do
einfo "Running tests in ${dir}"
- cd ${dir}
- emake -j1 check || die "test failed in ${dir}"
+ emake -C ${dir} -j1 check
done
}
@@ -128,13 +128,12 @@ src_install () {
local dir
for dir in "${S}-single" "${S}-double"
do
- cd ${dir}
- emake DESTDIR="${D}" install || die "installation failed in ${dir}"
+ emake DESTDIR="${D}" -C ${dir} install
done
insinto /usr/include
- doins fortran/fftw_f77.i || die "doins failed"
- dodoc AUTHORS ChangeLog NEWS TODO README README.hacks || die "dodoc failed"
+ doins fortran/fftw_f77.i
+ dodoc AUTHORS ChangeLog NEWS TODO README README.hacks
use doc && dohtml doc/*
if use float; then
diff --git a/sci-libs/fftw/fftw-3.3.2.ebuild b/sci-libs/fftw/fftw-3.3.2.ebuild
deleted file mode 100644
index 43d20858c6b8..000000000000
--- a/sci-libs/fftw/fftw-3.3.2.ebuild
+++ /dev/null
@@ -1,143 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.3.2.ebuild,v 1.2 2012/07/20 20:30:20 bicatali Exp $
-
-EAPI=4
-
-#AUTOTOOLS_AUTORECONF=1
-inherit autotools-utils eutils flag-o-matic fortran-2 toolchain-funcs
-
-DESCRIPTION="Fast C library for the Discrete Fourier Transform"
-HOMEPAGE="http://www.fftw.org/"
-SRC_URI="http://www.fftw.org/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="3.0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE="altivec avx doc fortran mpi neon openmp quad sse sse2 static-libs threads zbus"
-
-DEPEND="
- fortran? ( virtual/fortran[openmp?] )
- mpi? ( virtual/mpi )"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
- if use openmp; then
- if [[ $(tc-getCC) == *gcc ]] && ! tc-has-openmp; then
- ewarn "OpenMP is not available in your current selected gcc"
- die "need openmp capable gcc"
- fi
- FORTRAN_NEED_OPENMP=1
- fi
- use fortran && fortran-2_pkg_setup
- FFTW_DIRS="single double longdouble"
- if use quad; then
- if [[ $(tc-getCC) == *gcc ]] && ! version_is_at_least 4.6 $(gcc-version); then
- ewarn "quad precision only available for gcc >= 4.6"
- die "need quad precision capable gcc"
- fi
- FFTW_DIRS+= "quad"
- fi
-}
-
-src_prepare() {
- # fix info file for category directory
- sed -i \
- -e 's/Texinfo documentation system/Libraries/' \
- doc/fftw3.info || die "failed to fix info file"
-
- # why?
- #rm m4/lt* m4/libtool.m4
-}
-
-src_configure() {
- local x
-
- # filter -Os according to docs
- replace-flags -Os -O2
-
- for x in ${FFTW_DIRS}; do
- myeconfargs=(
- $(use_enable fortran)
- $(use_enable zbus mips-zbus-timer)
- $(use_enable threads)
- $(use_enable openmp)
- )
- if [[ $x == single ]]; then
- #altivec, sse, single-paired only work for single
- myeconfargs+=(
- --enable-single
- $(use_enable altivec)
- $(use_enable avx)
- $(use_enable sse)
- $(use_enable mpi)
- $(use_enable neon)
- )
- elif [[ $x == double ]]; then
- myeconfargs+=(
- $(use_enable avx)
- $(use_enable sse2)
- $(use_enable mpi)
- )
- elif [[ $x == longdouble ]]; then
- myeconfargs+=(
- --enable-long-double
- $(use_enable mpi)
- )
- elif [[ $x == quad ]]; then
- #quad does not support mpi
- myeconfargs+=( --enable-quad-precision )
- else
- die "${x} precision not implemented in this ebuild"
- fi
-
- einfo "Configuring for ${x} precision"
- AUTOTOOLS_BUILD_DIR="${S}-${x}" \
- autotools-utils_src_configure
- done
-}
-
-src_compile() {
- for x in ${FFTW_DIRS}; do
- einfo "Compiling for ${x} precision"
- AUTOTOOLS_BUILD_DIR="${S}-${x}" \
- autotools-utils_src_compile
- done
-}
-
-src_test () {
- # We want this to be a reasonably quick test, but that is still hard...
- ewarn "This test series will take 30 minutes on a modern 2.5Ghz machine"
- # Do not increase the number of threads, it will not help your performance
- #local testbase="perl check.pl --nthreads=1 --estimate"
- # ${testbase} -${p}d || die "Failure: $n"
- for x in ${FFTW_DIRS}; do
- cd "${S}-${x}/tests"
- einfo "Testing ${x} precision"
- emake smallcheck
- done
-}
-
-src_install () {
- local u x
- DOCS=( AUTHORS ChangeLog NEWS README TODO COPYRIGHT CONVENTIONS )
- HTML_DOCS=( doc/html/ )
- for x in ${FFTW_DIRS}; do
- AUTOTOOLS_BUILD_DIR="${S}-${x}" \
- autotools-utils_src_install
- done
-
- if use doc; then
- dodoc doc/*.pdf
- insinto /usr/share/doc/${PF}/faq
- doins -r doc/FAQ/fftw-faq.html/*
- else
- rm -r "${ED}"/usr/share/doc/${PF}/html
- fi
-
- for x in "${ED}"/usr/lib*/pkgconfig/*.pc; do
- for u in $(usev mpi) $(usev threads) $(usex openmp omp ""); do
- sed -e "s|-lfftw3[flq]\?|&_$u &|" "$x" > "${x%.pc}_$u.pc" || die
- done
- done
-}