summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-04-30 14:59:22 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-04-30 14:59:22 +0000
commitb1f44b22cb603d8b5661506e6ad5118549e5c6af (patch)
treeca62e31e797bf4fd2b1feb9cc4f7d6ae46859b3c /sci-libs/galib/galib-2.4.6.ebuild
parentBlue skin updated (diff)
downloadgentoo-2-b1f44b22cb603d8b5661506e6ad5118549e5c6af.tar.gz
gentoo-2-b1f44b22cb603d8b5661506e6ad5118549e5c6af.tar.bz2
gentoo-2-b1f44b22cb603d8b5661506e6ad5118549e5c6af.zip
Patched makefile to also install crucial std_stream.h header into include directory. This fixes bug #131629.
(Portage version: 2.1_pre9-r4)
Diffstat (limited to 'sci-libs/galib/galib-2.4.6.ebuild')
-rw-r--r--sci-libs/galib/galib-2.4.6.ebuild10
1 files changed, 8 insertions, 2 deletions
diff --git a/sci-libs/galib/galib-2.4.6.ebuild b/sci-libs/galib/galib-2.4.6.ebuild
index beb8a90bb510..d1230875683e 100644
--- a/sci-libs/galib/galib-2.4.6.ebuild
+++ b/sci-libs/galib/galib-2.4.6.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/galib-2.4.6.ebuild,v 1.2 2005/09/21 15:30:17 phosphan Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/galib/galib-2.4.6.ebuild,v 1.3 2006/04/30 14:59:22 markusle Exp $
inherit eutils
@@ -18,6 +18,12 @@ DEPEND=""
S="${WORKDIR}/galib${MYPV}"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
src_compile() {
make CXXFLAGS="${CXXFLAGS}" || die "make failed"
}