summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-13 16:42:19 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-13 16:42:19 +0000
commit7fa22321df4048374f3880d9cd95832832f1f76b (patch)
tree947d3cf7e52b8957fe975c363ba48addf4650a43 /sci-libs/gaul-devel
parentMarked ~x86-linux, ~amd64-linux (bug #303115) and ~ppc-macos (diff)
downloadgentoo-2-7fa22321df4048374f3880d9cd95832832f1f76b.tar.gz
gentoo-2-7fa22321df4048374f3880d9cd95832832f1f76b.tar.bz2
gentoo-2-7fa22321df4048374f3880d9cd95832832f1f76b.zip
Fix for as-needed, thanks Kacper Kowalik for providing the patch #248357
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gaul-devel')
-rw-r--r--sci-libs/gaul-devel/ChangeLog10
-rw-r--r--sci-libs/gaul-devel/files/gaul-devel-0.1849-as-needed.patch26
-rw-r--r--sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild43
3 files changed, 77 insertions, 2 deletions
diff --git a/sci-libs/gaul-devel/ChangeLog b/sci-libs/gaul-devel/ChangeLog
index 2d305dc978d1..4506bf3d7df0 100644
--- a/sci-libs/gaul-devel/ChangeLog
+++ b/sci-libs/gaul-devel/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gaul-devel
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gaul-devel/ChangeLog,v 1.9 2009/09/23 20:06:52 patrick Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gaul-devel/ChangeLog,v 1.10 2010/02/13 16:42:19 jlec Exp $
+
+*gaul-devel-0.1849-r2 (13 Feb 2010)
+
+ 13 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +gaul-devel-0.1849-r2.ebuild, +files/gaul-devel-0.1849-as-needed.patch:
+ Fix for as-needed, thanks Kacper Kowalik for providing the patch #248357
23 Sep 2009; Patrick Lauer <patrick@gentoo.org>
gaul-devel-0.1849-r1.ebuild:
diff --git a/sci-libs/gaul-devel/files/gaul-devel-0.1849-as-needed.patch b/sci-libs/gaul-devel/files/gaul-devel-0.1849-as-needed.patch
new file mode 100644
index 000000000000..aadea97e6929
--- /dev/null
+++ b/sci-libs/gaul-devel/files/gaul-devel-0.1849-as-needed.patch
@@ -0,0 +1,26 @@
+--- gaul-devel-0.1849-0.orig/src/Makefile.am 2005-04-20 16:25:27.000000000 +0200
++++ gaul-devel-0.1849-0/src/Makefile.am 2010-02-13 16:57:55.051370268 +0100
+@@ -83,7 +83,7 @@
+ gaul/ga_tabu.h \
+ gaul.h
+
+-libgaul_la_LIBFLAGS = -lm
++libgaul_la_LIBADD = $(top_srcdir)/util/libgaul_util.la -lm
+ libgaul_la_LDFLAGS = -version-info ${GA_MAJOR_VERSION}:${GA_LT_MINOR_VERSION}:0
+
+
+--- gaul-devel-0.1849-0.orig/util/Makefile.am 2005-04-20 16:25:53.000000000 +0200
++++ gaul-devel-0.1849-0/util/Makefile.am 2010-02-13 17:00:00.128370192 +0100
+@@ -64,10 +64,10 @@
+ gaul/table_util.h \
+ gaul/timer_util.h
+
+-libgaul_util_a_LIBFLAGS =
++libgaul_util_la_LIBADD = -lm
+ libgaul_util_la_LDFLAGS = -version-info ${GA_MAJOR_VERSION}:${GA_LT_MINOR_VERSION}:0
+
+-libnn_util_a_LIBFLAGS =
++libnn_util_la_LIBADD = -lm
+ libnn_util_la_LDFLAGS = -version-info ${GA_MAJOR_VERSION}:${GA_LT_MINOR_VERSION}:0
+
+ # Regenerate gaul_config.h with config.status whenever gaul_config.h.in changes.
diff --git a/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild b/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild
new file mode 100644
index 000000000000..f7b10c0bb48d
--- /dev/null
+++ b/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gaul-devel/gaul-devel-0.1849-r2.ebuild,v 1.1 2010/02/13 16:42:19 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+DESCRIPTION="Genetic Algorithm Utility Library"
+HOMEPAGE="http://GAUL.sourceforge.net/"
+SRC_URI="mirror://sourceforge/gaul/${P}-0.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="debug slang"
+
+DEPEND=">=sys-apps/sed-4
+ slang? ( >=sys-libs/slang-2.1.3 )"
+
+S=${WORKDIR}/${P}-0
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-slang2-error.patch
+ epatch "${FILESDIR}"/${P}-as-needed.patch
+ eautoreconf
+}
+
+src_configure() {
+ local myconf
+ use slang || myconf="--enable-slang=no"
+ if use debug ; then
+ myconf="${myconf} --enable-debug=yes --enable-memory-debug=yes"
+ else
+ myconf="${myconf} --enable-g=no"
+ fi
+ econf ${myconf}
+}
+
+src_install() {
+ emake -j1 DESTDIR="${D}" install || die
+ dodoc README || die
+}