summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-28 14:45:17 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-28 14:45:17 +0000
commit03f383e09ae6ff088ba826e70b513c405b6f1504 (patch)
treed713a47a33f542e379ec7cf769009756e64b8915 /sci-libs/geos/geos-3.1.1.ebuild
parentRemove vulnerable versions, bug 271685 (diff)
downloadgentoo-2-03f383e09ae6ff088ba826e70b513c405b6f1504.tar.gz
gentoo-2-03f383e09ae6ff088ba826e70b513c405b6f1504.tar.bz2
gentoo-2-03f383e09ae6ff088ba826e70b513c405b6f1504.zip
Version bump also fixed license in previous versions.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/geos/geos-3.1.1.ebuild')
-rw-r--r--sci-libs/geos/geos-3.1.1.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sci-libs/geos/geos-3.1.1.ebuild b/sci-libs/geos/geos-3.1.1.ebuild
new file mode 100644
index 000000000000..0dade4e33419
--- /dev/null
+++ b/sci-libs/geos/geos-3.1.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/geos/geos-3.1.1.ebuild,v 1.1 2009/07/28 14:45:16 bicatali Exp $
+
+EAPI=2
+
+DESCRIPTION="Geometry engine library for Geographic Information Systems"
+HOMEPAGE="http://geos.refractions.net"
+SRC_URI="http://download.osgeo.org/geos/${P}.tar.bz2"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc python ruby"
+
+RDEPEND="ruby? ( virtual/ruby )
+ python? ( virtual/python )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )
+ ruby? ( dev-lang/swig )
+ python? ( dev-lang/swig )"
+
+src_configure() {
+ econf $(use_enable python) $(use_enable ruby)
+}
+
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ cd "${S}/doc"
+ emake doxygen-html || die "doc generation failed"
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS NEWS README TODO
+ if use doc; then
+ cd "${S}/doc"
+ dohtml -r doxygen_docs/html/* || die
+ fi
+}