summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-10-10 13:22:40 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-10-10 13:22:40 +0000
commit7405e15451cfa6a6e1de022a4e81d05cbd44210f (patch)
tree55f0c6cd2708a7abccb0d1c9efeafad58cd4877f /sci-libs/gsl/gsl-1.9-r1.ebuild
parentRemoved old versions, workaround for eselect bug #189942, cleanups. (diff)
downloadgentoo-2-7405e15451cfa6a6e1de022a4e81d05cbd44210f.tar.gz
gentoo-2-7405e15451cfa6a6e1de022a4e81d05cbd44210f.tar.bz2
gentoo-2-7405e15451cfa6a6e1de022a4e81d05cbd44210f.zip
Version bump, removed old versions, added work around eselect bug #189942. Added new cblas use flag to allow use of external cblas library.
(Portage version: 2.1.3.12)
Diffstat (limited to 'sci-libs/gsl/gsl-1.9-r1.ebuild')
-rw-r--r--sci-libs/gsl/gsl-1.9-r1.ebuild21
1 files changed, 16 insertions, 5 deletions
diff --git a/sci-libs/gsl/gsl-1.9-r1.ebuild b/sci-libs/gsl/gsl-1.9-r1.ebuild
index 45e3b95388b5..33786a689b74 100644
--- a/sci-libs/gsl/gsl-1.9-r1.ebuild
+++ b/sci-libs/gsl/gsl-1.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.9-r1.ebuild,v 1.1 2007/08/21 17:53:34 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.9-r1.ebuild,v 1.2 2007/10/10 13:22:40 bicatali Exp $
inherit eutils flag-o-matic toolchain-funcs autotools
@@ -52,11 +52,22 @@ src_install() {
|| die "sed cblas.pc failed"
insinto /usr/$(get_libdir)/blas/gsl
doins cblas.pc || die "installing cblas.pc failed"
- eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas.gsl gsl
+ ESELECT_PROF=gsl
+ eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas.gsl ${ESELECT_PROF}
}
pkg_postinst() {
- [[ -z "$(eselect cblas show)" ]] && eselect cblas set gsl
- elog "To use CBLAS gsl implementation, you have to issue (as root):"
- elog "\t eselect cblas set gsl"
+ local p=cblas
+ local current_lib=$(eselect ${p} show | cut -d' ' -f2)
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ # work around eselect bug #189942
+ local configfile="${ROOT}"/etc/env.d/${p}/lib/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_lib}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
}