summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-03-31 09:51:36 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-03-31 09:51:36 +0000
commit075a406fc09dbb6eb8679d809f14429918d1c3a9 (patch)
treec8b507fb84f558dcc74a4a2062152f52659c30b8 /sci-libs/gsl
parentRemove, bug #205482 (diff)
downloadgentoo-2-075a406fc09dbb6eb8679d809f14429918d1c3a9.tar.gz
gentoo-2-075a406fc09dbb6eb8679d809f14429918d1c3a9.tar.bz2
gentoo-2-075a406fc09dbb6eb8679d809f14429918d1c3a9.zip
Version bump. Removed icc test since it now compiles and tests are fine
(Portage version: 2.1.4.4)
Diffstat (limited to 'sci-libs/gsl')
-rw-r--r--sci-libs/gsl/ChangeLog8
-rw-r--r--sci-libs/gsl/gsl-1.11.ebuild77
-rw-r--r--sci-libs/gsl/gsl-1.8.ebuild40
3 files changed, 84 insertions, 41 deletions
diff --git a/sci-libs/gsl/ChangeLog b/sci-libs/gsl/ChangeLog
index 021e5f5d5ae9..05bc073bd7bd 100644
--- a/sci-libs/gsl/ChangeLog
+++ b/sci-libs/gsl/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gsl
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.42 2008/01/09 16:15:02 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.43 2008/03/31 09:51:36 bicatali Exp $
+
+*gsl-1.11 (31 Mar 2008)
+
+ 31 Mar 2008; Sébastien Fabbro <bicatali@gentoo.org> -gsl-1.8.ebuild,
+ +gsl-1.11.ebuild:
+ Version bump. Removed icc test since it now compiles and tests are fine
09 Jan 2008; Jeroen Roovers <jer@gentoo.org> gsl-1.9-r1.ebuild,
gsl-1.10.ebuild:
diff --git a/sci-libs/gsl/gsl-1.11.ebuild b/sci-libs/gsl/gsl-1.11.ebuild
new file mode 100644
index 000000000000..dd3e28d814ad
--- /dev/null
+++ b/sci-libs/gsl/gsl-1.11.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.11.ebuild,v 1.1 2008/03/31 09:51:36 bicatali Exp $
+
+inherit eutils flag-o-matic toolchain-funcs autotools
+
+DESCRIPTION="The GNU Scientific Library"
+HOMEPAGE="http://www.gnu.org/software/gsl/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="cblas"
+
+RDEPEND="app-admin/eselect-cblas
+ cblas? ( virtual/cblas )"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+#pkg_setup() {
+# # icc-10.0.026 did not pass rng tests (last check: gsl-1.10)
+# if [[ $(tc-getCC) == icc ]]; then
+# eerror "icc known to fail tests. Revert to safer compiler and re-emerge."
+# die "gsl does not work when compiled with icc"
+# fi
+#}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/gsl-cblas.patch
+ eautoreconf
+}
+
+src_compile() {
+ # could someone check if they are still needed?
+ replace-cpu-flags k6 k6-2 k6-3 i586
+ filter-flags -ffast-math
+ local myconf=
+ use cblas && myconf="--with-cblas=$(pkg-config --libs cblas)"
+ econf "${myconf}"|| die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed."
+ dodoc AUTHORS BUGS ChangeLog NEWS README SUPPORT \
+ THANKS TODO || die "dodoc failed"
+
+ # take care of pkgconfig file for cblas implementation.
+ sed -e "s/@LIBDIR@/$(get_libdir)/" \
+ -e "s/@PV@/${PV}/" \
+ "${FILESDIR}"/cblas.pc.in > cblas.pc \
+ || die "sed cblas.pc failed"
+ insinto /usr/$(get_libdir)/blas/gsl
+ doins cblas.pc || die "installing cblas.pc failed"
+ ESELECT_PROF=gsl
+ eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas.gsl ${ESELECT_PROF}
+}
+
+pkg_postinst() {
+ local p=cblas
+ local current_lib=$(eselect ${p} show | cut -d' ' -f2)
+ if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
+ # work around eselect bug #189942
+ local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
+ [[ -e ${configfile} ]] && rm -f ${configfile}
+ eselect ${p} set ${ESELECT_PROF}
+ elog "${p} has been eselected to ${ESELECT_PROF}"
+ else
+ elog "Current eselected ${p} is ${current_lib}"
+ elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
+ elog "\t eselect ${p} set ${ESELECT_PROF}"
+ fi
+}
diff --git a/sci-libs/gsl/gsl-1.8.ebuild b/sci-libs/gsl/gsl-1.8.ebuild
deleted file mode 100644
index d45ff9985f66..000000000000
--- a/sci-libs/gsl/gsl-1.8.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.8.ebuild,v 1.13 2007/08/25 14:28:25 vapier Exp $
-
-inherit eutils flag-o-matic autotools
-
-DESCRIPTION="The GNU Scientific Library"
-HOMEPAGE="http://www.gnu.org/software/gsl/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm hppa ia64 ppc ppc64 sh sparc x86"
-IUSE=""
-
-DEPEND=""
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/gsl-1.6-deps.diff
- eautoreconf
-}
-
-src_compile() {
- replace-cpu-flags k6 k6-2 k6-3 i586
- filter-flags -ffast-math
-
- econf --disable-libtool-lock || die
- emake || die 'emake failed.'
-}
-
-src_test() {
- make check || die 'make check failed.'
-}
-
-src_install() {
- einstall || die 'einstall failed.'
- dodoc AUTHORS BUGS ChangeLog INSTALL NEWS README SUPPORT THANKS TODO
-}