summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-10-11 16:55:45 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-10-11 16:55:45 +0000
commit0ceb6e8d8b39fbd9ad8f1e6638751a1c087cc770 (patch)
tree086e9e637dff3e7ccb8c5e0ef0933b7f83a888a9 /sci-libs/gsl
parentEnable amazon USE flag by default in amarok wrt #134493. (diff)
downloadgentoo-2-0ceb6e8d8b39fbd9ad8f1e6638751a1c087cc770.tar.gz
gentoo-2-0ceb6e8d8b39fbd9ad8f1e6638751a1c087cc770.tar.bz2
gentoo-2-0ceb6e8d8b39fbd9ad8f1e6638751a1c087cc770.zip
fixed lib->get_libdir for eselect bug workaround
(Portage version: 2.1.3.12)
Diffstat (limited to 'sci-libs/gsl')
-rw-r--r--sci-libs/gsl/ChangeLog6
-rw-r--r--sci-libs/gsl/gsl-1.10.ebuild4
-rw-r--r--sci-libs/gsl/gsl-1.9-r1.ebuild4
3 files changed, 9 insertions, 5 deletions
diff --git a/sci-libs/gsl/ChangeLog b/sci-libs/gsl/ChangeLog
index 6e7743e872ff..82d5ca373089 100644
--- a/sci-libs/gsl/ChangeLog
+++ b/sci-libs/gsl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/gsl
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.39 2007/10/10 13:22:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.40 2007/10/11 16:55:45 bicatali Exp $
+
+ 11 Oct 2007; Sébastien Fabbro <bicatali@gentoo.org> gsl-1.9-r1.ebuild,
+ gsl-1.10.ebuild:
+ fixed lib->get_libdir for eselect bug workaround
*gsl-1.10 (10 Oct 2007)
diff --git a/sci-libs/gsl/gsl-1.10.ebuild b/sci-libs/gsl/gsl-1.10.ebuild
index a646b0593c73..f2c320aba1df 100644
--- a/sci-libs/gsl/gsl-1.10.ebuild
+++ b/sci-libs/gsl/gsl-1.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.10.ebuild,v 1.1 2007/10/10 13:22:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.10.ebuild,v 1.2 2007/10/11 16:55:45 bicatali Exp $
inherit eutils flag-o-matic toolchain-funcs autotools
@@ -65,7 +65,7 @@ pkg_postinst() {
local current_lib=$(eselect ${p} show | cut -d' ' -f2)
if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
# work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/lib/config
+ local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
[[ -e ${configfile} ]] && rm -f ${configfile}
eselect ${p} set ${ESELECT_PROF}
elog "${p} has been eselected to ${ESELECT_PROF}"
diff --git a/sci-libs/gsl/gsl-1.9-r1.ebuild b/sci-libs/gsl/gsl-1.9-r1.ebuild
index 33786a689b74..396c2d7606c9 100644
--- a/sci-libs/gsl/gsl-1.9-r1.ebuild
+++ b/sci-libs/gsl/gsl-1.9-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.9-r1.ebuild,v 1.2 2007/10/10 13:22:40 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.9-r1.ebuild,v 1.3 2007/10/11 16:55:45 bicatali Exp $
inherit eutils flag-o-matic toolchain-funcs autotools
@@ -61,7 +61,7 @@ pkg_postinst() {
local current_lib=$(eselect ${p} show | cut -d' ' -f2)
if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
# work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/lib/config
+ local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
[[ -e ${configfile} ]] && rm -f ${configfile}
eselect ${p} set ${ESELECT_PROF}
elog "${p} has been eselected to ${ESELECT_PROF}"