summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-06-23 08:36:29 +0000
committerJustin Lecher <jlec@gentoo.org>2010-06-23 08:36:29 +0000
commit757c15dbe7497d89a4c8bf01f5e0349e8b4450c6 (patch)
treebd7381114ce2d227f17c948ac30b7cfc6d49430b /sci-libs/gsl
parentAdd missing dependencies wrt bug #324287 (diff)
downloadgentoo-2-757c15dbe7497d89a4c8bf01f5e0349e8b4450c6.tar.gz
gentoo-2-757c15dbe7497d89a4c8bf01f5e0349e8b4450c6.tar.bz2
gentoo-2-757c15dbe7497d89a4c8bf01f5e0349e8b4450c6.zip
Cleaned old versions
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gsl')
-rw-r--r--sci-libs/gsl/gsl-1.12.ebuild79
-rw-r--r--sci-libs/gsl/gsl-1.13.ebuild77
-rw-r--r--sci-libs/gsl/gsl-1.9-r1.ebuild73
3 files changed, 0 insertions, 229 deletions
diff --git a/sci-libs/gsl/gsl-1.12.ebuild b/sci-libs/gsl/gsl-1.12.ebuild
deleted file mode 100644
index 658879d792fb..000000000000
--- a/sci-libs/gsl/gsl-1.12.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.12.ebuild,v 1.8 2009/04/23 13:23:11 armin76 Exp $
-
-EAPI=2
-inherit eutils flag-o-matic autotools
-
-DESCRIPTION="The GNU Scientific Library"
-HOMEPAGE="http://www.gnu.org/software/gsl/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="cblas"
-
-RDEPEND="cblas? ( virtual/cblas )"
-DEPEND="${RDEPEND}
- app-admin/eselect-cblas
- dev-util/pkgconfig"
-
-pkg_setup() {
- ESELECT_PROF="gsl"
- # prevent to use external cblas from a previously installed gsl
- local current_lib=$(eselect cblas show | cut -d' ' -f2)
- if use cblas && [[ ${current_lib} == gsl ]]; then
- ewarn "USE flag cblas is set: linking gsl with an external cblas."
- ewarn "However the current selected external cblas is gsl."
- ewarn "Please install and/or eselect another cblas"
- die "Circular gsl dependency"
- fi
-}
-
-src_prepare() {
- filter-flags -ffast-math
- replace-cpu-flags k6 k6-2 k6-3 i586
- epatch "${FILESDIR}"/${P}-cblas.patch
- eautoreconf
-}
-
-src_configure() {
- if use cblas; then
- export CBLAS_LIBS="$(pkg-config --libs cblas)"
- export CBLAS_CFLAGS="$(pkg-config --cflags cblas)"
- fi
- econf $(use_with cblas)
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed."
- dodoc AUTHORS BUGS ChangeLog NEWS README SUPPORT \
- THANKS TODO || die "dodoc failed"
-
- # take care of pkgconfig file for cblas implementation.
- sed -e "s/@LIBDIR@/$(get_libdir)/" \
- -e "s/@PV@/${PV}/" \
- "${FILESDIR}"/cblas.pc.in > cblas.pc \
- || die "sed cblas.pc failed"
- insinto /usr/$(get_libdir)/blas/gsl
- doins cblas.pc || die "installing cblas.pc failed"
- eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas.gsl \
- ${ESELECT_PROF}
-}
-
-pkg_postinst() {
- local p=cblas
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
-}
diff --git a/sci-libs/gsl/gsl-1.13.ebuild b/sci-libs/gsl/gsl-1.13.ebuild
deleted file mode 100644
index 7574e6e4289c..000000000000
--- a/sci-libs/gsl/gsl-1.13.ebuild
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.13.ebuild,v 1.1 2009/09/17 22:13:22 bicatali Exp $
-
-EAPI=2
-inherit eutils flag-o-matic autotools
-
-DESCRIPTION="The GNU Scientific Library"
-HOMEPAGE="http://www.gnu.org/software/gsl/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-3"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="cblas"
-
-RDEPEND="cblas? ( virtual/cblas )"
-DEPEND="${RDEPEND}
- app-admin/eselect-cblas
- dev-util/pkgconfig"
-
-pkg_setup() {
- ESELECT_PROF="gsl"
- # prevent to use external cblas from a previously installed gsl
- local current_lib=$(eselect cblas show | cut -d' ' -f2)
- if use cblas && [[ ${current_lib} == gsl ]]; then
- ewarn "USE flag cblas is set: linking gsl with an external cblas."
- ewarn "However the current selected external cblas is gsl."
- ewarn "Please install and/or eselect another cblas"
- die "Circular gsl dependency"
- fi
-}
-
-src_prepare() {
- filter-flags -ffast-math
- epatch "${FILESDIR}"/${P}-cblas.patch
- eautoreconf
-}
-
-src_configure() {
- if use cblas; then
- export CBLAS_LIBS="$(pkg-config --libs cblas)"
- export CBLAS_CFLAGS="$(pkg-config --cflags cblas)"
- fi
- econf $(use_with cblas)
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed."
- dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
-
- # take care of pkgconfig file for cblas implementation.
- sed -e "s/@LIBDIR@/$(get_libdir)/" \
- -e "s/@PV@/${PV}/" \
- "${FILESDIR}"/cblas.pc.in > cblas.pc \
- || die "sed cblas.pc failed"
- insinto /usr/$(get_libdir)/blas/gsl
- doins cblas.pc || die "installing cblas.pc failed"
- eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas.gsl \
- ${ESELECT_PROF}
-}
-
-pkg_postinst() {
- local p=cblas
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
-}
diff --git a/sci-libs/gsl/gsl-1.9-r1.ebuild b/sci-libs/gsl/gsl-1.9-r1.ebuild
deleted file mode 100644
index 32dd7aa07ac3..000000000000
--- a/sci-libs/gsl/gsl-1.9-r1.ebuild
+++ /dev/null
@@ -1,73 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.9-r1.ebuild,v 1.4 2008/01/09 16:15:02 jer Exp $
-
-inherit eutils flag-o-matic toolchain-funcs autotools
-
-DESCRIPTION="The GNU Scientific Library"
-HOMEPAGE="http://www.gnu.org/software/gsl/"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 ~hppa ~ia64 ~mips ppc ppc64 sparc x86 ~x86-fbsd"
-IUSE=""
-
-RDEPEND="app-admin/eselect-cblas"
-DEPEND="${RDEPEND}"
-
-pkg_setup() {
- # icc-10.0.025 did not pass some tests
- if [[ $(tc-getCC) == icc ]]; then
- eerror "icc known to fail tests. Revert to safer gcc and re-emerge."
- die "gsl does not work when compiled with icc"
- fi
-}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- # fix for as-needed
- epatch "${FILESDIR}"/gsl-1.6-deps.diff
- eautoreconf
-}
-
-src_compile() {
- replace-cpu-flags k6 k6-2 k6-3 i586
- filter-flags -ffast-math
-
- econf || die "econf failed"
- emake || die 'emake failed.'
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed."
- dodoc AUTHORS BUGS ChangeLog NEWS README SUPPORT \
- THANKS TODO || die "dodoc failed"
-
- # take care of pkgconfig file for cblas implementation.
- sed -e "s/@LIBDIR@/$(get_libdir)/" \
- -e "s/@PV@/${PV}/" \
- "${FILESDIR}"/cblas.pc.in > cblas.pc \
- || die "sed cblas.pc failed"
- insinto /usr/$(get_libdir)/blas/gsl
- doins cblas.pc || die "installing cblas.pc failed"
- ESELECT_PROF=gsl
- eselect cblas add $(get_libdir) "${FILESDIR}"/eselect.cblas.gsl ${ESELECT_PROF}
-}
-
-pkg_postinst() {
- local p=cblas
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
-}