summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-21 12:21:23 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-21 12:21:23 +0000
commit81e109030a4cbd13c069182c3084ba27edf2f552 (patch)
tree6b24098aca396d683d0d62a6e320968c0a266bd4 /sci-libs/gts
parentNew snapshot, fixes bug #320811 (diff)
downloadgentoo-2-81e109030a4cbd13c069182c3084ba27edf2f552.tar.gz
gentoo-2-81e109030a4cbd13c069182c3084ba27edf2f552.tar.bz2
gentoo-2-81e109030a4cbd13c069182c3084ba27edf2f552.zip
Version Bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/gts')
-rw-r--r--sci-libs/gts/ChangeLog8
-rw-r--r--sci-libs/gts/files/gts-20100321-examples.patch24
-rw-r--r--sci-libs/gts/gts-20100321.ebuild50
3 files changed, 81 insertions, 1 deletions
diff --git a/sci-libs/gts/ChangeLog b/sci-libs/gts/ChangeLog
index 710d40fd5c65..3e8e27e8aba5 100644
--- a/sci-libs/gts/ChangeLog
+++ b/sci-libs/gts/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/gts
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/ChangeLog,v 1.10 2010/01/15 07:14:10 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/ChangeLog,v 1.11 2010/05/21 12:21:23 jlec Exp $
+
+*gts-20100321 (21 May 2010)
+
+ 21 May 2010; Justin Lecher <jlec@gentoo.org> +gts-20100321.ebuild,
+ +files/gts-20100321-examples.patch:
+ Version Bump
*gts-20090909 (15 Jan 2010)
diff --git a/sci-libs/gts/files/gts-20100321-examples.patch b/sci-libs/gts/files/gts-20100321-examples.patch
new file mode 100644
index 000000000000..b418bbd1ed4f
--- /dev/null
+++ b/sci-libs/gts/files/gts-20100321-examples.patch
@@ -0,0 +1,24 @@
+diff --git a/examples/Makefile.am b/examples/Makefile.am
+index f03f215..8e9ca63 100644
+--- a/examples/Makefile.am
++++ b/examples/Makefile.am
+@@ -9,6 +9,8 @@ EXTRA_PROGRAMS = happrox
+
+ happrox_LDADD = $(LDADD) -lnetpbm
+
++happrox_CPPFLAGS = -I/usr/include/netpbm
++
+ if HAS_NETPBM
+ NETPBM_EXTRA = happrox
+ endif
+@@ -16,9 +18,7 @@ endif
+ bin_PROGRAMS = \
+ transform \
+ delaunay \
+- $(NETPBM_EXTRA)
+-
+-noinst_PROGRAMS = \
++ $(NETPBM_EXTRA) \
+ set \
+ volume \
+ cleanup \
diff --git a/sci-libs/gts/gts-20100321.ebuild b/sci-libs/gts/gts-20100321.ebuild
new file mode 100644
index 000000000000..606676135324
--- /dev/null
+++ b/sci-libs/gts/gts-20100321.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gts/gts-20100321.ebuild,v 1.1 2010/05/21 12:21:23 jlec Exp $
+
+EAPI=2
+inherit eutils autotools
+
+DESCRIPTION="GNU Triangulated Surface Library"
+LICENSE="LGPL-2"
+HOMEPAGE="http://gts.sourceforge.net/"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc examples test"
+
+RDEPEND="
+ >=dev-libs/glib-2.4.0
+ !dev-vcs/rcs
+ !sys-apps/coreutil
+ !<=sci-chemistry/ccp4-apps-6.1.3-r2"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ test? ( media-libs/netpbm )"
+
+# tests are failing
+RESTRICT="test"
+
+S="${WORKDIR}"/${PN}-snapshot-100321
+
+src_prepare() {
+ chmod +x test/*/*.sh
+ epatch "${FILESDIR}"/${P}-examples.patch
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO || die
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c || die "Failed to install examples"
+ fi
+
+ # install additional docs
+ if use doc; then
+ dohtml doc/html/* || die
+ fi
+}