summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2014-11-25 15:26:17 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2014-11-25 15:26:17 +0000
commitb29627c302cc60592b46cf31440e3d20c5d975f0 (patch)
tree494f337513543a012f5aba60fc32df9a0d0e212e /sci-libs/hdf5
parentSupport python 3.4 (diff)
downloadgentoo-2-b29627c302cc60592b46cf31440e3d20c5d975f0.tar.gz
gentoo-2-b29627c302cc60592b46cf31440e3d20c5d975f0.tar.bz2
gentoo-2-b29627c302cc60592b46cf31440e3d20c5d975f0.zip
Version bump, drop old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0x5D21B852895192F9)
Diffstat (limited to 'sci-libs/hdf5')
-rw-r--r--sci-libs/hdf5/ChangeLog9
-rw-r--r--sci-libs/hdf5/files/hdf5-1.8.14-implicits.patch (renamed from sci-libs/hdf5/files/hdf5-1.8.11-implicits.patch)50
-rw-r--r--sci-libs/hdf5/hdf5-1.8.11.ebuild108
-rw-r--r--sci-libs/hdf5/hdf5-1.8.14.ebuild (renamed from sci-libs/hdf5/hdf5-1.8.12.ebuild)73
4 files changed, 73 insertions, 167 deletions
diff --git a/sci-libs/hdf5/ChangeLog b/sci-libs/hdf5/ChangeLog
index f13d1019c107..f1f83e4b6171 100644
--- a/sci-libs/hdf5/ChangeLog
+++ b/sci-libs/hdf5/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/hdf5
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.118 2014/06/04 16:05:55 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/ChangeLog,v 1.119 2014/11/25 15:26:17 xarthisius Exp $
+
+*hdf5-1.8.14 (25 Nov 2014)
+
+ 25 Nov 2014; Kacper Kowalik <xarthisius@gentoo.org>
+ +files/hdf5-1.8.14-implicits.patch, +hdf5-1.8.14.ebuild,
+ -files/hdf5-1.8.11-implicits.patch, -hdf5-1.8.11.ebuild, -hdf5-1.8.12.ebuild:
+ Version bump, drop old
*hdf5-1.8.13 (04 Jun 2014)
diff --git a/sci-libs/hdf5/files/hdf5-1.8.11-implicits.patch b/sci-libs/hdf5/files/hdf5-1.8.14-implicits.patch
index 478557013596..4ee6e83d9f2f 100644
--- a/sci-libs/hdf5/files/hdf5-1.8.11-implicits.patch
+++ b/sci-libs/hdf5/files/hdf5-1.8.14-implicits.patch
@@ -1,13 +1,35 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1522,6 +1522,9 @@ case "$host_cpu-$host_vendor-$host_os" in
+ ## however, we do not do this since it breaks the big test on some
+ ## older platforms.
+ AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
++
++ ## _GNU_SOURCE is needed for vasprintf
++ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
+ ;;
+ esac
+
--- a/hl/src/H5LTanalyze.c
+++ b/hl/src/H5LTanalyze.c
-@@ -49,6 +49,7 @@
- #define YY_FLEX_MINOR_VERSION 5
-
- #include <stdio.h>
-+#include "H5public.h"
- #ifdef H5_HAVE_UNISTD_H
- #include <unistd.h>
- #endif
+@@ -40,6 +40,7 @@
+ #include <string.h>
+ #include <errno.h>
+ #include <stdlib.h>
++#include <unistd.h>
+
+ /* end standard C headers. */
+
+--- a/hl/src/H5LTanalyze.l
++++ b/hl/src/H5LTanalyze.l
+@@ -16,6 +16,7 @@
+ %{
+ #include <stdlib.h>
+ #include <string.h>
++#include <unistd.h>
+ #include <hdf5.h>
+ #include "H5LTparse.h"
+
--- a/test/cache_common.h
+++ b/test/cache_common.h
@@ -702,5 +702,8 @@ void validate_mdc_config(hid_t file_id,
@@ -31,15 +53,3 @@
static void coll_write_test(int chunk_factor);
---- a/configure.ac
-+++ b/configure.ac
-@@ -1504,6 +1504,9 @@ case "$host_cpu-$host_vendor-$host_os" in
- ## however, we do not do this since it breaks the big test on some
- ## older platforms.
- AM_CPPFLAGS="-D_BSD_SOURCE $AM_CPPFLAGS"
-+
-+ ## _GNU_SOURCE is needed for vasprintf
-+ AM_CPPFLAGS="-D_GNU_SOURCE $AM_CPPFLAGS"
- ;;
- esac
-
diff --git a/sci-libs/hdf5/hdf5-1.8.11.ebuild b/sci-libs/hdf5/hdf5-1.8.11.ebuild
deleted file mode 100644
index 306c29db4aae..000000000000
--- a/sci-libs/hdf5/hdf5-1.8.11.ebuild
+++ /dev/null
@@ -1,108 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.11.ebuild,v 1.1 2013/09/18 10:11:32 xarthisius Exp $
-
-EAPI=5
-
-FORTRAN_NEEDED=fortran
-MY_P=${PN}-${PV/_p/-patch}
-
-inherit autotools eutils fortran-2 flag-o-matic toolchain-funcs multilib
-
-DESCRIPTION="General purpose library and file format for storing scientific data"
-HOMEPAGE="http://www.hdfgroup.org/HDF5/"
-SRC_URI="http://www.hdfgroup.org/ftp/HDF5/releases/${MY_P}/src/${MY_P}.tar.bz2"
-
-LICENSE="NCSA-HDF"
-SLOT="0/${PV%%_p*}"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
-IUSE="cxx debug examples fortran fortran2003 mpi static-libs szip threads zlib"
-
-REQUIRED_USE="
- cxx? ( !mpi ) mpi? ( !cxx )
- threads? ( !cxx !mpi !fortran )
- fortran2003? ( fortran )"
-
-RDEPEND="
- mpi? ( virtual/mpi[romio] )
- szip? ( >=sci-libs/szip-2.1 )
- zlib? ( sys-libs/zlib )"
-
-DEPEND="${RDEPEND}
- sys-devel/libtool:2
- >=sys-devel/autoconf-2.69"
-
-pkg_setup() {
- tc-export CXX CC AR # workaround for bug 285148
- if use fortran; then
- use fortran2003 && FORTRAN_STANDARD=2003
- fortran-2_pkg_setup
- fi
- if use mpi; then
- if has_version 'sci-libs/hdf5[-mpi]'; then
- ewarn "Installing hdf5 with mpi enabled with a previous hdf5 with mpi disabled may fail."
- ewarn "Try to uninstall the current hdf5 prior to enabling mpi support."
- fi
- export CC=mpicc
- use fortran && export FC=mpif90
- elif has_version 'sci-libs/hdf5[mpi]'; then
- ewarn "Installing hdf5 with mpi disabled while having hdf5 installed with mpi enabled may fail."
- ewarn "Try to uninstall the current hdf5 prior to disabling mpi support."
- fi
-}
-
-S=${WORKDIR}/${MY_P}
-
-src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.8.10-buildsystem.patch \
- "${FILESDIR}"/${PN}-1.8.8-array_bounds.patch \
- "${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch \
- "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch \
- "${FILESDIR}"/${P}-implicits.patch \
- "${FILESDIR}"/${PN}-1.8.10_p1-comments.patch
- # respect gentoo examples directory
- sed \
- -e "s:hdf5_examples:doc/${PF}/examples:g" \
- -i $(find . -name Makefile.am) $(find . -name "run*.sh.in") || die
- sed \
- -e '/docdir/d' \
- -i config/commence.am || die
- if ! use examples; then
- sed -e '/^install:/ s/install-examples//' \
- -i Makefile.am || die #409091
- fi
- eautoreconf
- # enable shared libs by default for h5cc config utility
- sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in || die
- # bug #419677
- use prefix && \
- append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir) \
- -Wl,-rpath,"${EPREFIX}"/$(get_libdir)
-}
-
-src_configure() {
- econf \
- --enable-production \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --enable-deprecated-symbols \
- --enable-shared \
- --disable-silent-rules \
- $(use_enable prefix sharedlib-rpath) \
- $(use_enable static-libs static) \
- $(use_enable debug debug all) \
- $(use_enable debug codestack) \
- $(use_enable cxx) \
- $(use_enable fortran) \
- $(use_enable fortran2003) \
- $(use_enable mpi parallel) \
- $(use_enable threads threadsafe) \
- $(use_with szip szlib) \
- $(use_with threads pthread) \
- $(use_with zlib) \
- ${myconf}
-}
-
-src_install() {
- default
- use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
-}
diff --git a/sci-libs/hdf5/hdf5-1.8.12.ebuild b/sci-libs/hdf5/hdf5-1.8.14.ebuild
index 8e3ae62b60b0..4a1816122120 100644
--- a/sci-libs/hdf5/hdf5-1.8.12.ebuild
+++ b/sci-libs/hdf5/hdf5-1.8.14.ebuild
@@ -1,13 +1,15 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.12.ebuild,v 1.1 2013/11/15 15:49:14 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/hdf5/hdf5-1.8.14.ebuild,v 1.1 2014/11/25 15:26:17 xarthisius Exp $
EAPI=5
FORTRAN_NEEDED=fortran
-MY_P=${PN}-${PV/_p/-patch}
+AUTOTOOLS_AUTORECONF=1
+
+inherit autotools-utils eutils fortran-2 flag-o-matic toolchain-funcs multilib
-inherit autotools eutils fortran-2 flag-o-matic toolchain-funcs multilib
+MY_P=${PN}-${PV/_p/-patch}
DESCRIPTION="General purpose library and file format for storing scientific data"
HOMEPAGE="http://www.hdfgroup.org/HDF5/"
@@ -25,13 +27,22 @@ REQUIRED_USE="
RDEPEND="
mpi? ( virtual/mpi[romio] )
- szip? ( >=sci-libs/szip-2.1 )
- zlib? ( sys-libs/zlib )"
+ szip? ( >=sci-libs/szip-2.1:0= )
+ zlib? ( sys-libs/zlib:0= )"
DEPEND="${RDEPEND}
sys-devel/libtool:2
>=sys-devel/autoconf-2.69"
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch
+ "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch
+ "${FILESDIR}"/${PN}-1.8.13-no-messing-ldpath.patch
+ "${FILESDIR}"/${PN}-1.8.14-implicits.patch
+)
+
pkg_setup() {
tc-export CXX CC AR # workaround for bug 285148
if use fortran; then
@@ -51,14 +62,7 @@ pkg_setup() {
fi
}
-S=${WORKDIR}/${MY_P}
-
src_prepare() {
- epatch "${FILESDIR}"/${PN}-1.8.10-buildsystem.patch \
- "${FILESDIR}"/${PN}-1.8.8-array_bounds.patch \
- "${FILESDIR}"/${PN}-1.8.9-static_libgfortran.patch \
- "${FILESDIR}"/${PN}-1.8.9-mpicxx.patch \
- "${FILESDIR}"/${PN}-1.8.11-implicits.patch
# respect gentoo examples directory
sed \
-e "s:hdf5_examples:doc/${PF}/examples:g" \
@@ -70,38 +74,31 @@ src_prepare() {
sed -e '/^install:/ s/install-examples//' \
-i Makefile.am || die #409091
fi
- eautoreconf
# enable shared libs by default for h5cc config utility
sed -i -e "s/SHLIB:-no/SHLIB:-yes/g" tools/misc/h5cc.in || die
# bug #419677
use prefix && \
append-ldflags -Wl,-rpath,"${EPREFIX}"/usr/$(get_libdir) \
-Wl,-rpath,"${EPREFIX}"/$(get_libdir)
+ autotools-utils_src_prepare
}
src_configure() {
- econf \
- --enable-production \
- --docdir="${EPREFIX}"/usr/share/doc/${PF} \
- --enable-deprecated-symbols \
- --enable-shared \
- --disable-silent-rules \
- $(use_enable prefix sharedlib-rpath) \
- $(use_enable static-libs static) \
- $(use_enable debug debug all) \
- $(use_enable debug codestack) \
- $(use_enable cxx) \
- $(use_enable fortran) \
- $(use_enable fortran2003) \
- $(use_enable mpi parallel) \
- $(use_enable threads threadsafe) \
- $(use_with szip szlib) \
- $(use_with threads pthread) \
- $(use_with zlib) \
- ${myconf}
-}
-
-src_install() {
- default
- use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+ local myeconfargs=(
+ --enable-production
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ --enable-deprecated-symbols
+ $(use_enable prefix sharedlib-rpath)
+ $(use_enable debug debug all)
+ $(use_enable debug codestack)
+ $(use_enable cxx)
+ $(use_enable fortran)
+ $(use_enable fortran2003)
+ $(use_enable mpi parallel)
+ $(use_enable threads threadsafe)
+ $(use_with szip szlib)
+ $(use_with threads pthread)
+ $(use_with zlib)
+ )
+ autotools-utils_src_configure
}