summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-09-25 18:58:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-09-25 18:58:48 +0000
commit1a9a4edfea473e16e1e92318fa27515308aafa64 (patch)
treecd24359a6cc4adf1d379de40bb03fa3214d54376 /sci-libs/itpp
parentVersion bump. (diff)
downloadgentoo-2-1a9a4edfea473e16e1e92318fa27515308aafa64.tar.gz
gentoo-2-1a9a4edfea473e16e1e92318fa27515308aafa64.tar.bz2
gentoo-2-1a9a4edfea473e16e1e92318fa27515308aafa64.zip
Bump, thanks Adam Piątyszek
(Portage version: 2.2_rc86/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/itpp')
-rw-r--r--sci-libs/itpp/ChangeLog8
-rw-r--r--sci-libs/itpp/itpp-4.0.5.ebuild80
-rw-r--r--sci-libs/itpp/itpp-4.0.7.ebuild80
-rw-r--r--sci-libs/itpp/itpp-4.2.ebuild55
4 files changed, 62 insertions, 161 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 358c623aafeb..042c69befde4 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.95 2010/08/10 18:24:27 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.96 2010/09/25 18:58:48 bicatali Exp $
+
+*itpp-4.2 (25 Sep 2010)
+
+ 25 Sep 2010; Sébastien Fabbro <bicatali@gentoo.org> -itpp-4.0.5.ebuild,
+ -itpp-4.0.7.ebuild, +itpp-4.2.ebuild:
+ Bump, thanks Adam Piątyszek
*itpp-4.0.7-r1 (10 Aug 2010)
diff --git a/sci-libs/itpp/itpp-4.0.5.ebuild b/sci-libs/itpp/itpp-4.0.5.ebuild
deleted file mode 100644
index daf1406a9ec8..000000000000
--- a/sci-libs/itpp/itpp-4.0.5.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.5.ebuild,v 1.5 2008/11/26 16:54:23 ranger Exp $
-
-inherit fortran flag-o-matic
-
-# we need this to prevent itpp's specialized debug lib
-# (built with USE="debug" set) from being stripped
-RESTRICT="strip"
-
-DESCRIPTION="C++ library of mathematical, signal processing and communication classes and functions"
-LICENSE="GPL-2"
-HOMEPAGE="http://itpp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 sparc x86"
-IUSE="blas debug doc fftw lapack minimal"
-
-RDEPEND="!minimal? ( fftw? ( >=sci-libs/fftw-3.0.0 ) )
- blas? ( virtual/blas
- lapack? ( virtual/lapack ) )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen
- virtual/latex-base )"
-
-pkg_setup() {
- # lapack can only be used in conjunction with blas
- if use lapack && ! use blas; then
- die "USE=lapack requires USE=blas to be set"
- fi
-}
-
-src_compile() {
- # turn off performance critical debug code
- append-flags -DNDEBUG
-
- # make sure that -g is stripped always since we use
- # RESTRICT=strip. If debug info is needed please enable
- # the debug use flag and link against the debug *.so
- filter-flags -g
-
- local blas_conf="--without-blas"
- local lapack_conf="--without-lapack"
- if use blas; then
- if use lapack; then
- blas_conf="--with-blas=$(pkg-config lapack --libs)"
- lapack_conf="--with-lapack"
- else
- blas_conf="--with-blas=$(pkg-config blas --libs)"
- fi
- fi
-
- local fftw_conf="--without-fft";
- if use fftw;
- then
- fftw_conf="--with-fft=-lfftw3"
- fi
-
- local myconf="--docdir=/usr/share/doc/${P}"
- if use minimal; then
- myconf="${myconf} --disable-comm --disable-fixed --disable-optim --disable-protocol --disable-signal --disable-srccode"
- fi
-
- econf $(use_enable doc html-doc) \
- $(use_enable debug) \
- "${blas_conf}" \
- "${lapack_conf}" \
- "${fftw_conf}" \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog ChangeLog-2007 ChangeLog-2006 \
- ChangeLog-2005 INSTALL NEWS NEWS-3.10 NEWS-3.99 README TODO \
- || die "failed to install docs"
-}
diff --git a/sci-libs/itpp/itpp-4.0.7.ebuild b/sci-libs/itpp/itpp-4.0.7.ebuild
deleted file mode 100644
index a01b581f5083..000000000000
--- a/sci-libs/itpp/itpp-4.0.7.ebuild
+++ /dev/null
@@ -1,80 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.7.ebuild,v 1.1 2010/01/09 12:29:09 markusle Exp $
-
-inherit fortran flag-o-matic
-
-# we need this to prevent itpp's specialized debug lib
-# (built with USE="debug" set) from being stripped
-RESTRICT="strip"
-
-DESCRIPTION="C++ library of mathematical, signal processing and communication classes and functions"
-LICENSE="GPL-2"
-HOMEPAGE="http://itpp.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
-
-SLOT="0"
-KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE="blas debug doc fftw lapack minimal"
-
-RDEPEND="!minimal? ( fftw? ( >=sci-libs/fftw-3.0.0 ) )
- blas? ( virtual/blas
- lapack? ( virtual/lapack ) )"
-DEPEND="${RDEPEND}
- doc? ( app-doc/doxygen
- virtual/latex-base )"
-
-pkg_setup() {
- # lapack can only be used in conjunction with blas
- if use lapack && ! use blas; then
- die "USE=lapack requires USE=blas to be set"
- fi
-}
-
-src_compile() {
- # turn off performance critical debug code
- append-flags -DNDEBUG
-
- # make sure that -g is stripped always since we use
- # RESTRICT=strip. If debug info is needed please enable
- # the debug use flag and link against the debug *.so
- filter-flags -g
-
- local blas_conf="--without-blas"
- local lapack_conf="--without-lapack"
- if use blas; then
- if use lapack; then
- blas_conf="--with-blas=$(pkg-config lapack --libs)"
- lapack_conf="--with-lapack"
- else
- blas_conf="--with-blas=$(pkg-config blas --libs)"
- fi
- fi
-
- local fftw_conf="--without-fft";
- if use fftw;
- then
- fftw_conf="--with-fft=-lfftw3"
- fi
-
- local myconf="--docdir=/usr/share/doc/${P}"
- if use minimal; then
- myconf="${myconf} --disable-comm --disable-fixed --disable-optim --disable-protocol --disable-signal --disable-srccode"
- fi
-
- econf $(use_enable doc html-doc) \
- $(use_enable debug) \
- "${blas_conf}" \
- "${lapack_conf}" \
- "${fftw_conf}" \
- ${myconf} \
- || die "econf failed"
- emake || die "emake failed"
-}
-
-src_install() {
- make install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS ChangeLog ChangeLog-2007 ChangeLog-2006 \
- ChangeLog-2005 INSTALL NEWS NEWS-3.10 NEWS-3.99 README TODO \
- || die "failed to install docs"
-}
diff --git a/sci-libs/itpp/itpp-4.2.ebuild b/sci-libs/itpp/itpp-4.2.ebuild
new file mode 100644
index 000000000000..3a598783f26b
--- /dev/null
+++ b/sci-libs/itpp/itpp-4.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.2.ebuild,v 1.1 2010/09/25 18:58:48 bicatali Exp $
+
+EAPI=3
+inherit flag-o-matic
+
+DESCRIPTION="C++ library of mathematical, signal processing and communication classes and functions"
+LICENSE="GPL-3"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blas debug doc fftw lapack minimal static-libs"
+
+RDEPEND="!minimal? ( fftw? ( >=sci-libs/fftw-3 ) )
+ blas? ( virtual/blas lapack? ( virtual/lapack ) )"
+DEPEND="${RDEPEND}
+ blas? ( dev-util/pkgconfig )
+ lapack? ( dev-util/pkgconfig )
+ doc? ( app-doc/doxygen virtual/latex-base )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-4.0.7-fastica-fix-endless-loop.patch
+}
+
+src_configure() {
+ # turn off performance critical debug code
+ use debug || append-flags -DNDEBUG
+ local blasconf="no"
+ use blas && blasconf="$(pkg-config --libs blas)"
+ local lapackconf="no"
+ use lapack && lapackconf="$(pkg-config --libs blas lapack)"
+ econf \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ --enable-shared \
+ $(use_enable doc html-doc) \
+ $(use_enable debug) \
+ $(use_enable !minimal comm) \
+ $(use_enable !minimal fixed) \
+ $(use_enable !minimal optim) \
+ $(use_enable !minimal protocol) \
+ $(use_enable !minimal signal) \
+ $(use_enable !minimal srccode) \
+ $(use_enable static-libs static) \
+ $(use_with fftw fft) \
+ --with-blas="${blasconf}" \
+ --with-lapack="${lapackconf}"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog INSTALL NEWS README
+}