summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-11-03 09:30:24 +0000
committerJustin Lecher <jlec@gentoo.org>2010-11-03 09:30:24 +0000
commit1de1cfe7abf0966431d7e98d4844cbb1b0e56eb8 (patch)
tree9c11ee69f7b4d2ca1cde3e47c9b9ed6210dae6d7 /sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild
parentSecurity version bump, bug #343389 (diff)
downloadgentoo-2-1de1cfe7abf0966431d7e98d4844cbb1b0e56eb8.tar.gz
gentoo-2-1de1cfe7abf0966431d7e98d4844cbb1b0e56eb8.tar.bz2
gentoo-2-1de1cfe7abf0966431d7e98d4844cbb1b0e56eb8.zip
New Addition, imported from sci overlay
(Portage version: 2.1.9.24/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild')
-rw-r--r--sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild b/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild
new file mode 100644
index 000000000000..01522394aec2
--- /dev/null
+++ b/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libcmatrix/libcmatrix-3.2.1.ebuild,v 1.1 2010/11/03 09:30:24 jlec Exp $
+
+EAPI="3"
+
+inherit autotools eutils
+
+MY_P="${PN}${PV}_lite"
+
+DESCRIPTION="lite version of pNMRsim"
+HOMEPAGE="http://www.dur.ac.uk/paul.hodgkinson/pNMRsim/"
+#SRC_URI="${HOMEPAGE}/${MY_P}.tar.gz"
+SRC_URI="http://dev.gentooexperimental.org/~jlec/distfiles/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atlas threads"
+
+RDEPEND="
+ sci-libs/minuit
+ atlas? ( sci-libs/blas-atlas )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/${PN}R3
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PV}-shared.patch \
+ "${FILESDIR}"/${PV}-minuit2.patch \
+ "${FILESDIR}"/${PV}-gcc4.4.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --with-minuit \
+ $(use_with atlas) \
+ $(use_with threads)
+}
+
+src_install() {
+ dolib.so lib/*.so* || die "install failed"
+
+ insinto /usr/include/${PN}R3
+ doins include/* || die "no includes"
+
+ dodoc CHANGES docs/* || die "no docs"
+}