summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 07:09:30 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2008-07-08 07:09:30 +0000
commit79e08ac302fc0c3d6c226f40dbc5c0d8735e7906 (patch)
treea63a80672aff438245775219b2b00c2fd4bd27e8 /sci-libs/libghemical/libghemical-2.96.ebuild
parentNew package: A library for creating portable OpenGL applications with easy-to... (diff)
downloadgentoo-2-79e08ac302fc0c3d6c226f40dbc5c0d8735e7906.tar.gz
gentoo-2-79e08ac302fc0c3d6c226f40dbc5c0d8735e7906.tar.bz2
gentoo-2-79e08ac302fc0c3d6c226f40dbc5c0d8735e7906.zip
Bump. Pull in newer mopac, use emake instead of make to respect MAKEOPTS.
(Portage version: 2.2_rc1/cvs/Linux 2.6.26-rc8 x86_64)
Diffstat (limited to 'sci-libs/libghemical/libghemical-2.96.ebuild')
-rw-r--r--sci-libs/libghemical/libghemical-2.96.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sci-libs/libghemical/libghemical-2.96.ebuild b/sci-libs/libghemical/libghemical-2.96.ebuild
new file mode 100644
index 000000000000..97480d2f3773
--- /dev/null
+++ b/sci-libs/libghemical/libghemical-2.96.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libghemical/libghemical-2.96.ebuild,v 1.1 2008/07/08 07:09:30 dberkholz Exp $
+
+inherit autotools
+
+DESCRIPTION="Chemical quantum mechanics and molecular mechanics"
+HOMEPAGE="http://bioinformatics.org/ghemical/"
+SRC_URI="http://www.bioinformatics.org/ghemical/download/current/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="mopac7 mpqc"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.15"
+RDEPEND="mopac7? ( >=sci-chemistry/mopac7-1.13 )
+ mpqc? ( >=sci-chemistry/mpqc-2.3.1-r1
+ virtual/blas
+ virtual/lapack )"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-gcc43.patch
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ $(use_enable mopac7) \
+ $(use_enable mpqc) \
+ || die "configure failed"
+
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}