summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2009-04-24 19:08:19 +0000
committerAndrey Grozin <grozin@gentoo.org>2009-04-24 19:08:19 +0000
commit806a042e23ec3df278b3928b6fa6dc39ea020e1a (patch)
tree2b5b70478c449bd984cdb9311f613e1dbe04cd92 /sci-libs/mathgl
parentversion bump (diff)
downloadgentoo-2-806a042e23ec3df278b3928b6fa6dc39ea020e1a.tar.gz
gentoo-2-806a042e23ec3df278b3928b6fa6dc39ea020e1a.tar.bz2
gentoo-2-806a042e23ec3df278b3928b6fa6dc39ea020e1a.zip
Fixed bug #267061
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'sci-libs/mathgl')
-rw-r--r--sci-libs/mathgl/ChangeLog6
-rw-r--r--sci-libs/mathgl/files/mathgl-1.8.1-gcc43.patch10
-rw-r--r--sci-libs/mathgl/mathgl-1.8.1.ebuild33
3 files changed, 33 insertions, 16 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index be7606216895..b06debd10bac 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.4 2009/04/13 13:09:29 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.5 2009/04/24 19:08:19 grozin Exp $
+
+ 24 Apr 2009; Andrey Grozin <grozin@gentoo.org>
+ +files/mathgl-1.8.1-gcc43.patch, mathgl-1.8.1:
+ Fixed bug #267061
*mathgl-1.8.1 (13 Apr 2009)
diff --git a/sci-libs/mathgl/files/mathgl-1.8.1-gcc43.patch b/sci-libs/mathgl/files/mathgl-1.8.1-gcc43.patch
new file mode 100644
index 000000000000..7a639bb9a4ab
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-1.8.1-gcc43.patch
@@ -0,0 +1,10 @@
+--- utils/mgl2gif.cpp.ORIG 2009-03-04 14:22:12.000000000 +0100
++++ utils/mgl2gif.cpp 2009-04-22 10:15:02.000000000 +0200
+@@ -19,6 +19,7 @@
+ ***************************************************************************/
+ #include <stdio.h>
+ #include <string.h>
++#include <cstdlib>
+ #include <locale.h>
+ #include <wchar.h>
+ #include "mgl/mgl_zb.h"
diff --git a/sci-libs/mathgl/mathgl-1.8.1.ebuild b/sci-libs/mathgl/mathgl-1.8.1.ebuild
index 45ed8095bd93..8a009ade15d9 100644
--- a/sci-libs/mathgl/mathgl-1.8.1.ebuild
+++ b/sci-libs/mathgl/mathgl-1.8.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.8.1.ebuild,v 1.1 2009/04/13 13:09:29 grozin Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-1.8.1.ebuild,v 1.2 2009/04/24 19:08:19 grozin Exp $
EAPI=2
WX_GTK_VER=2.8
inherit autotools wxwidgets python versionator toolchain-funcs
@@ -38,6 +38,23 @@ pkg_setup() {
fi
}
+src_prepare() {
+ # bug #267061
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+
+ # correct location of numpy/arrayobject.h
+ if use python; then
+ local numpy_h
+ numpy_h=$(python_get_sitedir)/numpy/core/include/numpy/arrayobject.h
+ einfo "fixing numpy.i"
+ sed -e "s|<numpy/arrayobject.h>|\"${numpy_h}\"|" \
+ -i lang/numpy.i \
+ || die "sed failed"
+ fi
+
+ eautoreconf
+}
+
src_configure() {
econf --docdir="${ROOT}"usr/share/doc/${PF} \
$(use_enable glut) \
@@ -53,20 +70,6 @@ src_configure() {
$(use_enable doc docs)
}
-src_prepare() {
- # correct location of numpy/arrayobject.h
- if use python; then
- local numpy_h
- numpy_h=$(python_get_sitedir)/numpy/core/include/numpy/arrayobject.h
- einfo "fixing numpy.i"
- sed -e "s|<numpy/arrayobject.h>|\"${numpy_h}\"|" \
- -i lang/numpy.i \
- || die "sed failed"
- fi
-
- eautoreconf
-}
-
src_compile() {
# see bug #249627
local JOBS