summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-04-24 11:28:12 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-04-24 11:28:12 +0000
commit108de51ece5e12600f144625cf385ae4403a2a3e (patch)
tree6ba5201420bb629a21d658380972f2a8be905d38 /sci-libs/netcdf
parentia64 + x86 stable (diff)
downloadgentoo-2-108de51ece5e12600f144625cf385ae4403a2a3e.tar.gz
gentoo-2-108de51ece5e12600f144625cf385ae4403a2a3e.tar.bz2
gentoo-2-108de51ece5e12600f144625cf385ae4403a2a3e.zip
Version bump, with better autotools handling and install. Adapted the ebuild to match the structure. Extended the longdescription in metadata.xml.
(Portage version: 2.1.2.2)
Diffstat (limited to 'sci-libs/netcdf')
-rw-r--r--sci-libs/netcdf/ChangeLog11
-rw-r--r--sci-libs/netcdf/files/digest-netcdf-3.6.23
-rw-r--r--sci-libs/netcdf/metadata.xml12
-rw-r--r--sci-libs/netcdf/netcdf-3.6.2.ebuild76
4 files changed, 96 insertions, 6 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index 13cae1fb5c90..e54c763a9f07 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/netcdf
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.32 2006/10/24 12:31:31 markusle Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.33 2007/04/24 11:28:12 bicatali Exp $
+
+*netcdf-3.6.2 (24 Apr 2007)
+
+ 24 Apr 2007; Sébastien Fabbro <bicatali@gentoo.org> metadata.xml,
+ +netcdf-3.6.2.ebuild:
+ Version bump, with better autotools handling and install. Adapted the ebuild
+ to match the structure. Extended the longdescription in metadata.xml.
*netcdf-3.6.1-r1 (22 Oct 2006)
diff --git a/sci-libs/netcdf/files/digest-netcdf-3.6.2 b/sci-libs/netcdf/files/digest-netcdf-3.6.2
new file mode 100644
index 000000000000..4e628fa6b05c
--- /dev/null
+++ b/sci-libs/netcdf/files/digest-netcdf-3.6.2
@@ -0,0 +1,3 @@
+MD5 a7d450da9081e4a6e440705ea31868d3 netcdf-3.6.2.tar.gz 5312882
+RMD160 dcf1efa90b7479215ac0a2d8dc231d94dddc73d8 netcdf-3.6.2.tar.gz 5312882
+SHA256 feaa7673f369e5fb57fcc51426e2be694228ddcc141fc3fd20399269fb6b9311 netcdf-3.6.2.tar.gz 5312882
diff --git a/sci-libs/netcdf/metadata.xml b/sci-libs/netcdf/metadata.xml
index 597cede6b022..27285af7fd97 100644
--- a/sci-libs/netcdf/metadata.xml
+++ b/sci-libs/netcdf/metadata.xml
@@ -2,8 +2,12 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>sci</herd>
-<maintainer>
- <email>sci@gentoo.org</email>
-</maintainer>
-<longdescription>The netCDF library defines a machine-independent format and interface for representing scientific data.</longdescription>
+<longdescription lang="en">
+NetCDF (network Common Data Form) is an interface for scientific
+data access and a freely-distributed software library that provides an
+implementation of the interface. The netCDF library also defines a
+machine-independent format for representing scientific data.
+Together, the interface, library, and format support the creation,
+access, and sharing of scientific data.
+</longdescription>
</pkgmetadata>
diff --git a/sci-libs/netcdf/netcdf-3.6.2.ebuild b/sci-libs/netcdf/netcdf-3.6.2.ebuild
new file mode 100644
index 000000000000..6110312679f5
--- /dev/null
+++ b/sci-libs/netcdf/netcdf-3.6.2.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.2.ebuild,v 1.1 2007/04/24 11:28:12 bicatali Exp $
+
+inherit fortran eutils toolchain-funcs
+
+DESCRIPTION="Scientific library and interface for array oriented data access"
+SRC_URI="ftp://ftp.unidata.ucar.edu/pub/netcdf/${P}.tar.gz"
+HOMEPAGE="http://my.unidata.ucar.edu/content/software/netcdf/index.html"
+
+LICENSE="UCAR-Unidata"
+SLOT="0"
+IUSE="fortran debug doc"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="!sci-libs/hdf"
+DEPEND="${RDEPEND}
+ doc? ( virtual/tetex )"
+
+pkg_setup() {
+ if use fortran ; then
+ FORTRAN="gfortran ifc g77 pgf77 pgf90"
+ fortran_pkg_setup
+ fi
+}
+
+src_compile() {
+ use debug || CPPFLAGS="${CPPFLAGS} -DNDEBUG"
+ local myconf
+ if use fortran; then
+ # cfortran CPPFLAGS are now automatically set by the configure script
+ case "${FORTRANC}" in
+ g77)
+ myconf="${myconf} --enable-f77 --disable-f90"
+ myconf="${myconf} F77=g77"
+ ;;
+ pgf77)
+ myconf="${myconf} --enable-f77 --disable-f90"
+ myconf="${myconf} F77=pgf77"
+ ;;
+ pgf90)
+ myconf="${myconf} --enable-f77 --enable-f90"
+ myconf="${myconf} FC=pgf90 F90=pgf90 F77=pgf90"
+ ;;
+ ifc|ifort)
+ myconf="${myconf} --enable-f77 --enable-f90"
+ myconf="${myconf} FC=ifort F90=ifort F77=ifort"
+ ;;
+ *)
+ myconf="${myconf} --enable-f77 --enable-f90"
+ myconf="${myconf} FC=gfortran F90=gfortran F77=gfortran"
+ ;;
+ esac
+ else
+ myconf="${myconf} --disable-f77 --disable-f90"
+ fi
+ econf \
+ --enable-shared \
+ --docdir=/usr/share/doc/${PF} \
+ $(use_enable debug flag-setting ) \
+ $(use_enable doc docs-install) \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ find "${D}usr/$(get_libdir)" -name \*.la -exec rm -f {} \;
+ dodoc README RELEASE_NOTES VERSION || die "dodoc failed"
+ # keep only pdf,txt and html docs
+ if use doc; then
+ find "${D}usr/share/doc/${PF}" -name \*.ps -exec rm -f {} \;
+ find "${D}usr/share/doc/${PF}" -name \*.info -exec rm -f {} \;
+ find "${D}usr/share/doc/${PF}" -name \*.txt -exec ecompress {} \;
+ fi
+}