summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2014-10-29 10:20:20 +0000
committerAlexis Ballier <aballier@gentoo.org>2014-10-29 10:20:20 +0000
commitca6f1caf30a8547ee04f7f3a33db49d8ce558c04 (patch)
treea6a98c89f481f272446d18a18df04dbc4c0e13c9 /sci-libs/octomap
parentStable on alpha, bug 507788 (diff)
downloadgentoo-2-ca6f1caf30a8547ee04f7f3a33db49d8ce558c04.tar.gz
gentoo-2-ca6f1caf30a8547ee04f7f3a33db49d8ce558c04.tar.bz2
gentoo-2-ca6f1caf30a8547ee04f7f3a33db49d8ce558c04.zip
initial import, ebuild by me
Signed-off-by: aballier@gentoo.org (Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sci-libs/octomap')
-rw-r--r--sci-libs/octomap/ChangeLog11
-rw-r--r--sci-libs/octomap/metadata.xml14
-rw-r--r--sci-libs/octomap/octomap-1.6.8.ebuild81
-rw-r--r--sci-libs/octomap/octomap-9999.ebuild81
4 files changed, 187 insertions, 0 deletions
diff --git a/sci-libs/octomap/ChangeLog b/sci-libs/octomap/ChangeLog
new file mode 100644
index 000000000000..d802f209528e
--- /dev/null
+++ b/sci-libs/octomap/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for sci-libs/octomap
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/octomap/ChangeLog,v 1.1 2014/10/29 10:20:20 aballier Exp $
+
+*octomap-9999 (29 Oct 2014)
+*octomap-1.6.8 (29 Oct 2014)
+
+ 29 Oct 2014; Alexis Ballier <aballier@gentoo.org> +octomap-1.6.8.ebuild,
+ +octomap-9999.ebuild, +metadata.xml:
+ initial import, ebuild by me
+
diff --git a/sci-libs/octomap/metadata.xml b/sci-libs/octomap/metadata.xml
new file mode 100644
index 000000000000..4bcb0dae33dc
--- /dev/null
+++ b/sci-libs/octomap/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>aballier@gentoo.org</email>
+<name>Alexis Ballier</name>
+</maintainer>
+<longdescription lang="en">
+ The OctoMap library implements a 3D occupancy grid mapping approach, providing data structures and mapping algorithms in C++ particularly suited for robotics.
+</longdescription>
+ <use>
+ <flag name="dynamicEDT3D">Build and install dynamicEDT3D library: A library for incrementally updatable Euclidean distance transforms in 3D.</flag>
+ </use>
+</pkgmetadata>
diff --git a/sci-libs/octomap/octomap-1.6.8.ebuild b/sci-libs/octomap/octomap-1.6.8.ebuild
new file mode 100644
index 000000000000..ee432d7d2af7
--- /dev/null
+++ b/sci-libs/octomap/octomap-1.6.8.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/octomap/octomap-1.6.8.ebuild,v 1.1 2014/10/29 10:20:20 aballier Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://github.com/OctoMap/octomap"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="http://github.com/OctoMap/octomap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An Efficient Probabilistic 3D Mapping Framework Based on Octrees"
+HOMEPAGE="http://octomap.github.io/"
+IUSE="qt4 dynamicEDT3D doc"
+LICENSE="BSD qt4? ( GPL-2 )"
+SLOT="0"
+
+RDEPEND="
+ qt4? (
+ virtual/opengl
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-libs/libQGLViewer
+ )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+
+src_prepare() {
+ sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ -i */CMakeLists.txt \
+ -i */CMakeModules/InstallPkgConfigFile.cmake || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_OCTOVIS_SUBPROJECT=$(usex qt4 ON OFF)"
+ "-DBUILD_DYNAMICETD3D_SUBPROJECT=$(usex dynamicEDT3D ON OFF)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc ; then
+ cd "${BUILD_DIR}/octomap"
+ emake docs
+ if use dynamicEDT3D ; then
+ cd "${BUILD_DIR}/dynamicEDT3D"
+ emake docs_dynamicEDT3D
+ fi
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/html/octomap
+ doins -r "${S}/octomap/doc/html/"*
+ if use dynamicEDT3D ; then
+ insinto /usr/share/doc/${PF}/html/dynamicEDT3D
+ doins -r "${S}/dynamicEDT3D/doc/html/"*
+ fi
+ fi
+}
diff --git a/sci-libs/octomap/octomap-9999.ebuild b/sci-libs/octomap/octomap-9999.ebuild
new file mode 100644
index 000000000000..878ff4441bc1
--- /dev/null
+++ b/sci-libs/octomap/octomap-9999.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/octomap/octomap-9999.ebuild,v 1.1 2014/10/29 10:20:20 aballier Exp $
+
+EAPI=5
+
+SCM=""
+if [ "${PV#9999}" != "${PV}" ] ; then
+ SCM="git-r3"
+ EGIT_REPO_URI="http://github.com/OctoMap/octomap"
+fi
+
+inherit ${SCM} cmake-utils
+
+if [ "${PV#9999}" != "${PV}" ] ; then
+ KEYWORDS=""
+ SRC_URI=""
+else
+ KEYWORDS="~amd64"
+ SRC_URI="http://github.com/OctoMap/octomap/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+fi
+
+DESCRIPTION="An Efficient Probabilistic 3D Mapping Framework Based on Octrees"
+HOMEPAGE="http://octomap.github.io/"
+IUSE="qt4 dynamicEDT3D doc"
+LICENSE="BSD qt4? ( GPL-2 )"
+SLOT="0"
+
+RDEPEND="
+ qt4? (
+ virtual/opengl
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ x11-libs/libQGLViewer
+ )
+"
+DEPEND="${RDEPEND}
+ doc? (
+ app-doc/doxygen
+ media-gfx/graphviz
+ )
+"
+
+src_prepare() {
+ sed -e 's/DESTINATION lib/DESTINATION ${CMAKE_INSTALL_LIBDIR}/' \
+ -i */CMakeLists.txt \
+ -i */CMakeModules/InstallPkgConfigFile.cmake || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ "-DBUILD_OCTOVIS_SUBPROJECT=$(usex qt4 ON OFF)"
+ "-DBUILD_DYNAMICETD3D_SUBPROJECT=$(usex dynamicEDT3D ON OFF)"
+ )
+ cmake-utils_src_configure
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc ; then
+ cd "${BUILD_DIR}/octomap"
+ emake docs
+ if use dynamicEDT3D ; then
+ cd "${BUILD_DIR}/dynamicEDT3D"
+ emake docs_dynamicEDT3D
+ fi
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/html/octomap
+ doins -r "${S}/octomap/doc/html/"*
+ if use dynamicEDT3D ; then
+ insinto /usr/share/doc/${PF}/html/dynamicEDT3D
+ doins -r "${S}/dynamicEDT3D/doc/html/"*
+ fi
+ fi
+}