summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-04-13 01:52:38 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-04-13 01:52:38 +0000
commit6388f87c8c2b00e138819f77a882220d86b97158 (patch)
tree9a444ffb8c4e23d75f4fd2d8a5a1daf65fd778d8 /sci-libs/scipy
parentVersion bump for 2.14.1 (diff)
downloadgentoo-2-6388f87c8c2b00e138819f77a882220d86b97158.tar.gz
gentoo-2-6388f87c8c2b00e138819f77a882220d86b97158.tar.bz2
gentoo-2-6388f87c8c2b00e138819f77a882220d86b97158.zip
Added ATLAS profile check in pk_setup() (fixes bug #129524).
(Portage version: 2.0.54)
Diffstat (limited to 'sci-libs/scipy')
-rw-r--r--sci-libs/scipy/ChangeLog7
-rw-r--r--sci-libs/scipy/Manifest2
-rw-r--r--sci-libs/scipy/files/digest-scipy-0.4.8-r11
-rw-r--r--sci-libs/scipy/scipy-0.4.8-r1.ebuild104
4 files changed, 113 insertions, 1 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index a3116617497b..80be5d10330c 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.2 2006/04/01 20:26:03 ribosome Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.3 2006/04/13 01:52:37 ribosome Exp $
+
+*scipy-0.4.8-r1 (13 Apr 2006)
+
+ 13 Apr 2006; Olivier Fisette <ribosome@gentoo.org> +scipy-0.4.8-r1.ebuild:
+ Added ATLAS profile check in pk_setup() (fixes bug #129524).
*scipy-0.4.8 (01 Apr 2006)
diff --git a/sci-libs/scipy/Manifest b/sci-libs/scipy/Manifest
index c71ab92f59af..6267202f99e7 100644
--- a/sci-libs/scipy/Manifest
+++ b/sci-libs/scipy/Manifest
@@ -1,7 +1,9 @@
MD5 9c88e29226abcbca9e02dc9efe29d8d2 ChangeLog 595
MD5 1b281bbd7d7655bf8fb89c5cb8e05db0 files/digest-scipy-0.3.2 73
MD5 33b97bb0d4cf02b003fc6fb26d8ace5f files/digest-scipy-0.4.8 64
+MD5 33b97bb0d4cf02b003fc6fb26d8ace5f files/digest-scipy-0.4.8-r1 64
MD5 a5ac5edc39d8266b13659fd429e8e939 files/system_info.diff 2155
MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 c48241d7cc7765759cf9eb54bbdff32f scipy-0.3.2.ebuild 1414
+MD5 6f186b02b77e7b46a34c6aab15c758dd scipy-0.4.8-r1.ebuild 3090
MD5 b9ab6884937783091de535b7d3e9ce82 scipy-0.4.8.ebuild 2024
diff --git a/sci-libs/scipy/files/digest-scipy-0.4.8-r1 b/sci-libs/scipy/files/digest-scipy-0.4.8-r1
new file mode 100644
index 000000000000..34e44425482c
--- /dev/null
+++ b/sci-libs/scipy/files/digest-scipy-0.4.8-r1
@@ -0,0 +1 @@
+MD5 854db037c56a0a359f877e8f852925ea scipy-0.4.8.tar.gz 2623917
diff --git a/sci-libs/scipy/scipy-0.4.8-r1.ebuild b/sci-libs/scipy/scipy-0.4.8-r1.ebuild
new file mode 100644
index 000000000000..1b8b08a4f96d
--- /dev/null
+++ b/sci-libs/scipy/scipy-0.4.8-r1.ebuild
@@ -0,0 +1,104 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.4.8-r1.ebuild,v 1.1 2006/04/13 01:52:37 ribosome Exp $
+
+inherit distutils fortran
+
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+DESCRIPTION="Open source scientific tools for Python"
+HOMEPAGE="http://www.scipy.org/"
+LICENSE="BSD"
+
+SLOT="0"
+IUSE="fftw"
+KEYWORDS="~amd64 ~x86"
+
+# did not use virtual/blas and virtual/lapack
+# because doc says scipy needs to compile all libraries with the same compiler
+RDEPEND=">=dev-lang/python-2.3.3
+ >=dev-python/numpy-0.9.6
+ sci-libs/blas-atlas
+ sci-libs/lapack-atlas
+ fftw? ( =sci-libs/fftw-2.1* )"
+
+DEPEND="${RDEPEND}
+ =sys-devel/gcc-3*"
+
+# install doc claims fftw-2 is faster for complex ffts.
+# install doc claims gcc-4 not fully tested and blas-atlas is compiled
+# with g77 only, so force use of g77 here as well.
+# wxwindows seems to have disapeared : ?
+# f2py seems to be in numpy.
+
+FORTRAN="g77"
+
+pkg_setup() {
+ if built_with_use lapack-atlas ifc; then
+ echo
+ ewarn "${PN} needs consistency among Fortran compilers."
+ eerror "lapack-atlas was compiled with IFC, whereas"
+ eerror "blas-atlas and scipy use the GNU compiler."
+ eerror "please re-emerge lapack-atlas with 'USE=\"-ifc\"'."
+ echo
+ die Inconsistent Fortran compilers
+ fi
+
+ echo
+ einfo "Checking active BLAS implementations for ATLAS."
+ blas-config -p
+ if ! blas-config -p | grep "F77 BLAS:" | grep -q f77-ATLAS; then
+ eerror "Your F77 BLAS profile is not set to the ATLAS implementation,"
+ eerror "which is required by ${PN} to compile and run properly."
+ eerror "Use: 'blas-config -f ATLAS' to activate ATLAS."
+ echo
+ bad_profile=1
+ fi
+ if ! blas-config -p | grep "C BLAS:" | grep -q c-ATLAS; then
+ eerror "Your C BLAS profile is not set to the ATLAS implementation,"
+ eerror "Which is required by ${PN} to compile and run properly."
+ eerror "Use: 'blas-config -c ATLAS' to activate ATLAS."
+ echo
+ bad_profile=1
+ fi
+ einfo "Checking active LAPACK implementation for ATLAS."
+ lapack-config -p
+ if ! lapack-config -p | grep "F77 LAPACK:" | grep -q f77-ATLAS; then
+ eerror "Your F77 LAPACK profile is not set to the ATLAS implementation,"
+ eerror "which is required by ${PN} to compile and run properly."
+ eerror "Use: 'lapack-config ATLAS' to activate ATLAS."
+ bad_profile=1
+ fi
+ if ! [ -z ${bad_profile} ]; then
+ die "Active BLAS/LAPACK implementations are not ATLAS."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ echo "[atlas]" > site.cfg
+ echo "include_dirs = /usr/include/atlas" >> site.cfg
+ echo "atlas_libs = lapack, blas, cblas, atlas" >> site.cfg
+ echo -n "library_dirs = /usr/$(get_libdir)/lapack:/usr/$(get_libdir):" \
+ >> site.cfg
+ if [ -d "/usr/$(get_libdir)/blas/threaded-atlas" ]; then
+ echo "/usr/$(get_libdir)/blas/threaded-atlas" >> site.cfg
+ else
+ echo "/usr/$(get_libdir)/blas/atlas" >> site.cfg
+ fi
+
+ export FFTW3=None
+ if use fftw; then
+ echo "[fftw] " >> site.cfg
+ echo "fftw_libs = rfftw, fftw" >> site.cfg
+ echo "fftw_opt_libs = rfftw_threads, fftw_threads" >> site.cfg
+ else
+ export FFTW=None
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ dodoc `ls *.txt`
+}