summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2012-11-12 02:20:56 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2012-11-12 02:20:56 +0000
commit79cbb414ba40e6036ea24ddd1e31a14eb0fa45a2 (patch)
tree46f9ae3ef1653ceb21cb763f794aabf26fa518b2 /sci-libs/spqr/spqr-1.3.1.ebuild
parentVersion bump (diff)
downloadgentoo-2-79cbb414ba40e6036ea24ddd1e31a14eb0fa45a2.tar.gz
gentoo-2-79cbb414ba40e6036ea24ddd1e31a14eb0fa45a2.tar.bz2
gentoo-2-79cbb414ba40e6036ea24ddd1e31a14eb0fa45a2.zip
Version bump
(Portage version: 2.2.01.21313-prefix/cvs/Linux x86_64, signed Manifest commit with key 0x13CB1360)
Diffstat (limited to 'sci-libs/spqr/spqr-1.3.1.ebuild')
-rw-r--r--sci-libs/spqr/spqr-1.3.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/sci-libs/spqr/spqr-1.3.1.ebuild b/sci-libs/spqr/spqr-1.3.1.ebuild
new file mode 100644
index 000000000000..b1ec736c3fe9
--- /dev/null
+++ b/sci-libs/spqr/spqr-1.3.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/spqr/spqr-1.3.1.ebuild,v 1.1 2012/11/12 02:20:56 bicatali Exp $
+
+EAPI=4
+
+inherit autotools-utils
+
+DESCRIPTION="Multithreaded multifrontal sparse QR factorization library"
+HOMEPAGE="http://www.cise.ufl.edu/research/sparse/SPQR"
+SRC_URI="http://dev.gentoo.org/~bicatali/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc metis static-libs tbb"
+RDEPEND="
+ >=sci-libs/cholmod-2
+ tbb? ( dev-cpp/tbb )
+ metis? ( >=sci-libs/cholmod-2[metis] )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( virtual/latex-base )"
+
+src_configure() {
+ local myeconfargs+=(
+ $(use_with doc)
+ $(use_with metis partition)
+ $(use_with tbb)
+ )
+ autotools-utils_src_configure
+}