summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2008-01-22 00:06:56 +0000
committerRyan Hill <dirtyepic@gentoo.org>2008-01-22 00:06:56 +0000
commit81fb21e9e67a9a0f7cdc2936627046a7a92e3952 (patch)
tree77cb685f9d84678eefdea478b7f260dc0006f67d /sci-libs/ta-lib/ta-lib-0.4.0.ebuild
parentVersion bump, bug #197703. Prevent absorbing dependencies in tvbrowser's jars... (diff)
downloadgentoo-2-81fb21e9e67a9a0f7cdc2936627046a7a92e3952.tar.gz
gentoo-2-81fb21e9e67a9a0f7cdc2936627046a7a92e3952.tar.bz2
gentoo-2-81fb21e9e67a9a0f7cdc2936627046a7a92e3952.zip
Temporary workaround for parallel build problem. (bug #206745)
(Portage version: 2.1.4)
Diffstat (limited to 'sci-libs/ta-lib/ta-lib-0.4.0.ebuild')
-rw-r--r--sci-libs/ta-lib/ta-lib-0.4.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sci-libs/ta-lib/ta-lib-0.4.0.ebuild b/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
index 75a4b9b83d9d..5fc2126bf3f8 100644
--- a/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
+++ b/sci-libs/ta-lib/ta-lib-0.4.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/ta-lib/ta-lib-0.4.0.ebuild,v 1.4 2008/01/20 21:50:17 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/ta-lib/ta-lib-0.4.0.ebuild,v 1.5 2008/01/22 00:06:56 dirtyepic Exp $
inherit eutils
@@ -24,6 +24,11 @@ src_unpack() {
epatch "${FILESDIR}"/${P}-asneeded.patch
}
+src_compile() {
+ econf || die "econf failed."
+ emake ${MAKEOPTS} -j1 || die "emake failed."
+}
+
src_test() {
ewarn "Note: this testsuite will fail without an active internet connection."
"${S}"/src/tools/ta_regtest/ta_regtest || die "Failed testsuite."