summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <ottxor@gentoo.org>2011-03-07 22:09:53 +0000
committerChristoph Junghans <ottxor@gentoo.org>2011-03-07 22:09:53 +0000
commite89399613bbc0627420a14b3c87ee40701211271 (patch)
treea682ccb942c0aceb633a7f3fa35070d979bf58d6 /sci-libs/votca-tools
parentKeyworded on alpha, bug #351551 (diff)
downloadgentoo-2-e89399613bbc0627420a14b3c87ee40701211271.tar.gz
gentoo-2-e89399613bbc0627420a14b3c87ee40701211271.tar.bz2
gentoo-2-e89399613bbc0627420a14b3c87ee40701211271.zip
version bump
(Portage version: 2.1.9.25/cvs/Linux i686)
Diffstat (limited to 'sci-libs/votca-tools')
-rw-r--r--sci-libs/votca-tools/ChangeLog8
-rw-r--r--sci-libs/votca-tools/votca-tools-1.0.1.ebuild65
-rw-r--r--sci-libs/votca-tools/votca-tools-1.1.1.ebuild76
3 files changed, 83 insertions, 66 deletions
diff --git a/sci-libs/votca-tools/ChangeLog b/sci-libs/votca-tools/ChangeLog
index 17ef2f14d038..478fc3917ab1 100644
--- a/sci-libs/votca-tools/ChangeLog
+++ b/sci-libs/votca-tools/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/votca-tools
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.1 2011/02/12 16:12:08 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/ChangeLog,v 1.2 2011/03/07 22:09:52 ottxor Exp $
+
+*votca-tools-1.1.1 (07 Mar 2011)
+
+ 07 Mar 2011; Christoph Junghans <ottxor@gentoo.org>
+ -votca-tools-1.0.1.ebuild, +votca-tools-1.1.1.ebuild:
+ version bump
*votca-tools-1.0.1 (12 Feb 2011)
diff --git a/sci-libs/votca-tools/votca-tools-1.0.1.ebuild b/sci-libs/votca-tools/votca-tools-1.0.1.ebuild
deleted file mode 100644
index e5f28e88379f..000000000000
--- a/sci-libs/votca-tools/votca-tools-1.0.1.ebuild
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/votca-tools-1.0.1.ebuild,v 1.1 2011/02/12 16:12:08 ottxor Exp $
-
-EAPI="3"
-
-inherit eutils autotools
-
-if [ "${PV}" != "9999" ]; then
- SRC_URI="http://votca.googlecode.com/files/${PF}.tar.gz"
-else
- SRC_URI=""
- inherit mercurial
- EHG_REPO_URI="https://tools.votca.googlecode.com/hg"
- S="${WORKDIR}/${EHG_REPO_URI##*/}"
-fi
-
-DESCRIPTION="Votca tools library"
-HOMEPAGE="http://www.votca.org"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~x86"
-IUSE="boost doc +fftw +gsl static-libs"
-
-RDEPEND="fftw? ( sci-libs/fftw:3.0 )
- dev-libs/expat
- gsl? ( sci-libs/gsl )
- boost? ( dev-libs/boost )
- doc? ( >=app-text/txt2tags-2.5 )"
-
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_prepare() {
- use gsl || ewarn "Disabling gsl will lead to reduced functionality"
- use fftw || ewarn "Disabling fftw will lead to reduced functionality"
-
- #remove bundled libs
- rm -rf src/libexpat
- use boost && rm -rf src/libboost
-
- eautoreconf || die "eautoreconf failed"
-}
-
-src_configure() {
- local myconf="--disable-la-files --disable-rc-files"
-
- use boost \
- && myconf="${myconf} $(use_with boost) --disable-votca-boost" \
- || myconf="${myconf} $(use_with boost) --enable-votca-boost"
-
- myconf="${myconf} $(use_with gsl) $(use_with fftw) $(use_enable static-libs static)"
-
- econf ${myconf} || die "econf failed"
-}
-
-src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
- dodoc NOTICE
- if use doc; then
- emake CHANGELOG || die "emake CHANGELOG failed"
- dodoc CHANGELOG
- fi
-}
diff --git a/sci-libs/votca-tools/votca-tools-1.1.1.ebuild b/sci-libs/votca-tools/votca-tools-1.1.1.ebuild
new file mode 100644
index 000000000000..9f61807ba932
--- /dev/null
+++ b/sci-libs/votca-tools/votca-tools-1.1.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/votca-tools/votca-tools-1.1.1.ebuild,v 1.1 2011/03/07 22:09:52 ottxor Exp $
+
+EAPI="3"
+
+inherit eutils autotools-utils
+
+if [ "${PV}" != "9999" ]; then
+ SRC_URI="boost? ( http://votca.googlecode.com/files/${PF}_pristine.tar.gz )
+ !boost? ( http://votca.googlecode.com/files/${PF}.tar.gz )"
+ RESTRICT="primaryuri"
+else
+ SRC_URI=""
+ inherit mercurial
+ EHG_REPO_URI="https://tools.votca.googlecode.com/hg"
+ S="${WORKDIR}/${EHG_REPO_URI##*/}"
+fi
+
+DESCRIPTION="Votca tools library"
+HOMEPAGE="http://www.votca.org"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE="-boost doc +fftw +gsl static-libs"
+
+RDEPEND="fftw? ( sci-libs/fftw:3.0 )
+ dev-libs/expat
+ gsl? ( sci-libs/gsl )
+ boost? ( dev-libs/boost )"
+
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen[-nodot] )
+ >=app-text/txt2tags-2.5
+ dev-util/pkgconfig"
+
+src_prepare() {
+ use gsl || ewarn "Disabling gsl will lead to reduced functionality"
+ use fftw || ewarn "Disabling fftw will lead to reduced functionality"
+
+ #remove bundled libs
+ rm -rf src/libexpat
+ if use boost; then
+ rm -rf src/libboost
+ else
+ #fix a qa issue ../../config is not support as m4 dir
+ mkdir -p src/libboost/config || die
+ sed -i 's@\.\./\.\./config@config@' \
+ src/libboost/configure.ac \
+ src/libboost/Makefile.am || \
+ die "sed of libboost configure.ac and Makefile.am failed"
+ fi
+ eautoreconf || die "eautoreconf failed"
+}
+
+src_configure() {
+ local myconf
+ use boost && myconf="--disable-votca-boost" || myconf="--enable-votca-boost"
+
+ myeconfargs=( ${myconf} --disable-rc-files
+ $(use_with gsl)
+ $(use_with fftw)
+ )
+ autotools-utils_src_configure || die
+}
+
+src_install() {
+ DOCS=(${AUTOTOOLS_BUILD_DIR}/CHANGELOG NOTICE)
+ autotools-utils_src_install || die
+ if use doc; then
+ cd share/doc || die
+ doxygen || die
+ dohtml -r html/* || die
+ fi
+}