summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2006-06-23 01:13:23 +0000
committerMarkus Dittrich <markusle@gentoo.org>2006-06-23 01:13:23 +0000
commit7bceccabb650989158a1f07a33f697f04284df1d (patch)
treec6f398fe56709dd2bae4b1230428ce70409f8651 /sci-libs/vtk/vtk-5.0.0.ebuild
parentMarked amd64 as per bug #137198 (diff)
downloadgentoo-2-7bceccabb650989158a1f07a33f697f04284df1d.tar.gz
gentoo-2-7bceccabb650989158a1f07a33f697f04284df1d.tar.bz2
gentoo-2-7bceccabb650989158a1f07a33f697f04284df1d.zip
Added a warning to the ebuild that qt4 is the default in case both qt3 and qt4 are selected as use flags (see bug #137658).
(Portage version: 2.1.1_pre1-r1)
Diffstat (limited to 'sci-libs/vtk/vtk-5.0.0.ebuild')
-rw-r--r--sci-libs/vtk/vtk-5.0.0.ebuild12
1 files changed, 11 insertions, 1 deletions
diff --git a/sci-libs/vtk/vtk-5.0.0.ebuild b/sci-libs/vtk/vtk-5.0.0.ebuild
index 4c913bbf1e84..485afe8f849c 100644
--- a/sci-libs/vtk/vtk-5.0.0.ebuild
+++ b/sci-libs/vtk/vtk-5.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.0.ebuild,v 1.6 2006/06/12 12:38:38 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.0.ebuild,v 1.7 2006/06/23 01:13:23 markusle Exp $
# TODO: need to fix Examples/CMakeLists.txt to build other examples
@@ -37,6 +37,16 @@ DEPEND="${RDEPEND}
S="${WORKDIR}"/VTK
+
+pkg_setup() {
+ if use qt3 && use qt4; then
+ echo
+ ewarn "qt3 and qt4 support for vtk are mutually exclusive and"
+ ewarn "qt4 support has therefore been enabled by default."
+ echo
+ fi
+}
+
src_unpack() {
unpack ${A}
cd "${S}"