summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-05-07 12:38:32 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-05-07 12:38:32 +0000
commita99375a07ba16734d65e4e2ab53403b01a2a0ac4 (patch)
tree6671d3df1c5d05ba1ed84faedd712fc28818fdea /sci-libs/vtk
parentStable on sparc wrt security #170977 (diff)
downloadgentoo-2-a99375a07ba16734d65e4e2ab53403b01a2a0ac4.tar.gz
gentoo-2-a99375a07ba16734d65e4e2ab53403b01a2a0ac4.tar.bz2
gentoo-2-a99375a07ba16734d65e4e2ab53403b01a2a0ac4.zip
Added patch fixing cmake files to properly detect and add lam-mpi libraries.
(Portage version: 2.1.2.7)
Diffstat (limited to 'sci-libs/vtk')
-rw-r--r--sci-libs/vtk/ChangeLog7
-rw-r--r--sci-libs/vtk/files/vtk-5.0.3-lammpi.patch45
-rw-r--r--sci-libs/vtk/vtk-5.0.3.ebuild9
3 files changed, 59 insertions, 2 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index 74d856d50228..7e0df7fbacb8 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.31 2007/05/04 01:49:31 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.32 2007/05/07 12:38:32 markusle Exp $
+
+ 06 May 2007; Markus Dittrich <markusle@gentoo.org>
+ +files/vtk-5.0.3-lammpi.patch, vtk-5.0.3.ebuild:
+ Added patch fixing cmake files to properly detect and add lam-mpi
+ libraries.
04 May 2007; Markus Dittrich <markusle@gentoo.org> vtk-5.0.3.ebuild:
Check for qt3support useflag when building the examples under qt4
diff --git a/sci-libs/vtk/files/vtk-5.0.3-lammpi.patch b/sci-libs/vtk/files/vtk-5.0.3-lammpi.patch
new file mode 100644
index 000000000000..4493667cf7db
--- /dev/null
+++ b/sci-libs/vtk/files/vtk-5.0.3-lammpi.patch
@@ -0,0 +1,45 @@
+diff -Naur VTK/Parallel/CMakeLists.txt VTK-new/Parallel/CMakeLists.txt
+--- VTK/Parallel/CMakeLists.txt 2007-03-28 16:38:46.000000000 -0400
++++ VTK-new/Parallel/CMakeLists.txt 2007-05-06 08:46:55.000000000 -0400
+@@ -78,6 +78,7 @@
+
+ IF (VTK_USE_MPI)
+ INCLUDE (${CMAKE_ROOT}/Modules/FindMPI.cmake)
++ INCLUDE(${VTK_SOURCE_DIR}/Parallel/FindLAMMPI.cmake)
+ SET ( Kit_SRCS
+ ${Kit_SRCS}
+ vtkMPICommunicator.cxx
+@@ -94,6 +95,12 @@
+ IF (MPI_EXTRA_LIBRARY)
+ SET(KIT_LIBS ${KIT_LIBS} "${MPI_EXTRA_LIBRARY}")
+ ENDIF (MPI_EXTRA_LIBRARY)
++ IF (LAMMPI_LIBRARY)
++ SET(KIT_LIBS ${KIT_LIBS} "${LAMMPI_LIBRARY}")
++ ENDIF (LAMMPI_LIBRARY)
++ IF (LAMMPI_EXTRA_LIBRARY)
++ SET(KIT_LIBS ${KIT_LIBS} "${LAMMPI_EXTRA_LIBRARY}")
++ ENDIF (LAMMPI_EXTRA_LIBRARY)
+ ENDIF (VTK_USE_MPI)
+
+ SET(Kit_EXTRA_SRCS)
+diff -Naur VTK/Parallel/FindLAMMPI.cmake VTK-new/Parallel/FindLAMMPI.cmake
+--- VTK/Parallel/FindLAMMPI.cmake 1969-12-31 19:00:00.000000000 -0500
++++ VTK-new/Parallel/FindLAMMPI.cmake 2007-05-06 18:30:22.000000000 -0400
+@@ -0,0 +1,17 @@
++# - Find LamMPI
++FIND_LIBRARY(LAMMPI_LIBRARY
++ NAMES lam
++ PATHS /usr/lib /usr/lib64
++ "$ENV{ProgramFiles}/MPICH/SDK/Lib"
++ "$ENV{ProgramFiles}/MPICH2/Lib"
++ "C:/Program Files/MPICH/SDK/Lib"
++)
++
++FIND_LIBRARY(LAMMPI_EXTRA_LIBRARY
++ NAMES lammpi++
++ PATHS /usr/lib /usr/lib64
++ "$ENV{ProgramFiles}/MPICH/SDK/Lib"
++ "C:/Program Files/MPICH/SDK/Lib"
++ DOC "If a second mpi library is necessary, specify it here.")
++
++MARK_AS_ADVANCED(LAMMPI_LIBRARY LAMMPI_EXTRA_LIBRARY)
diff --git a/sci-libs/vtk/vtk-5.0.3.ebuild b/sci-libs/vtk/vtk-5.0.3.ebuild
index ed7f2f054efb..3c9eb8a3526b 100644
--- a/sci-libs/vtk/vtk-5.0.3.ebuild
+++ b/sci-libs/vtk/vtk-5.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.3.ebuild,v 1.3 2007/05/04 01:49:31 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.0.3.ebuild,v 1.4 2007/05/07 12:38:32 markusle Exp $
inherit distutils eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2 python qt3
@@ -55,6 +55,13 @@ pkg_setup() {
fi
}
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-lammpi.patch
+}
+
+
src_compile() {
# gcc versions 3.2.x seem to have sse-related bugs that are
# triggered by VTK when compiling for pentium3/4