summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2007-06-22 14:48:26 +0000
committerMarkus Dittrich <markusle@gentoo.org>2007-06-22 14:48:26 +0000
commit03d52f9d997514e81f2b54553b59680282d22496 (patch)
treed6ab54bab911c02c2078d422cb827d6b7dc24fde /sci-libs
parentalpha stable wrt #172213 (diff)
downloadgentoo-2-03d52f9d997514e81f2b54553b59680282d22496.tar.gz
gentoo-2-03d52f9d997514e81f2b54553b59680282d22496.tar.bz2
gentoo-2-03d52f9d997514e81f2b54553b59680282d22496.zip
Version bump.
(Portage version: 2.1.3_rc4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itpp/ChangeLog8
-rw-r--r--sci-libs/itpp/files/digest-itpp-3.99.23
-rw-r--r--sci-libs/itpp/itpp-3.10.11.ebuild3
-rw-r--r--sci-libs/itpp/itpp-3.99.2.ebuild64
4 files changed, 76 insertions, 2 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index eb6a3dd55a38..7cc31bcc8a2e 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.42 2007/06/14 15:36:20 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.43 2007/06/22 14:48:26 markusle Exp $
+
+*itpp-3.99.2 (22 Jun 2007)
+
+ 22 Jun 2007; Markus Dittrich <markusle@gentoo.org> itpp-3.10.11.ebuild,
+ +itpp-3.99.2.ebuild:
+ Version bump.
14 Jun 2007; Christoph Mende <angelos@gentoo.org> itpp-3.10.10.ebuild:
Stable on amd64 wrt bug 181252
diff --git a/sci-libs/itpp/files/digest-itpp-3.99.2 b/sci-libs/itpp/files/digest-itpp-3.99.2
new file mode 100644
index 000000000000..dce550198610
--- /dev/null
+++ b/sci-libs/itpp/files/digest-itpp-3.99.2
@@ -0,0 +1,3 @@
+MD5 c7cc3d39a6a32a8428340baa70d5fc37 itpp-3.99.2.tar.bz2 883125
+RMD160 cec0ed679f686e38450e68c12b021ca05ab21c70 itpp-3.99.2.tar.bz2 883125
+SHA256 90fd8a9e5eabab844d2c317f5cf197bb590765df320bcec0015ac0f653c7133b itpp-3.99.2.tar.bz2 883125
diff --git a/sci-libs/itpp/itpp-3.10.11.ebuild b/sci-libs/itpp/itpp-3.10.11.ebuild
index e0a338187dd0..75cd8a88af3e 100644
--- a/sci-libs/itpp/itpp-3.10.11.ebuild
+++ b/sci-libs/itpp/itpp-3.10.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-3.10.11.ebuild,v 1.2 2007/06/06 14:27:04 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-3.10.11.ebuild,v 1.3 2007/06/22 14:48:26 markusle Exp $
inherit fortran
@@ -18,6 +18,7 @@ DEPEND="fftw? ( || ( >=sci-libs/fftw-3.0.0
blas? ( virtual/blas
cblas? ( || ( >=sci-libs/gsl-1.4
>=sci-libs/acml-2.5.3
+ >=sci-libs/mkl-8.1
>=sci-libs/blas-atlas-3.6.0
sci-libs/cblas-reference ) )
lapack? ( virtual/lapack ) )
diff --git a/sci-libs/itpp/itpp-3.99.2.ebuild b/sci-libs/itpp/itpp-3.99.2.ebuild
new file mode 100644
index 000000000000..292797b63e10
--- /dev/null
+++ b/sci-libs/itpp/itpp-3.99.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-3.99.2.ebuild,v 1.1 2007/06/22 14:48:26 markusle Exp $
+
+inherit fortran
+
+DESCRIPTION="IT++ is a C++ library of mathematical, signal processing, speech processing, and communications classes and functions"
+LICENSE="GPL-2"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blas cblas debug doc fftw lapack minimal"
+
+DEPEND="!minimal? ( fftw? ( || ( >=sci-libs/fftw-3.0.0
+ >=sci-libs/acml-2.5.3 ) ) )
+ blas? ( virtual/blas
+ cblas? ( || ( >=sci-libs/gsl-1.4
+ >=sci-libs/mkl-8.1
+ >=sci-libs/acml-2.5.3
+ >=sci-libs/blas-atlas-3.6.0
+ sci-libs/cblas-reference ) )
+ lapack? ( virtual/lapack ) )
+ doc? ( app-doc/doxygen
+ virtual/tetex )"
+
+pkg_setup() {
+ # lapack/cblas can only be used in conjunction with blas
+ if use cblas && ! use blas; then
+ die "USE=cblas requires USE=blas to be set"
+ fi
+ if use lapack && ! use blas; then
+ die "USE=lapack requires USE=blas to be set"
+ fi
+}
+
+src_compile() {
+ local myconf
+ if use blas; then
+ myconf="--with-blas=-lblas"
+ else
+ myconf="--without-blas"
+ fi
+
+ if use minimal; then
+ myconf="${myconf} --disable-comm --disable-fixed --disable-optim --disable-protocol --disable-signal --disable-srccode"
+ fi
+
+ econf $(use_enable doc html-doc) \
+ $(use_enable debug) \
+ $(use_with cblas) \
+ $(use_with lapack) \
+ $(use_with fftw fft) \
+ "${myconf}" \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "make install failed"
+ dodoc AUTHORS ChangeLog ChangeLog-2006 ChangeLog-2005 INSTALL \
+ NEWS NEWS-3.10 README TODO || die "failed to install docs"
+}