summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2006-08-17 18:25:12 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2006-08-17 18:25:12 +0000
commit0c97882d152005c2902a22a32735a9ec95bf60eb (patch)
treeae297d8f2dcaad031356e7a2ba854e91f57c237f /sci-libs
parentNote that configuration now uses eselect rather than blas-config. (diff)
downloadgentoo-2-0c97882d152005c2902a22a32735a9ec95bf60eb.tar.gz
gentoo-2-0c97882d152005c2902a22a32735a9ec95bf60eb.tar.bz2
gentoo-2-0c97882d152005c2902a22a32735a9ec95bf60eb.zip
Change einfo uses that should get read to elog.
(Portage version: 2.1.1_pre4-r4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/lapack-atlas/ChangeLog6
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.6.0-r2.ebuild42
-rw-r--r--sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild42
3 files changed, 47 insertions, 43 deletions
diff --git a/sci-libs/lapack-atlas/ChangeLog b/sci-libs/lapack-atlas/ChangeLog
index 8e9d05bf0d29..17571f8eae7e 100644
--- a/sci-libs/lapack-atlas/ChangeLog
+++ b/sci-libs/lapack-atlas/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/lapack-atlas
# Copyright 2004-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.17 2006/08/17 00:45:07 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/ChangeLog,v 1.18 2006/08/17 18:25:12 dberkholz Exp $
+
+ 17 Aug 2006; Donnie Berkholz <dberkholz@gentoo.org>;
+ lapack-atlas-3.6.0-r2.ebuild, lapack-atlas-3.7.11-r1.ebuild:
+ Change einfo uses that should get read to elog.
16 Aug 2006; Markus Dittrich <markusle@gentoo.org>
lapack-atlas-3.6.0.ebuild, lapack-atlas-3.6.0-r1.ebuild, lapack-atlas-3.6.0-r2.ebuild:
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.6.0-r2.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.6.0-r2.ebuild
index 2676465811ef..b442e228ce1a 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.6.0-r2.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.6.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.6.0-r2.ebuild,v 1.2 2006/08/17 00:45:07 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.6.0-r2.ebuild,v 1.3 2006/08/17 18:25:12 dberkholz Exp $
inherit eutils flag-o-matic toolchain-funcs fortran
@@ -42,19 +42,19 @@ RPATH="${TOP_PATH}/atlas"
ifc_info() {
if [ -z "${IFCFLAGS}" ]
then
- einfo
- einfo "You may want to set some ifc optimization flags by running this"
- einfo "ebuild as, for example:"
- einfo
- einfo "IFCFLAGS=\"-O3 -tpp7 -xW\" emerge lapack-atlas"
- einfo "(Pentium 4 exclusive optimizations)."
- einfo
- einfo "ifc defaults to -O2, with code tuned for Pentium 4, but that"
- einfo "will run on any processor."
- einfo
- einfo "Beware that ifc's -O3 is very aggressive, sometimes resulting in"
- einfo "significantly worse performance."
- einfo
+ elog
+ elog "You may want to set some ifc optimization flags by running this"
+ elog "ebuild as, for example:"
+ elog
+ elog "IFCFLAGS=\"-O3 -tpp7 -xW\" emerge lapack-atlas"
+ elog "(Pentium 4 exclusive optimizations)."
+ elog
+ elog "ifc defaults to -O2, with code tuned for Pentium 4, but that"
+ elog "will run on any processor."
+ elog
+ elog "Beware that ifc's -O3 is very aggressive, sometimes resulting in"
+ elog "significantly worse performance."
+ elog
fi
}
@@ -179,11 +179,11 @@ pkg_postinst() {
eselect lapack set atlas
fi
- einfo
- einfo "To link with ATLAS LAPACK from C or Fortran, simply use:"
- einfo
- einfo "-llapack"
- einfo
- einfo "C users: your header is /usr/include/atlas/clapack.h"
- einfo
+ elog
+ elog "To link with ATLAS LAPACK from C or Fortran, simply use:"
+ elog
+ elog "-llapack"
+ elog
+ elog "C users: your header is /usr/include/atlas/clapack.h"
+ elog
}
diff --git a/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild b/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild
index 9dd5f378eff0..802632800c5c 100644
--- a/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild
+++ b/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild,v 1.3 2006/08/04 13:37:50 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/lapack-atlas/lapack-atlas-3.7.11-r1.ebuild,v 1.4 2006/08/17 18:25:12 dberkholz Exp $
inherit eutils flag-o-matic toolchain-funcs fortran
@@ -42,19 +42,19 @@ RPATH="${TOP_PATH}/atlas"
ifc_info() {
if [ -z "${IFCFLAGS}" ]
then
- einfo
- einfo "You may want to set some ifc optimization flags by running this"
- einfo "ebuild as, for example:"
- einfo
- einfo "IFCFLAGS=\"-O3 -tpp7 -xW\" emerge lapack-atlas"
- einfo "(Pentium 4 exclusive optimizations)."
- einfo
- einfo "ifc defaults to -O2, with code tuned for Pentium 4, but that"
- einfo "will run on any processor."
- einfo
- einfo "Beware that ifc's -O3 is very aggressive, sometimes resulting in"
- einfo "significantly worse performance."
- einfo
+ elog
+ elog "You may want to set some ifc optimization flags by running this"
+ elog "ebuild as, for example:"
+ elog
+ elog "IFCFLAGS=\"-O3 -tpp7 -xW\" emerge lapack-atlas"
+ elog "(Pentium 4 exclusive optimizations)."
+ elog
+ elog "ifc defaults to -O2, with code tuned for Pentium 4, but that"
+ elog "will run on any processor."
+ elog
+ elog "Beware that ifc's -O3 is very aggressive, sometimes resulting in"
+ elog "significantly worse performance."
+ elog
fi
}
@@ -218,11 +218,11 @@ pkg_postinst() {
eselect lapack set atlas
fi
- einfo
- einfo "To link with ATLAS LAPACK from C or Fortran, simply use:"
- einfo
- einfo "-llapack"
- einfo
- einfo "C users: your header is /usr/include/atlas/clapack.h"
- einfo
+ elog
+ elog "To link with ATLAS LAPACK from C or Fortran, simply use:"
+ elog
+ elog "-llapack"
+ elog
+ elog "C users: your header is /usr/include/atlas/clapack.h"
+ elog
}