summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-05-17 12:46:53 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-05-17 12:46:53 +0000
commit10acf6e85ee529a907a4dd5a15598442e80887be (patch)
treecbd267da7772ba626648d8ac368cf48f7aa02775 /sci-libs
parentFixed compilation problems with python and gcc-4.3 (bug #219604, thanks to vo... (diff)
downloadgentoo-2-10acf6e85ee529a907a4dd5a15598442e80887be.tar.gz
gentoo-2-10acf6e85ee529a907a4dd5a15598442e80887be.tar.bz2
gentoo-2-10acf6e85ee529a907a4dd5a15598442e80887be.zip
Made stripping of -g CXXFLAG unconditional
(Portage version: 2.1.5_rc10)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itpp/ChangeLog5
-rw-r--r--sci-libs/itpp/itpp-4.0.4.ebuild12
2 files changed, 9 insertions, 8 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index 4915e97b646f..94b06f00c5d9 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.75 2008/05/17 10:12:29 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.76 2008/05/17 12:46:53 markusle Exp $
+
+ 17 May 2008; Markus Dittrich <markusle@gentoo.org> itpp-4.0.4.ebuild:
+ Made stripping of -g CXXFLAG unconditional.
17 May 2008; Markus Dittrich <markusle@gentoo.org> itpp-4.0.4.ebuild:
Added RESTRICT="strip" to prevent debug lib from being stripped.
diff --git a/sci-libs/itpp/itpp-4.0.4.ebuild b/sci-libs/itpp/itpp-4.0.4.ebuild
index fd6eaadeea55..8bd2a94edf9a 100644
--- a/sci-libs/itpp/itpp-4.0.4.ebuild
+++ b/sci-libs/itpp/itpp-4.0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.4.ebuild,v 1.6 2008/05/17 10:12:29 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.4.ebuild,v 1.7 2008/05/17 12:46:53 markusle Exp $
inherit fortran flag-o-matic
@@ -41,12 +41,10 @@ src_compile() {
# turn off performance critical debug code
append-flags -DNDEBUG
- # make sure that -g is removed with USE="debug"
- # since we've turned stripping off and a separate
- # debug lib is being built
- if use debug; then
- filter-flags -g
- fi
+ # make sure that -g is stripped always since we use
+ # RESTRICT=strip. If debug info is needed please enable
+ # the debug use flag and link against the debug *.so
+ filter-flags -g
local blas_conf="--without-blas"
local lapack_conf="--without-lapack"