summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-12-22 18:18:13 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-12-22 18:18:13 +0000
commit186ee55fb1b940c27ea050629c480a0c763dc687 (patch)
tree1f4f37b4f6d24089368d0ee575b309cc650716c8 /sci-libs
parentStable for HPPA (bug #349045). (diff)
downloadgentoo-2-186ee55fb1b940c27ea050629c480a0c763dc687.tar.gz
gentoo-2-186ee55fb1b940c27ea050629c480a0c763dc687.tar.bz2
gentoo-2-186ee55fb1b940c27ea050629c480a0c763dc687.zip
Re-enable a working test and disable the proper failing one in the autotools patch. Added static-libs flag.
(Portage version: 2.1.9.26/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/amd/ChangeLog7
-rw-r--r--sci-libs/amd/amd-2.2.0.ebuild5
-rw-r--r--sci-libs/amd/amd-2.2.1.ebuild11
-rw-r--r--sci-libs/amd/files/amd-2.2.0-autotools.patch14
4 files changed, 22 insertions, 15 deletions
diff --git a/sci-libs/amd/ChangeLog b/sci-libs/amd/ChangeLog
index 2dd5a3a784df..ad6481ef8062 100644
--- a/sci-libs/amd/ChangeLog
+++ b/sci-libs/amd/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/amd
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/ChangeLog,v 1.24 2010/12/22 07:50:47 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/ChangeLog,v 1.25 2010/12/22 18:18:12 bicatali Exp $
+
+ 22 Dec 2010; Sébastien Fabbro <bicatali@gentoo.org> amd-2.2.0.ebuild,
+ files/amd-2.2.0-autotools.patch, amd-2.2.1.ebuild:
+ Re-enable a working test and disable the proper failing one in the autotools
+ patch. Added static-libs flag.
22 Dec 2010; Justin Lecher <jlec@gentoo.org> files/2.2.1-test.patch:
Remove bad test, #348272
diff --git a/sci-libs/amd/amd-2.2.0.ebuild b/sci-libs/amd/amd-2.2.0.ebuild
index f0f9d7fc79bf..694b758c4007 100644
--- a/sci-libs/amd/amd-2.2.0.ebuild
+++ b/sci-libs/amd/amd-2.2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/amd-2.2.0.ebuild,v 1.19 2010/12/16 14:18:02 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/amd-2.2.0.ebuild,v 1.20 2010/12/22 18:18:12 bicatali Exp $
inherit autotools eutils toolchain-funcs
@@ -23,8 +23,7 @@ src_unpack() {
unpack ${A}
cd "${S}"
epatch \
- "${FILESDIR}"/${P}-autotools.patch \
- "${FILESDIR}"/${P}-tests.patch
+ "${FILESDIR}"/${P}-autotools.patch
eautoreconf
}
diff --git a/sci-libs/amd/amd-2.2.1.ebuild b/sci-libs/amd/amd-2.2.1.ebuild
index f949552045b8..0743b25c3186 100644
--- a/sci-libs/amd/amd-2.2.1.ebuild
+++ b/sci-libs/amd/amd-2.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/amd-2.2.1.ebuild,v 1.4 2010/12/16 14:18:02 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/amd/amd-2.2.1.ebuild,v 1.5 2010/12/22 18:18:12 bicatali Exp $
EAPI="3"
@@ -15,7 +15,7 @@ SRC_URI="http://www.cise.ufl.edu/research/sparse/${PN}/${MY_PN}-${PV}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
-IUSE="doc"
+IUSE="doc static-libs"
RDEPEND="sci-libs/ufconfig"
DEPEND="${RDEPEND}"
@@ -24,11 +24,14 @@ S="${WORKDIR}/${MY_PN}"
src_prepare() {
epatch \
- "${FILESDIR}"/${PN}-2.2.0-autotools.patch \
- "${FILESDIR}"/${PV}-test.patch
+ "${FILESDIR}"/${PN}-2.2.0-autotools.patch
eautoreconf
}
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc README.txt Doc/ChangeLog || die "dodoc failed"
diff --git a/sci-libs/amd/files/amd-2.2.0-autotools.patch b/sci-libs/amd/files/amd-2.2.0-autotools.patch
index 8e53f9cf42f4..6ecb39fb3d9e 100644
--- a/sci-libs/amd/files/amd-2.2.0-autotools.patch
+++ b/sci-libs/amd/files/amd-2.2.0-autotools.patch
@@ -26,24 +26,24 @@ diff -Nur ../AMD.orig/Demo/Makefile.am ./Demo/Makefile.am
+ amd_simple \
+ amd_demo \
+ amd_demo2 \
++ amd_l_demo \
+ amd_f77demo \
-+ amd_f77simple \
-+ amd_f77cross
++ amd_f77simple
+# buggy demo
-+# amd_l_demo
++# amd_f77cross
+
+amd_demo_SOURCES = amd_demo.c
-+#amd_l_demo_SOURCES = amd_l_demo.c
++amd_l_demo_SOURCES = amd_l_demo.c
+amd_demo2_SOURCES = amd_demo2.c
+amd_simple_SOURCES = amd_simple.c
-+amd_f77demo_SOURCES = amd_f77demo.f
+
++amd_f77demo_SOURCES = amd_f77demo.f
+amd_f77demo_LDADD = $(LDADD) $(top_builddir)/Source/libamdf77.la
+amd_f77simple_SOURCES = amd_f77simple.f
+amd_f77simple_LDADD = $(LDADD) $(top_builddir)/Source/libamdf77.la
+amd_f77wrapper_CPPFLAGS = -DDINT
-+amd_f77cross_SOURCES = amd_f77cross.f amd_f77wrapper.f
-+amd_f77cross_LDADD = $(LDADD) $(top_builddir)/Source/libamdf77.la
++#amd_f77cross_SOURCES = amd_f77cross.f amd_f77wrapper.f
++#amd_f77cross_LDADD = $(LDADD) $(top_builddir)/Source/libamdf77.la
+
+check-local: $(check_PROGRAMS)
+ @for i in $(check_PROGRAMS); do \