summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2008-01-04 05:24:28 +0000
committerSteve Arnold <nerdboy@gentoo.org>2008-01-04 05:24:28 +0000
commit2780ef1986a7fce9e5894f234fede895d710c5f4 (patch)
treeff2c217aeb05f493014a7691c206ad17f1f94845 /sci-libs
parentprune unused versions (diff)
downloadgentoo-2-2780ef1986a7fce9e5894f234fede895d710c5f4.tar.gz
gentoo-2-2780ef1986a7fce9e5894f234fede895d710c5f4.tar.bz2
gentoo-2-2780ef1986a7fce9e5894f234fede895d710c5f4.zip
fixed mysql borkage
(Portage version: 2.1.4_rc12)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gdal/ChangeLog5
-rw-r--r--sci-libs/gdal/gdal-1.4.2.ebuild9
2 files changed, 9 insertions, 5 deletions
diff --git a/sci-libs/gdal/ChangeLog b/sci-libs/gdal/ChangeLog
index d5d3ef0accd0..45d9af163471 100644
--- a/sci-libs/gdal/ChangeLog
+++ b/sci-libs/gdal/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sci-libs/gdal
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.33 2008/01/04 04:08:15 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/ChangeLog,v 1.34 2008/01/04 05:24:28 nerdboy Exp $
+
+ 04 Jan 2008; Steve Arnold <nerdboy@gentoo.org> gdal-1.4.2.ebuild:
+ fixed mysql borkage; no idea what happened...
04 Jan 2008; Steve Arnold <nerdboy@gentoo.org>
-files/gdal-1.2.6-installpathfix.patch,
diff --git a/sci-libs/gdal/gdal-1.4.2.ebuild b/sci-libs/gdal/gdal-1.4.2.ebuild
index fd93ad3ebc4e..5cfb8f110e7a 100644
--- a/sci-libs/gdal/gdal-1.4.2.ebuild
+++ b/sci-libs/gdal/gdal-1.4.2.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.4.2.ebuild,v 1.2 2008/01/04 04:08:15 nerdboy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gdal/gdal-1.4.2.ebuild,v 1.3 2008/01/04 05:24:28 nerdboy Exp $
inherit eutils libtool distutils toolchain-funcs
-IUSE="jpeg png geos gif jpeg2k netcdf hdf hdf5 python ruby postgres \
- odbc sqlite ogdi fits gml doc debug"
+IUSE="debug doc fits geos gif gml hdf hdf5 jpeg jpeg2k mysql netcdf \
+ odbc png ogdi postgres python ruby sqlite"
DESCRIPTION="GDAL is a translator library for raster geospatial data formats (includes OGR support)"
HOMEPAGE="http://www.gdal.org/"
@@ -36,6 +36,7 @@ DEPEND=">=sys-libs/zlib-1.1.4
hdf? ( sci-libs/hdf )
)
jpeg2k? ( media-libs/jasper )
+ mysql? ( virtual/mysql )
odbc? ( dev-db/unixODBC )
geos? ( >=sci-libs/geos-2.2.1 )
sqlite? ( >=dev-db/sqlite-3 )
@@ -106,7 +107,7 @@ src_compile() {
econf ${pkg_conf} ${use_conf} || die "econf failed"
# parallel makes fail on the ogr stuff (C++, what can I say?)
# also failing with gcc4 in libcsf
- make || die "make failed"
+ emake -j1 || die "make failed"
if useq ruby ; then
cd "${S}"/swig
make build || die "make ruby failed"