summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-15 12:44:36 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-15 12:44:36 +0000
commit332363d90baf3e6da42f6b558fbb48352829965e (patch)
tree9fea3fc6e0bf812b94225fa07c18e41a88b830bd /sci-libs
parentImport the live ebuild. (diff)
downloadgentoo-2-332363d90baf3e6da42f6b558fbb48352829965e.tar.gz
gentoo-2-332363d90baf3e6da42f6b558fbb48352829965e.tar.bz2
gentoo-2-332363d90baf3e6da42f6b558fbb48352829965e.zip
Import the live ebuild.
(Portage version: 2.2.0_alpha148/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/libh2o/ChangeLog7
-rw-r--r--sci-libs/libh2o/libh2o-9999.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/sci-libs/libh2o/ChangeLog b/sci-libs/libh2o/ChangeLog
index d8d2fefffaae..a1ab14b085bd 100644
--- a/sci-libs/libh2o/ChangeLog
+++ b/sci-libs/libh2o/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/libh2o
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/libh2o/ChangeLog,v 1.5 2012/08/24 18:48:34 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libh2o/ChangeLog,v 1.6 2012/12/15 12:44:36 mgorny Exp $
+
+*libh2o-9999 (15 Dec 2012)
+
+ 15 Dec 2012; Michał Górny <mgorny@gentoo.org> +libh2o-9999.ebuild:
+ Import the live ebuild.
24 Aug 2012; Michał Górny <mgorny@gentoo.org> -libh2o-0.1.ebuild,
-libh2o-0.2.ebuild, libh2o-0.2.1.ebuild:
diff --git a/sci-libs/libh2o/libh2o-9999.ebuild b/sci-libs/libh2o/libh2o-9999.ebuild
new file mode 100644
index 000000000000..f07484433a1a
--- /dev/null
+++ b/sci-libs/libh2o/libh2o-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/libh2o/libh2o-9999.ebuild,v 1.1 2012/12/15 12:44:36 mgorny Exp $
+
+EAPI=4
+
+#if LIVE
+AUTOTOOLS_AUTORECONF=yes
+EGIT_REPO_URI="http://bitbucket.org/mgorny/${PN}.git"
+
+inherit git-2
+#endif
+
+inherit autotools-utils
+
+DESCRIPTION="Library of routines for IF97 water & steam properties"
+HOMEPAGE="https://bitbucket.org/mgorny/libh2o/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug static-libs"
+
+DEPEND="virtual/pkgconfig"
+
+#if LIVE
+KEYWORDS=
+SRC_URI=
+#endif
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable debug)
+ )
+
+ autotools-utils_src_configure
+}