summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-01-24 15:18:58 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-01-24 15:18:58 +0000
commit3fd0bb67ea53d50003fda03d925444cf32c1fdaf (patch)
treea94129d785947a4783b8f8a02ac3875dbf1acc28 /sci-libs
parentAdded back the ~hppa keyword. (diff)
downloadgentoo-2-3fd0bb67ea53d50003fda03d925444cf32c1fdaf.tar.gz
gentoo-2-3fd0bb67ea53d50003fda03d925444cf32c1fdaf.tar.bz2
gentoo-2-3fd0bb67ea53d50003fda03d925444cf32c1fdaf.zip
Moved smem binary to examples in doc directory (fixing bug #207023). Now supports library versioning
(Portage version: 2.1.4)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cfitsio/ChangeLog9
-rw-r--r--sci-libs/cfitsio/cfitsio-3.060.ebuild13
-rw-r--r--sci-libs/cfitsio/files/cfitsio-3.060-autotools.patch101
3 files changed, 65 insertions, 58 deletions
diff --git a/sci-libs/cfitsio/ChangeLog b/sci-libs/cfitsio/ChangeLog
index e3843fa98b2f..27a580ad9617 100644
--- a/sci-libs/cfitsio/ChangeLog
+++ b/sci-libs/cfitsio/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/cfitsio
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cfitsio/ChangeLog,v 1.12 2007/09/10 20:27:58 bicatali Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cfitsio/ChangeLog,v 1.13 2008/01/24 15:18:58 bicatali Exp $
+
+ 24 Jan 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ files/cfitsio-3.060-autotools.patch, cfitsio-3.060.ebuild:
+ Moved smem binary to examples in doc directory (fixing bug #207023). Now
+ supports library versioning
*cfitsio-3.060 (10 Sep 2007)
diff --git a/sci-libs/cfitsio/cfitsio-3.060.ebuild b/sci-libs/cfitsio/cfitsio-3.060.ebuild
index 581a0083fc8a..207cc499de54 100644
--- a/sci-libs/cfitsio/cfitsio-3.060.ebuild
+++ b/sci-libs/cfitsio/cfitsio-3.060.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cfitsio/cfitsio-3.060.ebuild,v 1.1 2007/09/10 20:27:58 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cfitsio/cfitsio-3.060.ebuild,v 1.2 2008/01/24 15:18:58 bicatali Exp $
inherit eutils fortran autotools
@@ -15,7 +15,7 @@ IUSE="doc fortran"
DEPEND="fortran? ( dev-lang/cfortran )"
-S=${WORKDIR}/${PN}
+S="${WORKDIR}/${PN}"
pkg_setup() {
if use fortran; then
@@ -27,11 +27,12 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
- # sed to avoid internal cfortran
+ # avoid internal cfortran
if use fortran; then
sed -i \
-e 's:"cfortran.h":<cfortran.h>:' \
f77_wrap.h || die "sed fortran failed"
+ mv cfortran.h cfortran.h.disabled
fi
epatch "${FILESDIR}"/${P}-autotools.patch
eautoreconf
@@ -58,8 +59,8 @@ src_test() {
src_install () {
emake DESTDIR="${D}" install || die "emake install failed"
dodoc changes.txt README License.txt cfitsio.doc || die "dodoc failed"
- insinto /usr/share/doc/${PF}
- doins cookbook.c || die "install cookbook failed"
+ insinto /usr/share/doc/${PF}/examples
+ doins cookbook.c testprog.c speed.c smem.c || die "install examples failed"
use doc && dodoc cfitsio.ps quick.ps
if use fortran; then
doins cookbook.f || die "install cookbook failed"
diff --git a/sci-libs/cfitsio/files/cfitsio-3.060-autotools.patch b/sci-libs/cfitsio/files/cfitsio-3.060-autotools.patch
index 2155ef48c640..f454bfca83ce 100644
--- a/sci-libs/cfitsio/files/cfitsio-3.060-autotools.patch
+++ b/sci-libs/cfitsio/files/cfitsio-3.060-autotools.patch
@@ -1,5 +1,52 @@
+--- Makefile.am 1970-01-01 01:00:00.000000000 +0100
++++ Makefile.am 2008-01-24 14:48:14.000000000 +0000
+@@ -0,0 +1,44 @@
++lib_LTLIBRARIES = libcfitsio.la
++
++C_SOURCES = \
++ buffers.c cfileio.c checksum.c compress.c drvrfile.c drvrmem.c \
++ drvrnet.c drvrsmem.c drvrgsiftp.c editcol.c edithdu.c eval_l.c \
++ eval_y.c eval_f.c fitscore.c getcol.c getcolb.c getcold.c getcole.c \
++ getcoli.c getcolj.c getcolk.c getcoll.c getcols.c getcolsb.c \
++ getcoluk.c getcolui.c getcoluj.c getkey.c group.c grparser.c \
++ histo.c iraffits.c \
++ modkey.c putcol.c putcolb.c putcold.c putcole.c putcoli.c \
++ putcolj.c putcolk.c putcoluk.c putcoll.c putcols.c putcolsb.c \
++ putcolu.c putcolui.c putcoluj.c putkey.c region.c scalnull.c \
++ swapproc.c wcssub.c wcsutil.c imcompress.c quantize.c ricecomp.c \
++ pliocomp.c fits_hcompress.c fits_hdecompress.c
++
++F77_SOURCES=
++if ENABLE_FORTRAN
++F77_SOURCES += f77_wrap1.c f77_wrap2.c f77_wrap3.c f77_wrap4.c f77_wrap.h
++endif
++
++include_HEADERS = fitsio.h fitsio2.h longnam.h drvrsmem.h
++libcfitsio_la_SOURCES = $(C_SOURCES) $(F77_SOURCES) $(include_HEADERS)
++libcfitsio_la_LDFLAGS = -no-undefined -version-info 3:0:0
++
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = cfitsio.pc
++
++LDADD = libcfitsio.la
++noinst_PROGRAMS = testprog speed cookbook smem
++bin_PROGRAMS = fitscopy imcopy listhead
++
++testprog_SOURCES = testprog.c
++speed_SOURCES = speed.c
++cookbook_SOURCES = cookbook.c
++smem_SOURCES = smem.c
++
++fitscopy_SOURCES = fitscopy.c
++listhead_SOURCES = listhead.c
++imcopy_SOURCES = imcopy.c
++
++if ENABLE_FORTRAN
++noinst_PROGRAMS += testf77
++testf77_SOURCES = testf77.f
++endif
--- configure.ac 1970-01-01 01:00:00.000000000 +0100
-+++ configure.ac 2007-09-10 19:04:36.382298581 +0100
++++ configure.ac 2008-01-24 14:46:39.000000000 +0000
@@ -0,0 +1,230 @@
+AC_PREREQ(2.59)
+AC_INIT(cfitsio, 3.060, pence@tetra.gsfc.nasa.gov)
@@ -7,7 +54,7 @@
+AM_INIT_AUTOMAKE([foreign])
+
+AC_PROG_LIBTOOL
-+
++SHARED_VERSION_INFO="3:0:0"
+AC_MSG_CHECKING([whether to enable fortran api])
+AC_ARG_ENABLE([fortran],
+ AS_HELP_STRING([--enable-fortran], [Build the fortran API]),
@@ -231,54 +278,8 @@
+AC_CHECK_LIB(m, cos)
+AC_CONFIG_FILES([Makefile cfitsio.pc])
+AC_OUTPUT
---- Makefile.am 1970-01-01 01:00:00.000000000 +0100
-+++ Makefile.am 2007-09-10 16:02:13.520646341 +0100
-@@ -0,0 +1,43 @@
-+lib_LTLIBRARIES = libcfitsio.la
-+
-+C_SOURCES = \
-+ buffers.c cfileio.c checksum.c compress.c drvrfile.c drvrmem.c \
-+ drvrnet.c drvrsmem.c drvrgsiftp.c editcol.c edithdu.c eval_l.c \
-+ eval_y.c eval_f.c fitscore.c getcol.c getcolb.c getcold.c getcole.c \
-+ getcoli.c getcolj.c getcolk.c getcoll.c getcols.c getcolsb.c \
-+ getcoluk.c getcolui.c getcoluj.c getkey.c group.c grparser.c \
-+ histo.c iraffits.c \
-+ modkey.c putcol.c putcolb.c putcold.c putcole.c putcoli.c \
-+ putcolj.c putcolk.c putcoluk.c putcoll.c putcols.c putcolsb.c \
-+ putcolu.c putcolui.c putcoluj.c putkey.c region.c scalnull.c \
-+ swapproc.c wcssub.c wcsutil.c imcompress.c quantize.c ricecomp.c \
-+ pliocomp.c fits_hcompress.c fits_hdecompress.c
-+
-+F77_SOURCES=
-+if ENABLE_FORTRAN
-+F77_SOURCES += f77_wrap1.c f77_wrap2.c f77_wrap3.c f77_wrap4.c f77_wrap.h
-+endif
-+
-+include_HEADERS = fitsio.h fitsio2.h longnam.h drvrsmem.h
-+libcfitsio_la_SOURCES = $(C_SOURCES) $(F77_SOURCES) $(include_HEADERS)
-+
-+pkgconfigdir = $(libdir)/pkgconfig
-+pkgconfig_DATA = cfitsio.pc
-+
-+LDADD = libcfitsio.la
-+noinst_PROGRAMS = testprog speed cookbook
-+bin_PROGRAMS = fitscopy imcopy listhead smem
-+
-+testprog_SOURCES = testprog.c
-+speed_SOURCES = speed.c
-+cookbook_SOURCES = cookbook.c
-+
-+fitscopy_SOURCES = fitscopy.c
-+listhead_SOURCES = listhead.c
-+imcopy_SOURCES = imcopy.c
-+smem_SOURCES = smem.c
-+
-+if ENABLE_FORTRAN
-+noinst_PROGRAMS += testf77
-+testf77_SOURCES = testf77.f
-+endif
---- cfitsio.pc.in.orig 2007-09-05 12:35:29.153211202 +0100
-+++ cfitsio.pc.in 2007-09-05 12:30:31.664258273 +0100
+--- cfitsio.pc.in.orig 2006-07-24 15:35:56.000000000 +0100
++++ cfitsio.pc.in 2008-01-24 14:23:31.000000000 +0000
@@ -1,10 +1,10 @@
prefix=@prefix@
exec_prefix=@exec_prefix@