summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2006-03-21 19:29:10 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2006-03-21 19:29:10 +0000
commit443efaf753bbac8edb17982f1d0c57192128e591 (patch)
treef4da661db512596011610961f50356773af4d92d /sci-libs
parentMake net-tools a dependency only for linux kernel. (diff)
downloadgentoo-2-443efaf753bbac8edb17982f1d0c57192128e591.tar.gz
gentoo-2-443efaf753bbac8edb17982f1d0c57192128e591.tar.bz2
gentoo-2-443efaf753bbac8edb17982f1d0c57192128e591.zip
(#121855) Allow compilation with gcc-4. Also at least partially fix compilation with non-gcc compilers (e.g. ifc).
(Portage version: 2.1_pre6-r3)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/blas-atlas/ChangeLog7
-rw-r--r--sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild19
-rw-r--r--sci-libs/blas-atlas/files/3.7.11-allow-any-gcc-version.patch15
3 files changed, 38 insertions, 3 deletions
diff --git a/sci-libs/blas-atlas/ChangeLog b/sci-libs/blas-atlas/ChangeLog
index 9b442f9ae4d1..c307df091008 100644
--- a/sci-libs/blas-atlas/ChangeLog
+++ b/sci-libs/blas-atlas/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/blas-atlas
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.19 2006/02/24 04:07:14 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/ChangeLog,v 1.20 2006/03/21 19:29:10 spyderous Exp $
+
+ 21 Mar 2006; Donnie Berkholz <spyderous@gentoo.org>;
+ +files/3.7.11-allow-any-gcc-version.patch, blas-atlas-3.7.11.ebuild:
+ (#121855) Allow compilation with gcc-4. Also at least partially fix
+ compilation with non-gcc compilers (e.g. ifc).
24 Feb 2006; Markus Dittrich <markusle@gentoo.org>
blas-atlas-3.6.0-r1.ebuild:
diff --git a/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild b/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild
index b8cb5c783388..0d201f1418a8 100644
--- a/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild
+++ b/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild,v 1.4 2006/02/02 16:23:03 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/blas-atlas/blas-atlas-3.7.11.ebuild,v 1.5 2006/03/21 19:29:10 spyderous Exp $
inherit eutils toolchain-funcs fortran
@@ -24,19 +24,34 @@ PROVIDE="virtual/blas"
S="${WORKDIR}/ATLAS"
RPATH="${DESTTREE}/$(get_libdir)/blas"
-FORTRAN="g77"
+FORTRAN="g77 gfortran"
src_unpack() {
unpack ${A}
cd ${S}
epatch "${FILESDIR}"/unbuffered.patch
+ epatch "${FILESDIR}"/${PV}-allow-any-gcc-version.patch
epatch "${DISTDIR}"/atlas3.6.0-shared-libs.1.patch.bz2
sed -i \
-e "s:ASM:ASM VOLATILE:" \
include/contrib/camm_dpa.h \
|| die "sed failed to fix clobbering"
+ sed -i \
+ -e "s:\(\t./xconfig\):\1 -m $(tc-getCC) -c $(tc-getCC) -f ${FORTRANC}:g" \
+ ${S}/Makefile \
+ || die "Failed to fix compilers"
+
+ if [[ $(gcc-major-version) -ge 4 ]]; then
+ einfo "Updating Makefiles for gcc-4"
+ sed -i \
+ -e "s:g2c:gfortran:g" \
+ ${S}/Make.top \
+ ${S}/makes/Make.lib \
+ || die "Failed to update for gcc-4"
+ fi
+
cp "${FILESDIR}"/war "${S}"
chmod a+x "${S}"/war
}
diff --git a/sci-libs/blas-atlas/files/3.7.11-allow-any-gcc-version.patch b/sci-libs/blas-atlas/files/3.7.11-allow-any-gcc-version.patch
new file mode 100644
index 000000000000..6dfd33ab74af
--- /dev/null
+++ b/sci-libs/blas-atlas/files/3.7.11-allow-any-gcc-version.patch
@@ -0,0 +1,15 @@
+diff -urN ATLAS.orig/config.c ATLAS/config.c
+--- ATLAS.orig/config.c 2006-01-16 19:08:16.000000000 -0800
++++ ATLAS/config.c 2006-01-16 19:27:22.000000000 -0800
+@@ -712,11 +712,6 @@
+ gcc, major, minor, patch);
+ if (major == -1)
+ iret = 0;
+- else if ( MachIsX86(mach) ) /* don't use gcc 2.96 - 3.0 */
+- {
+- if ((major == 2 && minor < 96) || (major == 3 && minor > 1))
+- iret = 1;
+- }
+ else if (mach == IA64Itan || mach == IA64Itan2 || MachIsUS(mach) ||
+ mach == Dec21164 || mach == Dec21264)
+ {