summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-27 10:39:28 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-27 10:39:28 +0000
commit4451778de0a9f898de90687c02694638071e05d5 (patch)
tree6a15c8267d80a9cfe25fa993f849a4e49c56c14f /sci-libs
parentVersion bump wrt #242860 (diff)
downloadgentoo-2-4451778de0a9f898de90687c02694638071e05d5.tar.gz
gentoo-2-4451778de0a9f898de90687c02694638071e05d5.tar.bz2
gentoo-2-4451778de0a9f898de90687c02694638071e05d5.zip
Fixed for older libtool versions and forcing posix threads in the ebuild if gcc<4.2, closing bug #248687
(Portage version: 2.2_rc16/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/ChangeLog6
-rw-r--r--sci-libs/fftw/fftw-3.2.ebuild31
2 files changed, 19 insertions, 18 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index ce5aec033233..f7ba701c8629 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/fftw
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.74 2008/11/24 11:02:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.75 2008/11/27 10:39:28 bicatali Exp $
+
+ 27 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org> fftw-3.2.ebuild:
+ Fixed for older libtool versions and forcing posix threads in the ebuild
+ if gcc<4.2, closing bug #248687
*fftw-3.2 (21 Nov 2008)
diff --git a/sci-libs/fftw/fftw-3.2.ebuild b/sci-libs/fftw/fftw-3.2.ebuild
index a3556fe09eae..6dc56fa75194 100644
--- a/sci-libs/fftw/fftw-3.2.ebuild
+++ b/sci-libs/fftw/fftw-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.ebuild,v 1.1 2008/11/24 11:02:05 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.ebuild,v 1.2 2008/11/27 10:39:28 bicatali Exp $
inherit flag-o-matic eutils toolchain-funcs autotools fortran
@@ -14,6 +14,12 @@ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
IUSE="altivec doc fortran openmp sse sse2 threads"
pkg_setup() {
+ FFTW_THREADS="--disable-threads --disable-openmp"
+ if use openmp; then
+ FFTW_THREADS="--disable-threads --enable-openmp"
+ elif use threads; then
+ FFTW_THREADS="--enable-threads --disable-openmp"
+ fi
if use openmp &&
[[ $(tc-getCC)$ == *gcc* ]] &&
( [[ $(gcc-major-version)$(gcc-minor-version) -lt 42 ]] ||
@@ -22,8 +28,9 @@ pkg_setup() {
ewarn "You are using gcc and OpenMP is only available with gcc >= 4.2 "
ewarn "If you want to build fftw with OpenMP, abort now,"
ewarn "and switch CC to an OpenMP capable compiler"
- ewarn "Otherwise the configure script will select POSIX threads."
+ ewarn "Otherwise, we will build using POSIX threads."
epause 5
+ FFTW_THREADS="--enable-threads --disable-openmp"
fi
FORTRAN="gfortran ifc g77"
use fortran && fortran_pkg_setup
@@ -39,6 +46,9 @@ src_unpack() {
# fix info file
sed -e 's/Texinfo documentation system/Libraries/' \
-i doc/fftw3.info || die "failed to fix info file"
+
+ rm m4/lt* m4/libtool.m4
+
AT_M4DIR=m4 eautoreconf
cd "${WORKDIR}"
mv ${P} ${P}-single
@@ -52,22 +62,9 @@ src_compile() {
local myconfcommon="
--enable-shared
- $(use_enable threads)
- $(use_enable fortran)"
+ $(use_enable fortran)
+ ${FFTW_THREADS}"
- if use openmp; then
- myconfcommon="${myconfcommon}
- --disable-threads
- --enable-openmp"
- elif use threads; then
- myconfcommon="${myconfcommon}
- --enable-threads
- --disable-openmp"
- else
- myconfcommon="${myconfcommon}
- --disable-threads
- --disable-openmp"
- fi
local myconfsingle=""
local myconfdouble=""
local myconflongdouble=""