summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2011-06-12 17:00:25 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2011-06-12 17:00:25 +0000
commit6155d6f41bd9564eb2a9f728c8d090fa3b0b7cb4 (patch)
tree5566becbb764841882f1224a89133cb990442701 /sci-libs
parentAdd dependency on app-vim/align, update HOMEPAGE, and remove old. (diff)
downloadgentoo-2-6155d6f41bd9564eb2a9f728c8d090fa3b0b7cb4.tar.gz
gentoo-2-6155d6f41bd9564eb2a9f728c8d090fa3b0b7cb4.tar.bz2
gentoo-2-6155d6f41bd9564eb2a9f728c8d090fa3b0b7cb4.zip
Move to eapi4. Punt .la files. Run eselect only if really required for pretend phase.
(Portage version: 2.2.0_alpha40/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/gsl/ChangeLog6
-rw-r--r--sci-libs/gsl/gsl-1.15.ebuild33
2 files changed, 26 insertions, 13 deletions
diff --git a/sci-libs/gsl/ChangeLog b/sci-libs/gsl/ChangeLog
index 30c9c6309817..1238fd416976 100644
--- a/sci-libs/gsl/ChangeLog
+++ b/sci-libs/gsl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/gsl
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.80 2011/05/21 10:18:03 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/ChangeLog,v 1.81 2011/06/12 17:00:25 scarabeus Exp $
+
+ 12 Jun 2011; Tomáš Chvátal <scarabeus@gentoo.org> gsl-1.15.ebuild:
+ Move to eapi4. Punt .la files. Run eselect only if really required for
+ pretend phase.
*gsl-1.15 (21 May 2011)
diff --git a/sci-libs/gsl/gsl-1.15.ebuild b/sci-libs/gsl/gsl-1.15.ebuild
index 763073162f75..6b89346fc583 100644
--- a/sci-libs/gsl/gsl-1.15.ebuild
+++ b/sci-libs/gsl/gsl-1.15.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.15.ebuild,v 1.1 2011/05/21 10:18:03 ottxor Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/gsl/gsl-1.15.ebuild,v 1.2 2011/06/12 17:00:25 scarabeus Exp $
-EAPI="3"
+EAPI=4
inherit eutils flag-o-matic autotools toolchain-funcs
@@ -20,16 +20,24 @@ DEPEND="${RDEPEND}
app-admin/eselect-cblas
dev-util/pkgconfig"
-pkg_setup() {
- ESELECT_PROF="gsl"
+DOCS=( AUTHORS BUGS ChangeLog NEWS README THANKS TODO )
+
+pkg_pretend() {
# prevent to use external cblas from a previously installed gsl
- local current_lib=$(eselect cblas show | cut -d' ' -f2)
- if use cblas-external && [[ ${current_lib} == gsl ]]; then
- ewarn "USE flag cblas-external is set: linking gsl with an external cblas."
- ewarn "However the current selected external cblas is gsl."
- ewarn "Please install and/or eselect another cblas"
- die "Circular gsl dependency"
+ local current_lib
+ if use cblas-external; then
+ current_lib=$(eselect cblas show | cut -d' ' -f2)
+ if [[ ${current_lib} == gsl ]]; then
+ ewarn "USE flag cblas-external is set: linking gsl with an external cblas."
+ ewarn "However the current selected external cblas is gsl."
+ ewarn "Please install and/or eselect another cblas"
+ die "Circular gsl dependency"
+ fi
fi
+}
+
+pkg_setup() {
+ ESELECT_PROF="gsl"
# bug 349005
[[ $(tc-getCC)$ == *gcc* ]] && \
@@ -63,8 +71,9 @@ src_configure() {
}
src_install() {
- emake install DESTDIR="${D}" || die "emake install failed."
- dodoc AUTHORS BUGS ChangeLog NEWS README THANKS TODO
+ default
+
+ find "${ED}" -name '*.la' -exec rm -f {} +
# take care of pkgconfig file for cblas implementation.
sed -e "s/@LIBDIR@/$(get_libdir)/" \