summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-19 08:58:02 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-19 08:58:02 +0000
commit64308d92a2df48beb2a16bd4dcefb7277c9b77f7 (patch)
tree7e09524744c001052adfe25fc25969200924f1d0 /sci-libs
parentStable for x86, wrt bug #530652 (diff)
downloadgentoo-2-64308d92a2df48beb2a16bd4dcefb7277c9b77f7.tar.gz
gentoo-2-64308d92a2df48beb2a16bd4dcefb7277c9b77f7.tar.bz2
gentoo-2-64308d92a2df48beb2a16bd4dcefb7277c9b77f7.zip
Drop old, fixes #412145, #456012, #478620, #483340 and #496092
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/scipy/ChangeLog6
-rw-r--r--sci-libs/scipy/scipy-0.12.1.ebuild135
-rw-r--r--sci-libs/scipy/scipy-0.13.2.ebuild137
-rw-r--r--sci-libs/scipy/scipy-0.13.3.ebuild140
-rw-r--r--sci-libs/scipy/scipy-0.14.0.ebuild140
5 files changed, 5 insertions, 553 deletions
diff --git a/sci-libs/scipy/ChangeLog b/sci-libs/scipy/ChangeLog
index 7671dea74f95..bf4738390e31 100644
--- a/sci-libs/scipy/ChangeLog
+++ b/sci-libs/scipy/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/scipy
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.120 2015/02/19 08:25:29 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/ChangeLog,v 1.121 2015/02/19 08:58:02 jlec Exp $
+
+ 19 Feb 2015; Justin Lecher <jlec@gentoo.org> -scipy-0.12.1.ebuild,
+ -scipy-0.13.2.ebuild, -scipy-0.13.3.ebuild, -scipy-0.14.0.ebuild:
+ Drop old, fixes #412145, #456012, #478620, #483340 and #496092
*scipy-0.15.0 (19 Feb 2015)
diff --git a/sci-libs/scipy/scipy-0.12.1.ebuild b/sci-libs/scipy/scipy-0.12.1.ebuild
deleted file mode 100644
index 34dde8de92c8..000000000000
--- a/sci-libs/scipy/scipy-0.12.1.ebuild
+++ /dev/null
@@ -1,135 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.12.1.ebuild,v 1.6 2014/07/22 17:47:47 zerochaos Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit eutils fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${PN}/${PN}-html.zip -> ${P}-html.zip
- http://docs.scipy.org/doc/${PN}/${PN}-ref.pdf -> ${P}-ref.pdf
- )"
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="doc sparse test"
-KEYWORDS="amd64 ~arm ppc ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- dev-python/numpy[lapack,${PYTHON_USEDEP}]
- sci-libs/arpack
- virtual/cblas
- virtual/lapack
- sparse? ( sci-libs/umfpack )"
-DEPEND="${CDEPEND}
- dev-lang/swig
- dev-python/cython[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND="${CDEPEND}
- virtual/python-imaging[${PYTHON_USEDEP}]"
-
-DOCS=( HACKING.rst.txt README.txt THANKS.txt LATEST.txt TOCHANGE.txt )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${P}-html.zip -d html || die
- fi
-}
-
-pc_incdir() {
- $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//'
-}
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//'
-}
-
-python_prepare_all() {
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use sparse && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
-
- local PATCHES=(
- "${FILESDIR}"/${PN}-0.12.0-gerqf.patch
- "${FILESDIR}"/${PN}-0.12.0-blitz.patch
- "${FILESDIR}"/${PN}-0.12.0-restore-sys-argv.patch
- "${FILESDIR}"/${PN}-0.12.0-cephes-missing-include.patch
- )
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- distutils_install_for_testing ${SCIPY_FCONFIG}
- cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
- # nasty hack to remove weave tests because it is not python3 compat
- [[ ${TEST_DIR} =~ python3 ]] && rm -r "${TEST_DIR}"/lib/scipy/weave
-#r = scipy.test('full', verbose=10)
- "${EPYTHON}" -c "
-import scipy, sys
-r = scipy.test('fast',verbose=2)
-sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r "${WORKDIR}"/html/.
- dodoc "${DISTDIR}"/${P}*pdf
- fi
- distutils-r1_python_install_all
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer. Example:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}
diff --git a/sci-libs/scipy/scipy-0.13.2.ebuild b/sci-libs/scipy/scipy-0.13.2.ebuild
deleted file mode 100644
index 950ee7f6ed81..000000000000
--- a/sci-libs/scipy/scipy-0.13.2.ebuild
+++ /dev/null
@@ -1,137 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.13.2.ebuild,v 1.2 2014/07/22 17:47:47 zerochaos Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit eutils fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${PN}-0.13.0/${PN}-html.zip -> ${PN}-0.13.0-html.zip
- http://docs.scipy.org/doc/${PN}-0.13.0/${PN}-ref.pdf -> ${PN}-0.13.0-ref.pdf
- )"
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="doc sparse test"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- dev-python/numpy[lapack,${PYTHON_USEDEP}]
- sci-libs/arpack
- virtual/cblas
- virtual/lapack
- sparse? ( sci-libs/umfpack )"
-DEPEND="${CDEPEND}
- dev-lang/swig
- >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-RDEPEND="${CDEPEND}
- virtual/python-imaging[${PYTHON_USEDEP}]"
-
-DOCS=( HACKING.rst.txt THANKS.txt )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${PN}-0.13.0-html.zip -d html || die
- fi
-}
-
-pc_incdir() {
- $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//'
-}
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)[ ]*//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
- | sort | uniq | tr '\n' ','
-}
-
-python_prepare_all() {
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use sparse && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
-
- # Drop hashes to force rebuild of cython based .c code
- rm cythonize.dat || die
-
- local PATCHES=(
- "${FILESDIR}"/${PN}-0.12.0-blitz.patch
- "${FILESDIR}"/${PN}-0.12.0-restore-sys-argv.patch
- "${FILESDIR}"/${PN}-0.12.0-cephes-missing-include.patch
- )
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- ${EPYTHON} tools/cythonize.py || die
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
- distutils_install_for_testing ${SCIPY_FCONFIG}
- cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
- "${EPYTHON}" -c "
-import scipy, sys
-r = scipy.test('fast',verbose=2)
-sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r "${WORKDIR}"/html/.
- dodoc "${DISTDIR}"/${PN}*pdf
- fi
- distutils-r1_python_install_all
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer. Example:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}
diff --git a/sci-libs/scipy/scipy-0.13.3.ebuild b/sci-libs/scipy/scipy-0.13.3.ebuild
deleted file mode 100644
index 432c5c83d1fe..000000000000
--- a/sci-libs/scipy/scipy-0.13.3.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.13.3.ebuild,v 1.5 2014/07/22 17:47:47 zerochaos Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-
-inherit eutils fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${PN}-0.13.0/${PN}-html.zip -> ${PN}-0.13.0-html.zip
- http://docs.scipy.org/doc/${PN}-0.13.0/${PN}-ref.pdf -> ${PN}-0.13.0-ref.pdf
- )"
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="doc sparse test"
-KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- dev-python/numpy[lapack,${PYTHON_USEDEP}]
- sci-libs/arpack
- virtual/cblas
- virtual/lapack
- sparse? ( sci-libs/umfpack )"
-DEPEND="${CDEPEND}
- dev-lang/swig
- >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- test? (
- dev-python/mpmath[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="${CDEPEND}
- virtual/python-imaging[${PYTHON_USEDEP}]"
-
-DOCS=( HACKING.rst.txt THANKS.txt )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${PN}-0.13.0-html.zip -d html || die
- fi
-}
-
-pc_incdir() {
- $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
-}
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
- | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
-}
-
-python_prepare_all() {
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use sparse && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
-
- # Drop hashes to force rebuild of cython based .c code
- rm cythonize.dat || die
-
- local PATCHES=(
- "${FILESDIR}"/${PN}-0.12.0-blitz.patch
- "${FILESDIR}"/${PN}-0.12.0-restore-sys-argv.patch
- "${FILESDIR}"/${PN}-0.12.0-cephes-missing-include.patch
- )
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- ${EPYTHON} tools/cythonize.py || die
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
- distutils_install_for_testing ${SCIPY_FCONFIG}
- cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
- "${EPYTHON}" -c "
-import scipy, sys
-r = scipy.test('fast',verbose=2)
-sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r "${WORKDIR}"/html/.
- dodoc "${DISTDIR}"/${PN}*pdf
- fi
- distutils-r1_python_install_all
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer. Example:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}
diff --git a/sci-libs/scipy/scipy-0.14.0.ebuild b/sci-libs/scipy/scipy-0.14.0.ebuild
deleted file mode 100644
index d6c918e8d48e..000000000000
--- a/sci-libs/scipy/scipy-0.14.0.ebuild
+++ /dev/null
@@ -1,140 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/scipy/scipy-0.14.0.ebuild,v 1.2 2014/07/22 17:47:47 zerochaos Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3,3_4} )
-
-DOC_PV=0.13.0
-inherit eutils fortran-2 distutils-r1 flag-o-matic multilib toolchain-funcs
-
-DESCRIPTION="Scientific algorithms library for Python"
-HOMEPAGE="http://www.scipy.org/"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-html.zip -> ${PN}-${DOC_PV}-html.zip
- http://docs.scipy.org/doc/${PN}-${DOC_PV}/${PN}-ref.pdf -> ${PN}-${DOC_PV}-ref.pdf
- )"
-
-LICENSE="BSD LGPL-2"
-SLOT="0"
-IUSE="doc sparse test"
-KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-
-CDEPEND="
- dev-python/numpy[lapack,${PYTHON_USEDEP}]
- sci-libs/arpack:0=
- virtual/cblas
- virtual/lapack
- sparse? ( sci-libs/umfpack:0= )"
-DEPEND="${CDEPEND}
- dev-lang/swig
- >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
- virtual/pkgconfig
- doc? ( app-arch/unzip )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-RDEPEND="${CDEPEND}
- virtual/python-imaging[${PYTHON_USEDEP}]"
-
-DOCS=( HACKING.rst.txt THANKS.txt )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${PN}-${DOC_PV}-html.zip -d html || die
- fi
-}
-
-pc_incdir() {
- $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
- sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
-}
-
-pc_libdir() {
- $(tc-getPKG_CONFIG) --libs-only-L $@ | \
- sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
-}
-
-pc_libs() {
- $(tc-getPKG_CONFIG) --libs-only-l $@ | \
- sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
- -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
- | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
-}
-
-python_prepare_all() {
- # scipy automatically detects libraries by default
- export {FFTW,FFTW3,UMFPACK}=None
- use sparse && unset UMFPACK
- # the missing symbols are in -lpythonX.Y, but since the version can
- # differ, we just introduce the same scaryness as on Linux/ELF
- [[ ${CHOST} == *-darwin* ]] \
- && append-ldflags -bundle "-undefined dynamic_lookup" \
- || append-ldflags -shared
- [[ -z ${FC} ]] && export FC="$(tc-getFC)"
- # hack to force F77 to be FC until bug #278772 is fixed
- [[ -z ${F77} ]] && export F77="$(tc-getFC)"
- export F90="${FC}"
- export SCIPY_FCONFIG="config_fc --noopt --noarch"
- append-fflags -fPIC
-
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pc_incdir cblas)
- library_dirs = $(pc_libdir cblas blas):${libdir}
- blas_libs = $(pc_libs cblas blas)
- [lapack]
- library_dirs = $(pc_libdir lapack):${libdir}
- lapack_libs = $(pc_libs lapack)
- EOF
-
- # Drop hashes to force rebuild of cython based .c code
- rm cythonize.dat || die
-
- local PATCHES=(
- "${FILESDIR}"/${PN}-0.12.0-blitz.patch
- "${FILESDIR}"/${PN}-0.12.0-restore-sys-argv.patch
- "${FILESDIR}"/${PN}-0.12.0-cephes-missing-include.patch
- )
- distutils-r1_python_prepare_all
-}
-
-python_compile() {
- ${EPYTHON} tools/cythonize.py || die
- distutils-r1_python_compile ${SCIPY_FCONFIG}
-}
-
-python_test() {
- # fails with bdist_egg. should it be fixed in distutils-r1 eclass?
- distutils_install_for_testing ${SCIPY_FCONFIG}
- cd "${TEST_DIR}" || die "no ${TEST_DIR} available"
- "${EPYTHON}" -c "
-import scipy, sys
-r = scipy.test('fast',verbose=2)
-sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- if use doc; then
- dohtml -r "${WORKDIR}"/html/.
- dodoc "${DISTDIR}"/${PN}*pdf
- fi
- distutils-r1_python_install_all
-}
-
-python_install() {
- distutils-r1_python_install ${SCIPY_FCONFIG}
-}
-
-pkg_postinst() {
- elog "You might want to set the variable SCIPY_PIL_IMAGE_VIEWER"
- elog "to your prefered image viewer. Example:"
- elog "\t echo \"export SCIPY_PIL_IMAGE_VIEWER=display\" >> ~/.bashrc"
-}