summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2011-12-20 06:37:48 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2011-12-20 06:37:48 +0000
commit657b8ad89868e2cdde7a750a5fdadb2db72bd36d (patch)
treea728b5a3718fb09ca131ded6f6c7c610b70f8d7d /sci-libs
parentVersion bump (diff)
downloadgentoo-2-657b8ad89868e2cdde7a750a5fdadb2db72bd36d.tar.gz
gentoo-2-657b8ad89868e2cdde7a750a5fdadb2db72bd36d.tar.bz2
gentoo-2-657b8ad89868e2cdde7a750a5fdadb2db72bd36d.zip
Version bump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/armadillo/ChangeLog7
-rw-r--r--sci-libs/armadillo/armadillo-2.4.2.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/sci-libs/armadillo/ChangeLog b/sci-libs/armadillo/ChangeLog
index 1ff2ed5a1d9f..fc73af9ddf14 100644
--- a/sci-libs/armadillo/ChangeLog
+++ b/sci-libs/armadillo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/armadillo
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.6 2011/11/27 06:09:39 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/ChangeLog,v 1.7 2011/12/20 06:37:48 bicatali Exp $
+
+*armadillo-2.4.2 (20 Dec 2011)
+
+ 20 Dec 2011; Sébastien Fabbro <bicatali@gentoo.org> +armadillo-2.4.2.ebuild:
+ Version bump
*armadillo-2.2.5 (27 Nov 2011)
diff --git a/sci-libs/armadillo/armadillo-2.4.2.ebuild b/sci-libs/armadillo/armadillo-2.4.2.ebuild
new file mode 100644
index 000000000000..7db27599b9cf
--- /dev/null
+++ b/sci-libs/armadillo/armadillo-2.4.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/armadillo/armadillo-2.4.2.ebuild,v 1.1 2011/12/20 06:37:48 bicatali Exp $
+
+EAPI=4
+
+CMAKE_IN_SOURCE_BUILD=1
+
+inherit cmake-utils
+
+DESCRIPTION="Streamlined C++ linear algebra library"
+HOMEPAGE="http://arma.sourceforge.net/"
+SRC_URI="mirror://sourceforge/arma/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="atlas blas doc lapack"
+
+RDEPEND="
+ >=dev-libs/boost-1.34
+ atlas? ( sci-libs/lapack-atlas )
+ blas? ( virtual/blas )
+ lapack? ( virtual/lapack )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ # avoid the automagic cmake macros
+ sed -i -e '/ARMA_Find/d' CMakeLists.txt || die
+}
+
+src_configure() {
+ local mycmakeargs=()
+ if use blas; then
+ mycmakeargs+=(
+ -DBLAS_FOUND=ON
+ -DBLAS_LIBRARIES="$(pkg-config --libs blas)"
+ )
+ fi
+ if use lapack; then
+ mycmakeargs+=(
+ -DLAPACK_FOUND=ON
+ -DLAPACK_LIBRARIES="$(pkg-config --libs lapack)"
+ )
+ fi
+ if use atlas; then
+ mycmakeargs=(
+ -DCBLAS_FOUND=ON
+ -DCLAPACK_FOUND=ON
+ -DATLAS_INCLUDE_DIR="${EPREFIX}/usr/include/atlas/"
+ -DCBLAS_LIBRARIES="$(pkg-config --libs cblas)"
+ -DCLAPACK_LIBRARIES="-L${EPREFIX}/usr/lib64/lapack/atlas -llapack"
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+ use doc && dodoc docs/*pdf
+}