summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2007-07-31 03:56:48 +0000
committerSteve Arnold <nerdboy@gentoo.org>2007-07-31 03:56:48 +0000
commit70c6d54ec8d6e8891b823d6583c7bb2bb8b08aee (patch)
tree8d9fbc5f35e5fdf79c93f5af4cafae6133d7306c /sci-libs
parentdrop old versions (bug #161452) (diff)
downloadgentoo-2-70c6d54ec8d6e8891b823d6583c7bb2bb8b08aee.tar.gz
gentoo-2-70c6d54ec8d6e8891b823d6583c7bb2bb8b08aee.tar.bz2
gentoo-2-70c6d54ec8d6e8891b823d6583c7bb2bb8b08aee.zip
added fix for build failure on amd64 (real size mis-match)
(Portage version: 2.1.3)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/netcdf/ChangeLog6
-rw-r--r--sci-libs/netcdf/netcdf-3.6.2.ebuild4
2 files changed, 8 insertions, 2 deletions
diff --git a/sci-libs/netcdf/ChangeLog b/sci-libs/netcdf/ChangeLog
index 0006bfc644e9..f7a4e0097c93 100644
--- a/sci-libs/netcdf/ChangeLog
+++ b/sci-libs/netcdf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/netcdf
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.35 2007/04/27 09:06:49 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/ChangeLog,v 1.36 2007/07/31 03:56:48 nerdboy Exp $
+
+ 31 Jul 2007; Steve Arnold <nerdboy@gentoo.org> netcdf-3.6.2.ebuild:
+ Added FFLAGS fix for build failure on amd64 (real size mis-match). AFAIK
+ this is a gfortran F90 thing; needs testing with other F90 compilers.
27 Apr 2007; Sébastien Fabbro <bicatali@gentoo.org> netcdf-3.6.2.ebuild:
Removed blocking of hdf-4, thanks to Erik Zeek <zeekec@mad.scientist.com>.
diff --git a/sci-libs/netcdf/netcdf-3.6.2.ebuild b/sci-libs/netcdf/netcdf-3.6.2.ebuild
index 36b49a22ceb1..096fa9fa55b3 100644
--- a/sci-libs/netcdf/netcdf-3.6.2.ebuild
+++ b/sci-libs/netcdf/netcdf-3.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.2.ebuild,v 1.2 2007/04/27 09:06:49 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/netcdf/netcdf-3.6.2.ebuild,v 1.3 2007/07/31 03:56:48 nerdboy Exp $
inherit fortran eutils toolchain-funcs flag-o-matic
@@ -49,6 +49,7 @@ src_compile() {
*)
myconf="${myconf} --enable-f77 --enable-f90"
myconf="${myconf} FC=gfortran F90=gfortran F77=gfortran"
+ export F90FLAGS="-i4 ${F90FLAGS}"
;;
esac
else
@@ -66,6 +67,7 @@ src_compile() {
src_install() {
emake DESTDIR="${D}" install || die "emake install failed"
find "${D}usr/$(get_libdir)" -name \*.la -exec rm -f {} \;
+
dodoc README RELEASE_NOTES VERSION || die "dodoc failed"
# keep only pdf,txt and html docs, info were already installed
if use doc; then