summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-28 18:25:51 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-28 18:25:51 +0000
commit79222b84188b6d3cbe12ea0521b40a7819add1ca (patch)
treebd069bbc9b3d7cbe641253d5baf8a0300790cac7 /sci-libs
parentUpdate for Exim 4.86 RC4 mask (diff)
downloadgentoo-2-79222b84188b6d3cbe12ea0521b40a7819add1ca.tar.gz
gentoo-2-79222b84188b6d3cbe12ea0521b40a7819add1ca.tar.bz2
gentoo-2-79222b84188b6d3cbe12ea0521b40a7819add1ca.zip
Fix underlinking, bug #547486
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/mathgl/ChangeLog6
-rw-r--r--sci-libs/mathgl/files/mathgl-2.1.3.1-x11.patch65
-rw-r--r--sci-libs/mathgl/mathgl-2.1.3.1.ebuild8
-rw-r--r--sci-libs/mathgl/mathgl-2.1.3.ebuild6
4 files changed, 78 insertions, 7 deletions
diff --git a/sci-libs/mathgl/ChangeLog b/sci-libs/mathgl/ChangeLog
index bdb56319abce..21c16dfa5cc8 100644
--- a/sci-libs/mathgl/ChangeLog
+++ b/sci-libs/mathgl/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/mathgl
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.43 2015/04/08 18:49:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/ChangeLog,v 1.44 2015/06/28 18:25:51 jlec Exp $
+
+ 28 Jun 2015; Justin Lecher <jlec@gentoo.org> +files/mathgl-2.1.3.1-x11.patch,
+ mathgl-2.1.3.1.ebuild, mathgl-2.1.3.ebuild:
+ Fix underlinking, bug #547486
08 Apr 2015; Michał Górny <mgorny@gentoo.org> mathgl-2.1.3.1.ebuild,
mathgl-2.1.3.ebuild:
diff --git a/sci-libs/mathgl/files/mathgl-2.1.3.1-x11.patch b/sci-libs/mathgl/files/mathgl-2.1.3.1-x11.patch
new file mode 100644
index 000000000000..cff27870d365
--- /dev/null
+++ b/sci-libs/mathgl/files/mathgl-2.1.3.1-x11.patch
@@ -0,0 +1,65 @@
+ CMakeLists.txt | 1 +
+ json/CMakeLists.txt | 2 +-
+ udav/CMakeLists.txt | 2 +-
+ widgets/CMakeLists.txt | 4 ++--
+ 4 files changed, 5 insertions(+), 4 deletions(-)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 3364973..0c3a645 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -316,6 +316,7 @@ endif(enable-wx)
+ if(enable-qt)
+ set(MGL_HAVE_QT 1)
+ FIND_PACKAGE(Qt4 4.8 REQUIRED QtCore QtGui QtNetwork QtWebKit)
++ FIND_PACKAGE(X11)
+ if(NOT QT4_FOUND)
+ message(SEND_ERROR "Couldn't find Qt4 library.")
+ endif(NOT QT4_FOUND)
+diff --git a/json/CMakeLists.txt b/json/CMakeLists.txt
+index 79d4716..0a53874 100644
+--- a/json/CMakeLists.txt
++++ b/json/CMakeLists.txt
+@@ -9,6 +9,6 @@ include_directories(${MathGL_BINARY_DIR}/json)
+ qt4_wrap_ui(json_ui_src MainWindow.ui)
+ qt4_wrap_cpp(json_moc_src ${json_moc_hdr} )
+ add_executable(MglForJsTestBench ${json_src} ${json_moc_src} ${json_ui_src})
+-target_link_libraries(MglForJsTestBench mgl-qt ${QT_LIBRARIES})
++target_link_libraries(MglForJsTestBench mgl-qt ${QT_LIBRARIES} ${X11_LIBRARIES})
+
+ endif(MGL_HAVE_QT)
+diff --git a/udav/CMakeLists.txt b/udav/CMakeLists.txt
+index 9a9c574..a1ff2df 100644
+--- a/udav/CMakeLists.txt
++++ b/udav/CMakeLists.txt
+@@ -27,7 +27,7 @@ qt4_add_resources(udav_rc_src ${udav_rc} )
+ qt4_wrap_cpp(udav_moc_src ${udav_moc_hdr} )
+ add_executable(udav ${udav_src} ${udav_moc_src} ${udav_rc_src})
+ #set_target_properties(udav PROPERTIES COMPILE_FLAGS "${CMAKE_CXX_FLAGS} -pthread")
+-target_link_libraries(udav mgl-qt ${QT_LIBRARIES})
++target_link_libraries(udav mgl-qt ${QT_LIBRARIES} ${X11_LIBRARIES})
+
+ if(MGL_HAVE_PTHREAD)
+ target_link_libraries(udav ${CMAKE_THREAD_LIBS_INIT})
+diff --git a/widgets/CMakeLists.txt b/widgets/CMakeLists.txt
+index 90ea00c..f582003 100644
+--- a/widgets/CMakeLists.txt
++++ b/widgets/CMakeLists.txt
+@@ -93,7 +93,7 @@ if(MGL_HAVE_QT)
+ set_target_properties(mgl-qt-static PROPERTIES CLEAN_DIRECT_OUTPUT 1)
+ set_target_properties(mgl-qt-static PROPERTIES COMPILE_FLAGS -DMGL_STATIC_DEFINE)
+ target_link_libraries(mgl-qt mgl)
+- target_link_libraries(mgl-qt ${QT_LIBRARIES})
++ target_link_libraries(mgl-qt ${QT_LIBRARIES} ${X11_LIBRARIES})
+
+ if(enable-mgl2)
+ set_target_properties(mgl-qt PROPERTIES OUTPUT_NAME "mgl2-qt")
+@@ -137,7 +137,7 @@ if(MGL_HAVE_QT AND MGL_HAVE_FLTK)
+ endif(enable-mgl2)
+
+ target_link_libraries(mgl-wnd mgl)
+- target_link_libraries(mgl-wnd ${QT_LIBRARIES})
++ target_link_libraries(mgl-wnd ${QT_LIBRARIES} ${X11_LIBRARIES})
+ # target_link_libraries(mgl-wnd ${wxWidgets_LIBRARIES})
+ target_link_libraries(mgl-wnd ${FLTK_LIBRARIES})
+
diff --git a/sci-libs/mathgl/mathgl-2.1.3.1.ebuild b/sci-libs/mathgl/mathgl-2.1.3.1.ebuild
index 5edd5cee4ebd..6b8100122cb5 100644
--- a/sci-libs/mathgl/mathgl-2.1.3.1.ebuild
+++ b/sci-libs/mathgl/mathgl-2.1.3.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.1.3.1.ebuild,v 1.3 2015/04/08 18:49:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.1.3.1.ebuild,v 1.4 2015/06/28 18:25:51 jlec Exp $
EAPI=5
@@ -33,10 +33,10 @@ RDEPEND="
gsl? ( sci-libs/gsl )
hdf? ( sci-libs/hdf )
hdf5? ( >=sci-libs/hdf5-1.8[mpi=] )
- jpeg? ( virtual/jpeg )
+ jpeg? ( virtual/jpeg:0 )
octave? ( >=sci-mathematics/octave-3.4.0 )
pdf? ( media-libs/libharu )
- png? ( media-libs/libpng )
+ png? ( media-libs/libpng:0 )
python? ( dev-python/numpy[${PYTHON_USEDEP}] ${PYTHON_DEPS} )
qt4? ( dev-qt/qtgui:4 )
wxwidgets? ( x11-libs/wxGTK:2.8[X] )
@@ -76,6 +76,8 @@ src_prepare() {
# fix desktop file
sed -i -e 's/.png//' udav/udav.desktop || die
use python && append-cppflags -I"$(${EPYTHON} -c 'import numpy; print(numpy.get_include())')"
+
+ epatch "${FILESDIR}"/${P}-x11.patch
}
src_configure() {
diff --git a/sci-libs/mathgl/mathgl-2.1.3.ebuild b/sci-libs/mathgl/mathgl-2.1.3.ebuild
index 5d3ba0cb9d7b..72b953539274 100644
--- a/sci-libs/mathgl/mathgl-2.1.3.ebuild
+++ b/sci-libs/mathgl/mathgl-2.1.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.1.3.ebuild,v 1.3 2015/04/08 18:49:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/mathgl/mathgl-2.1.3.ebuild,v 1.4 2015/06/28 18:25:51 jlec Exp $
EAPI=5
@@ -33,10 +33,10 @@ RDEPEND="
gsl? ( sci-libs/gsl )
hdf? ( sci-libs/hdf )
hdf5? ( >=sci-libs/hdf5-1.8[mpi=] )
- jpeg? ( virtual/jpeg )
+ jpeg? ( virtual/jpeg:0 )
octave? ( >=sci-mathematics/octave-3.4.0 )
pdf? ( media-libs/libharu )
- png? ( media-libs/libpng )
+ png? ( media-libs/libpng:0 )
python? ( dev-python/numpy[${PYTHON_USEDEP}] ${PYTHON_DEPS} )
qt4? ( dev-qt/qtgui:4 )
wxwidgets? ( x11-libs/wxGTK:2.8[X] )