summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-02-20 14:46:15 +0000
committerJustin Lecher <jlec@gentoo.org>2015-02-20 14:46:15 +0000
commitc0f682ca2694c0f401620ecc0495e4c407daa530 (patch)
tree63322fdb99764dc93ccf69da2a197ab422d2aac5 /sci-libs
parentStable for all (bug #540464) (diff)
downloadgentoo-2-c0f682ca2694c0f401620ecc0495e4c407daa530.tar.gz
gentoo-2-c0f682ca2694c0f401620ecc0495e4c407daa530.tar.bz2
gentoo-2-c0f682ca2694c0f401620ecc0495e4c407daa530.zip
Drop old; move to EAPI=5, fixes #478598
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/acml/ChangeLog8
-rw-r--r--sci-libs/acml/acml-3.6.1-r1.ebuild176
-rw-r--r--sci-libs/acml/acml-4.0.1.ebuild179
-rw-r--r--sci-libs/acml/acml-4.1.0-r2.ebuild (renamed from sci-libs/acml/acml-4.1.0-r1.ebuild)17
4 files changed, 15 insertions, 365 deletions
diff --git a/sci-libs/acml/ChangeLog b/sci-libs/acml/ChangeLog
index 1c0ec66ebe57..a6733964bef0 100644
--- a/sci-libs/acml/ChangeLog
+++ b/sci-libs/acml/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sci-libs/acml
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.48 2015/02/15 06:46:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/ChangeLog,v 1.49 2015/02/20 14:46:15 jlec Exp $
+
+*acml-4.1.0-r2 (20 Feb 2015)
+
+ 20 Feb 2015; Justin Lecher <jlec@gentoo.org> +acml-4.1.0-r2.ebuild,
+ -acml-3.6.1-r1.ebuild, -acml-4.0.1.ebuild, -acml-4.1.0-r1.ebuild:
+ Drop old; move to EAPI=5, fixes #478598
15 Feb 2015; Mike Frysinger <vapier@gentoo.org> acml-4.1.0-r1.ebuild:
Switch to matching versions as the SLOT in older versions is changing #528196.
diff --git a/sci-libs/acml/acml-3.6.1-r1.ebuild b/sci-libs/acml/acml-3.6.1-r1.ebuild
deleted file mode 100644
index c8ae04267bfe..000000000000
--- a/sci-libs/acml/acml-3.6.1-r1.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-3.6.1-r1.ebuild,v 1.14 2012/10/16 20:48:56 jlec Exp $
-
-inherit eutils fortran-2 multilib toolchain-funcs
-
-MY_PV=${PV//\./\-}
-
-DESCRIPTION="AMD Core Math Library (ACML) for x86 and amd64 CPUs"
-HOMEPAGE="http://developer.amd.com/acml.jsp"
-SRC_URI="
- x86? ( acml-${MY_PV}-gfortran-32bit.tgz )
- amd64? (
- acml-${MY_PV}-gfortran-64bit.tgz
- int64? ( acml-${MY_PV}-gfortran-64bit-int64.tgz ) )"
-
-SLOT="0"
-LICENSE="ACML"
-KEYWORDS="~amd64 ~x86"
-IUSE="openmp int64 doc examples"
-
-RESTRICT="strip fetch"
-
-DEPEND="
- app-admin/eselect-blas
- app-admin/eselect-lapack"
-RDEPEND="${DEPEND}
- doc? ( app-doc/blas-docs app-doc/lapack-docs )"
-
-S="${WORKDIR}"
-
-pkg_nofetch() {
- einfo "Please download the ACML from:"
- einfo "${HOMEPAGE}"
- einfo "and place it in ${DISTDIR}."
- einfo "The previous versions could be found at"
- einfo "http://developer.amd.com/acmlarchive.jsp"
-}
-
-get_fcomp() {
- case $(tc-getFC) in
- *gfortran* )
- FCOMP="gfortran" ;;
- ifort )
- FCOMP="ifc" ;;
- * )
- FCOMP=$(tc-getFC) ;;
- esac
-}
-
-pkg_setup() {
- elog "From version 3.5.0 on, ACML no longer supports"
- elog "hardware without SSE/SSE2 instructions. "
- elog "For older 32-bit without SSE/SSE2, use other blas/lapack libraries,"
- elog "or file a bug if you wish to have earlier ACML versions supported."
- if use openmp; then
- tc-has-openmp || die "Please ensure your compiler has openmp support"
- FORTRAN_NEED_OPENMP=1
- fi
- fortran-2_pkg_setup
- get_fcomp
-}
-
-src_unpack() {
- unpack ${A}
- (DISTDIR="${S}" unpack contents-acml-*.tgz)
- case ${FCOMP} in
- gfortran) FORT=gfortran ;;
- if*) FORT=ifort ;;
- *) eerror "Unsupported fortran compiler: $(tc-getFC)"
- die ;;
- esac
- use openmp || rm -rf ${FORT}*_mp*
- FORTDIRS="$(ls -d ${FORT}*)"
-}
-
-src_test() {
- local forts=${FORTDIRS}
- # only testing with current compiler
- use openmp && forts="$(ls -d ${FORT}*_mp*)"
- for fort in ${forts}; do
- einfo "Testing acml for ${fort}"
- cd "${S}"/${fort}/examples
- for d in . acml_mv; do
- cd "${S}"/${fort}/examples/${d}
- emake \
- ACMLDIR="${S}"/${fort} \
- F77=$(tc-getFC) \
- CC="$(tc-getCC)" \
- CPLUSPLUS="$(tc-getCXX)" \
- || die "emake test in ${fort}/examples/${d} failed"
- emake clean
- done
- done
-}
-
-src_install() {
- # respect acml default install dir (and FHS)
- local instdir=/opt/${PN}${PV}
- dodir ${instdir}
-
- for fort in ${FORTDIRS}; do
- # install acml
- use examples || rm -rf "${S}"/${fort}/examples
- cp -pPR "${S}/${fort}" "${D}"${instdir} || die "copy ${fort} failed"
-
- # install profiles
- ESELECT_PROF=acml-${FCOMP}
- local acmldir=${instdir}/${fort}
- local acmllibs="-lacml -lacml_mv"
- local libname=${acmldir}/lib/libacml
- local extlibs
- local extflags
- if [[ ${fort} =~ int64 ]]; then
- ESELECT_PROF=${ESELECT_PROF}-int64
- extflags="${extflags} -fdefault-integer-8"
- fi
- [[ ${fort} =~ gfortran ]] && extlibs="${extlibs} -lgfortran"
- if [[ ${fort} =~ _mp ]]; then
- ESELECT_PROF=${ESELECT_PROF}-openmp
- extlibs="${extlibs} -lpthread"
- acmllibs="-lacml_mp -lacml_mv"
- libname=${libname}_mp
- extflags="${extflags} -fopenmp"
- fi
- for l in blas lapack; do
- # pkgconfig files
- sed -e "s:@LIBDIR@:$(get_libdir):" \
- -e "s:@PV@:${PV}:" \
- -e "s:@ACMLDIR@:${acmldir}:g" \
- -e "s:@ACMLLIBS@:${acmllibs}:g" \
- -e "s:@EXTLIBS@:${extlibs}:g" \
- -e "s:@EXTFLAGS@:${extflags}:g" \
- "${FILESDIR}"/${l}.pc.in > ${l}.pc \
- || die "sed ${l}.pc failed"
- insinto ${acmldir}/lib
- doins ${l}.pc
-
- # eselect files
- cat > eselect.${l} <<-EOF
- ${libname}.so /usr/@LIBDIR@/lib${l}.so.0
- ${libname}.so /usr/@LIBDIR@/lib${l}.so
- ${libname}.a /usr/@LIBDIR@/lib${l}.a
- ${acmldir}/lib/${l}.pc /usr/@LIBDIR@/pkgconfig/${l}.pc
- EOF
- eselect ${l} add $(get_libdir) eselect.${l} ${ESELECT_PROF}
- done
- echo "LDPATH=${acmldir}/lib" > "${S}"/35acml
- done
-
- doenvd "${S}"/35acml || die "doenvd failed"
- use doc || rm -rf "${S}"/Doc/acml.pdf "${S}"/Doc/html
- cp -pPR "${S}"/Doc "${D}"${instdir} || die "copy doc failed"
-}
-
-pkg_postinst() {
- for p in blas lapack; do
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
- done
- if use openmp; then
- elog "Remember that if you want to use openmp"
- elog "You need to switch to gcc >= 4.2 with gcc-config"
- elog "When using ACML without openmp, stick with gcc-4.1.x"
- fi
-}
diff --git a/sci-libs/acml/acml-4.0.1.ebuild b/sci-libs/acml/acml-4.0.1.ebuild
deleted file mode 100644
index 81bb7cf391de..000000000000
--- a/sci-libs/acml/acml-4.0.1.ebuild
+++ /dev/null
@@ -1,179 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.0.1.ebuild,v 1.10 2012/10/16 20:48:56 jlec Exp $
-
-inherit eutils fortran-2 multilib toolchain-funcs
-
-MY_PV=${PV//\./\-}
-
-DESCRIPTION="AMD Core Math Library (ACML) for x86_64 CPUs"
-HOMEPAGE="http://developer.amd.com/acml.jsp"
-SRC_URI="
- ifc? ( acml-${MY_PV}-ifort-64bit.tgz )
- !ifc? (
- int64? ( acml-${MY_PV}-gfortran-64bit-int64.tgz )
- !int64? ( acml-${MY_PV}-gfortran-64bit.tgz )
- )"
-
-SLOT="0"
-LICENSE="ACML"
-KEYWORDS="~amd64"
-IUSE="openmp ifc int64 doc examples"
-
-RESTRICT="strip fetch"
-
-DEPEND="
- ifc? ( dev-lang/ifc )
- app-admin/eselect-blas
- app-admin/eselect-lapack"
-RDEPEND="${DEPEND}
- doc? ( app-doc/blas-docs app-doc/lapack-docs )"
-
-S="${WORKDIR}"
-
-pkg_nofetch() {
- einfo "Please download the ACML from:"
- einfo "${HOMEPAGE}"
- einfo "and place it in ${DISTDIR}."
- einfo "The previous versions could be found at"
- einfo "http://developer.amd.com/acmlarchive.jsp"
- einfo "SRC=${A} $SRC_URI"
-}
-
-get_fcomp() {
- case $(tc-getFC) in
- *gfortran* )
- FCOMP="gfortran" ;;
- ifort )
- FCOMP="ifc" ;;
- * )
- FCOMP=$(tc-getFC) ;;
- esac
-}
-
-pkg_setup() {
- if [[ $(tc-getFC) =~ gfortran ]]; then
- local gcc_version=$(gcc-major-version)$(gcc-minor-version)
- if ! use openmp && (( ${gcc_version} != 41 )); then
- eerror "You need gcc-4.1.x to test acml."
- eerror "Please use gcc-config to swicth gcc version 4.1.x"
- die "setup gcc failed"
- fi
- fi
- if use openmp; then
- tc-has-openmp || die "Please ensure your compiler has openmp support"
- FORTRAN_NEED_OPENMP=1
- fi
- fortran-2_pkg_setup
- get_fcomp
-}
-
-src_unpack() {
- unpack ${A}
- (DISTDIR="${S}" unpack contents-acml-*.tgz)
- case ${FCOMP} in
- gfortran) FORT=gfortran ;;
- if*) FORT=ifort ;;
- *) eerror "Unsupported fortran compiler: $(tc-getFC)"
- die "failed configuring fortran";;
- esac
- use openmp || rm -rf ${FORT}*_mp*
- FORTDIRS="$(ls -d ${FORT}*)"
-}
-
-src_test() {
- local forts=${FORTDIRS}
- # only testing with current compiler
- use openmp && forts="$(ls -d ${FORT}*_mp*)"
- for fort in ${forts}; do
- einfo "Testing acml for ${fort}"
- cd "${S}"/${fort}/examples
- for d in . acml_mv; do
- cd "${S}"/${fort}/examples/${d}
- emake \
- ACMLDIR="${S}"/${fort} \
- F77=$(tc-getFC) \
- CC="$(tc-getCC)" \
- CPLUSPLUS="$(tc-getCXX)" \
- || die "emake test in ${fort}/examples/${d} failed"
- emake clean
- done
- done
-}
-
-src_install() {
- # respect acml default install dir (and FHS)
- local instdir=/opt/${PN}${PV}
- dodir ${instdir}
-
- for fort in ${FORTDIRS}; do
- # install acml
- use examples || rm -rf "${S}"/${fort}/examples
- cp -pPR "${S}"/${fort} "${D}"${instdir} || die "copy ${fort} failed"
-
- # install profiles
- ESELECT_PROF=acml-${FCOMP}
- local acmldir=${instdir}/${fort}
- local acmllibs="-lacml -lacml_mv"
- local libname=${acmldir}/lib/libacml
- local extlibs=
- local extflags=
- if [[ ${fort} =~ int64 ]]; then
- ESELECT_PROF=${ESELECT_PROF}-int64
- extflags="${extflags} -fdefault-integer-8"
- fi
- [[ ${fort} =~ gfortran ]] && extlibs="${extlibs} -lgfortran"
- if [[ ${fort} =~ _mp ]]; then
- ESELECT_PROF=${ESELECT_PROF}-openmp
- extlibs="${extlibs} -lpthread"
- acmllibs="-lacml_mp -lacml_mv"
- libname=${libname}_mp
- extflags="${extflags} -fopenmp"
- fi
- for l in blas lapack; do
- # pkgconfig files
- sed -e "s:@LIBDIR@:$(get_libdir):" \
- -e "s:@PV@:${PV}:" \
- -e "s:@ACMLDIR@:${acmldir}:g" \
- -e "s:@ACMLLIBS@:${acmllibs}:g" \
- -e "s:@EXTLIBS@:${extlibs}:g" \
- -e "s:@EXTFLAGS@:${extflags}:g" \
- "${FILESDIR}"/${l}.pc.in > ${l}.pc \
- || die "sed ${l}.pc failed"
- insinto ${acmldir}/lib
- doins ${l}.pc || die "doins ${l}.pc failed"
-
- # eselect files
- cat > eselect.${l} <<-EOF
- ${libname}.so /usr/@LIBDIR@/lib${l}.so.0
- ${libname}.so /usr/@LIBDIR@/lib${l}.so
- ${libname}.a /usr/@LIBDIR@/lib${l}.a
- ${acmldir}/lib/${l}.pc /usr/@LIBDIR@/pkgconfig/${l}.pc
- EOF
- eselect ${l} add $(get_libdir) eselect.${l} ${ESELECT_PROF}
- done
- echo "LDPATH=${instdir}/${fort}/lib" > 35acml
- done
-
- doenvd 35acml || die "doenvd failed"
-
- use doc || rm -rf "${S}"/Doc/acml.pdf "${S}"/Doc/html
- cp -pPR "${S}"/Doc "${D}"${instdir} || die "copy doc failed"
-}
-
-pkg_postinst() {
- for p in blas lapack; do
- local current_lib=$(eselect ${p} show | cut -d' ' -f2)
- if [[ ${current_lib} == ${ESELECT_PROF} || -z ${current_lib} ]]; then
- # work around eselect bug #189942
- local configfile="${ROOT}"/etc/env.d/${p}/$(get_libdir)/config
- [[ -e ${configfile} ]] && rm -f ${configfile}
- eselect ${p} set ${ESELECT_PROF}
- elog "${p} has been eselected to ${ESELECT_PROF}"
- else
- elog "Current eselected ${p} is ${current_lib}"
- elog "To use ${p} ${ESELECT_PROF} implementation, you have to issue (as root):"
- elog "\t eselect ${p} set ${ESELECT_PROF}"
- fi
- done
-}
diff --git a/sci-libs/acml/acml-4.1.0-r1.ebuild b/sci-libs/acml/acml-4.1.0-r2.ebuild
index 6fc63cd0ba11..5a7c9f088341 100644
--- a/sci-libs/acml/acml-4.1.0-r1.ebuild
+++ b/sci-libs/acml/acml-4.1.0-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.1.0-r1.ebuild,v 1.13 2015/02/15 06:46:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/acml/acml-4.1.0-r2.ebuild,v 1.1 2015/02/20 14:46:15 jlec Exp $
-EAPI=1
+EAPI=5
inherit eutils fortran-2 multilib toolchain-funcs versionator
@@ -36,9 +36,10 @@ CDEPEND="
gfortran? ( =sys-devel/gcc-4.2* )
!gfortran? ( !ifc? ( =sys-devel/gcc-4.2* ) )"
-DEPEND="test? ( ${CDEPEND} )
+DEPEND="
app-admin/eselect-blas
- app-admin/eselect-lapack"
+ app-admin/eselect-lapack
+ test? ( ${CDEPEND} )"
RDEPEND="${CDEPEND}
app-admin/eselect-blas
@@ -68,7 +69,6 @@ get_fcomp() {
}
pkg_setup() {
-
if use test; then
# work around incomplete fortran eclass
if use gfortran &&
@@ -111,8 +111,7 @@ src_test() {
ACMLDIR="${S}"/${fdir} \
F77=$(tc-getFC) \
CC="$(tc-getCC)" \
- CPLUSPLUS="$(tc-getCXX)" \
- || die "emake test in ${fdir}/examples/${d} failed"
+ CPLUSPLUS="$(tc-getCXX)"
emake clean
done
done
@@ -163,7 +162,7 @@ src_install() {
"${FILESDIR}"/${x}.pc.in > ${x}.pc \
|| die "sed ${x}.pc failed"
insinto ${acmldir}/lib
- doins ${x}.pc || die "doins ${x}.pc failed"
+ doins ${x}.pc
# eselect files
cat > eselect.${prof}.${x} <<-EOF
@@ -177,7 +176,7 @@ src_install() {
done
echo "LDPATH=${instdir}/${ACML_DEFAULT_DIR}/lib" > 35acml
- doenvd "${S}"/35acml || die "doenvd failed"
+ doenvd "${S}"/35acml
use doc || rm -rf "${S}"/Doc/acml.pdf "${S}"/Doc/html
cp -pPR "${S}"/Doc "${D}"${instdir} || die "copy doc failed"
}