summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-11 07:38:19 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-11 07:38:19 +0000
commitc7aa638abd726d477e8b110a8ab2a2a41e8faedc (patch)
treedd583b9c4ab67a9d4a2c1b648e07fb28bb108e5e /sci-libs
parentVersion bump: Support 'ProxyCommand none' directive (diff)
downloadgentoo-2-c7aa638abd726d477e8b110a8ab2a2a41e8faedc.tar.gz
gentoo-2-c7aa638abd726d477e8b110a8ab2a2a41e8faedc.tar.bz2
gentoo-2-c7aa638abd726d477e8b110a8ab2a2a41e8faedc.zip
Removed qt3 support as it is no longer in the tree
(Portage version: 2.2_rc62/cvs/Linux i686)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/vtk/ChangeLog6
-rw-r--r--sci-libs/vtk/vtk-5.4.2-r1.ebuild27
-rw-r--r--sci-libs/vtk/vtk-5.4.2.ebuild28
3 files changed, 12 insertions, 49 deletions
diff --git a/sci-libs/vtk/ChangeLog b/sci-libs/vtk/ChangeLog
index c2c2bee4e23a..768e0f86b71c 100644
--- a/sci-libs/vtk/ChangeLog
+++ b/sci-libs/vtk/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/vtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.61 2010/01/21 23:38:26 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/ChangeLog,v 1.62 2010/02/11 07:38:19 jlec Exp $
+
+ 11 Feb 2010; Justin Lecher (jlec) <jlec@j-schmitz.net> vtk-5.4.2.ebuild,
+ vtk-5.4.2-r1.ebuild:
+ Removed qt3 support as it is no longer in the tree
21 Jan 2010; Markus Dittrich <markusle@gentoo.org> vtk-5.4.2-r1.ebuild,
+files/vtk-5.4.2-boost-property_map.patch:
diff --git a/sci-libs/vtk/vtk-5.4.2-r1.ebuild b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
index 479517e67f02..1b9ac9493c6e 100644
--- a/sci-libs/vtk/vtk-5.4.2-r1.ebuild
+++ b/sci-libs/vtk/vtk-5.4.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.3 2010/01/21 23:38:26 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2-r1.ebuild,v 1.4 2010/02/11 07:38:19 jlec Exp $
EAPI="2"
inherit eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2 python qt3 qt4 cmake-utils
@@ -17,7 +17,7 @@ SRC_URI="http://www.${PN}.org/files/release/${SPV}/${P}.tar.gz
LICENSE="BSD LGPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="boost cg doc examples mpi patented python tcl tk threads qt3 qt4"
+IUSE="boost cg doc examples mpi patented python tcl tk threads qt4"
RDEPEND="mpi? ( || (
sys-cluster/openmpi
sys-cluster/lam-mpi
@@ -27,7 +27,6 @@ RDEPEND="mpi? ( || (
tcl? ( >=dev-lang/tcl-8.2.3 )
tk? ( >=dev-lang/tk-8.2.3 )
java? ( >=virtual/jre-1.5 )
- !qt4? ( qt3? ( >=x11-libs/qt-3.3.4:3 ) )
qt4? ( x11-libs/qt-core:4
x11-libs/qt-opengl:4
x11-libs/qt-gui:4 )
@@ -58,12 +57,6 @@ pkg_setup() {
epause 5
java-pkg-opt-2_pkg_setup
- if use qt3 && use qt4; then
- echo
- ewarn "qt3 and qt4 support for vtk are mutually exclusive and"
- ewarn "qt4 support has therefore been enabled by default."
- echo
- fi
if use qt4; then
qt4_pkg_setup
@@ -143,7 +136,7 @@ src_configure() {
-DVTK_PYTHON_SETUP_ARGS:STRING=--root="${D}")
fi
- if use qt3 || use qt4 ; then
+ if use qt4 ; then
mycmakeargs+=(
-DVTK_USE_GUISUPPORT=ON
-DVTK_USE_QVTK=ON
@@ -152,20 +145,6 @@ src_configure() {
-DQT_WRAP_UI=ON)
fi
- # these options we only enable if the use request qt3
- # only. In case of qt3 && qt4 or qt4 only qt4 always
- # overrides qt3
- if use qt3 && use !qt4; then
- mycmakeargs+=(
- -DVTK_INSTALL_QT_DIR=/qt/3/plugins/${PN}
- -DDESIRED_QT_VERSION=3
- -DQT_MOC_EXECUTABLE=/usr/qt/3/bin/moc
- -DQT_UIC_EXECUTABLE=/usr/qt/3/bin/uic
- -DQT_INCLUDE_DIR=/usr/qt/3/include
- -DQT_QT_LIBRARY=/usr/qt/3/$(get_libdir)/libqt.so
- -DQT_QMAKE_EXECUTABLE=/usr/qt/3/bin/qmake)
- fi
-
if use qt4; then
mycmakeargs+=(
-DVTK_INSTALL_QT_DIR=/$(get_libdir)/qt4/plugins/${PN}
diff --git a/sci-libs/vtk/vtk-5.4.2.ebuild b/sci-libs/vtk/vtk-5.4.2.ebuild
index 93e1fcf8fcdf..51d86e962479 100644
--- a/sci-libs/vtk/vtk-5.4.2.ebuild
+++ b/sci-libs/vtk/vtk-5.4.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2.ebuild,v 1.5 2009/12/17 23:43:31 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/vtk/vtk-5.4.2.ebuild,v 1.6 2010/02/11 07:38:19 jlec Exp $
EAPI="2"
inherit distutils eutils flag-o-matic toolchain-funcs versionator java-pkg-opt-2 python qt3 qt4
@@ -17,7 +17,7 @@ SRC_URI="http://www.${PN}.org/files/release/${SPV}/${P}.tar.gz
LICENSE="BSD LGPL-2"
KEYWORDS="~amd64 ~x86"
SLOT="0"
-IUSE="boost cg doc examples mpi patented python tcl tk threads qt3 qt4"
+IUSE="boost cg doc examples mpi patented python tcl tk threads qt4"
RDEPEND="mpi? ( || (
sys-cluster/openmpi
sys-cluster/lam-mpi
@@ -27,7 +27,6 @@ RDEPEND="mpi? ( || (
tcl? ( >=dev-lang/tcl-8.2.3 )
tk? ( >=dev-lang/tk-8.2.3 )
java? ( >=virtual/jre-1.5 )
- !qt4? ( qt3? ( >=x11-libs/qt-3.3.4:3 ) )
qt4? ( x11-libs/qt-core:4
x11-libs/qt-opengl:4
x11-libs/qt-gui:4 )
@@ -58,13 +57,6 @@ pkg_setup() {
epause 5
java-pkg-opt-2_pkg_setup
- if use qt3 && use qt4; then
- echo
- ewarn "qt3 and qt4 support for vtk are mutually exclusive and"
- ewarn "qt4 support has therefore been enabled by default."
- echo
- fi
-
if use qt4; then
qt4_pkg_setup
fi
@@ -138,24 +130,12 @@ src_compile() {
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_PYTHON_SETUP_ARGS:STRING=\"--prefix=${D}/usr\""
fi
- if use qt3 || use qt4 ; then
+ if use qt4 ; then
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_GUISUPPORT:BOOL=ON"
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_QVTK:BOOL=ON"
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_USE_QVTK_QTOPENGL:BOOL=ON"
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DQT_WRAP_CPP:BOOL=ON"
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DQT_WRAP_UI:BOOL=ON"
- fi
-
- if use qt3; then
- CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_INSTALL_QT_DIR:PATH=/qt/3/plugins/${PN}"
- CMAKE_VARIABLES="${CMAKE_VARIABLES} -DDESIRED_QT_VERSION:STRING=3"
- CMAKE_VARIABLES="${CMAKE_VARIABLES} -DQT_MOC_EXECUTABLE:FILEPATH=/usr/qt/3/bin/moc"
- CMAKE_VARIABLES="${CMAKE_VARIABLES} -DQT_UIC_EXECUTABLE:FILEPATH=/usr/qt/3/bin/uic"
- CMAKE_VARIABLES="${CMAKE_VARIABLES} -DQT_INCLUDE_DIR:PATH=/usr/qt/3/include"
- CMAKE_VARIABLES="${CMAKE_VARIABLES} -DQT_QMAKE_EXECUTABLE:PATH=/usr/qt/3/bin/qmake"
- fi
-
- if use qt4; then
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DVTK_INSTALL_QT_DIR:PATH=/$(get_libdir)/qt4/plugins/${PN}"
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DDESIRED_QT_VERSION:STRING=4"
CMAKE_VARIABLES="${CMAKE_VARIABLES} -DQT_MOC_EXECUTABLE:FILEPATH=/usr/bin/moc"