summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-07-14 23:30:10 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-07-14 23:30:10 +0000
commitdc4af95fa8013696ec7565d61cb8f4a0978d7431 (patch)
tree96ccb6c4a11df3317538fd1a274af9855e6ebe15 /sci-libs
parentx11-drivers/xf86-video-intel: up dep on libdrm (fixes bug #277816, thanks Thi... (diff)
downloadgentoo-2-dc4af95fa8013696ec7565d61cb8f4a0978d7431.tar.gz
gentoo-2-dc4af95fa8013696ec7565d61cb8f4a0978d7431.tar.bz2
gentoo-2-dc4af95fa8013696ec7565d61cb8f4a0978d7431.zip
Version bump
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/cln/ChangeLog7
-rw-r--r--sci-libs/cln/cln-1.3.0.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/sci-libs/cln/ChangeLog b/sci-libs/cln/ChangeLog
index 7afe7b96d36b..cf41e92725e0 100644
--- a/sci-libs/cln/ChangeLog
+++ b/sci-libs/cln/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/cln
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/ChangeLog,v 1.35 2009/07/01 15:53:15 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/ChangeLog,v 1.36 2009/07/14 23:30:10 bicatali Exp $
+
+*cln-1.3.0 (14 Jul 2009)
+
+ 14 Jul 2009; Sébastien Fabbro <bicatali@gentoo.org> +cln-1.3.0.ebuild:
+ Version bump
01 Jul 2009; Alexis Ballier <aballier@gentoo.org> cln-1.2.2.ebuild:
keyword ~x86-fbsd
diff --git a/sci-libs/cln/cln-1.3.0.ebuild b/sci-libs/cln/cln-1.3.0.ebuild
new file mode 100644
index 000000000000..e01c89b07910
--- /dev/null
+++ b/sci-libs/cln/cln-1.3.0.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/cln/cln-1.3.0.ebuild,v 1.1 2009/07/14 23:30:10 bicatali Exp $
+
+EAPI=2
+inherit eutils flag-o-matic
+
+DESCRIPTION="Class library (C++) for numbers"
+HOMEPAGE="http://www.ginac.de/CLN/"
+SRC_URI="ftp://ftpthep.physik.uni-mainz.de/pub/gnu/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="1"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+DEPEND="dev-libs/gmp"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ use sparc && append-cppflags "-DNO_ASM"
+ use hppa && append-cppflags "-DNO_ASM"
+}
+
+src_prepare() {
+ # avoid building examples
+ # do it in Makefile.in to avoid time consuming eautoreconf
+ sed -i -e '/^SUBDIRS.*=/s/examples doc benchmarks/doc/' Makefile.in || die
+ # fix compilation under gcc 4.4
+ epatch "${FILESDIR}"/${PN}-1.2.2-gcc-4.4.patch
+}
+
+src_configure () {
+ econf \
+ --libdir=/usr/$(get_libdir) \
+ --datadir=/usr/share/doc/${PF}
+}
+src_compile() {
+ emake || die "emake failed"
+ if use doc; then
+ emake html pdf || die "emake doc failed"
+ fi
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README ChangeLog TODO* NEWS
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins doc/cln.pdf || die
+ dohtml doc/* || die
+ fi
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.cc || die
+ fi
+}