summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2008-11-24 11:02:06 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2008-11-24 11:02:06 +0000
commiteb63b33ebe541a4ff9cbd5fec5017e6415b9e279 (patch)
tree7afc83d800d170e4f9bac4ec3812c1120e227488 /sci-libs
parentRemove test from IUSE, bug 232497. (diff)
downloadgentoo-2-eb63b33ebe541a4ff9cbd5fec5017e6415b9e279.tar.gz
gentoo-2-eb63b33ebe541a4ff9cbd5fec5017e6415b9e279.tar.bz2
gentoo-2-eb63b33ebe541a4ff9cbd5fec5017e6415b9e279.zip
Version bump. Thanks to Adam Pi#tyszek, closing bug #247561
(Portage version: 2.2_rc15/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/fftw/ChangeLog9
-rw-r--r--sci-libs/fftw/fftw-3.2.ebuild (renamed from sci-libs/fftw/fftw-3.1.2-r1.ebuild)12
-rw-r--r--sci-libs/fftw/files/fftw-3.2-as-needed.patch36
-rw-r--r--sci-libs/fftw/files/fftw-3.2-cppflags.patch11
-rw-r--r--sci-libs/fftw/files/fftw-3.2-openmp.patch28
5 files changed, 89 insertions, 7 deletions
diff --git a/sci-libs/fftw/ChangeLog b/sci-libs/fftw/ChangeLog
index d33aec098a9b..ce5aec033233 100644
--- a/sci-libs/fftw/ChangeLog
+++ b/sci-libs/fftw/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sci-libs/fftw
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.73 2008/10/20 21:45:12 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/ChangeLog,v 1.74 2008/11/24 11:02:05 bicatali Exp $
+
+*fftw-3.2 (21 Nov 2008)
+
+ 21 Nov 2008; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/fftw-3.2-as-needed.patch, +files/fftw-3.2-cppflags.patch,
+ +files/fftw-3.2-openmp.patch, -fftw-3.1.2-r1.ebuild, +fftw-3.2.ebuild:
+ Version bump. Thanks to Adam Piątyszek, closing bug #247561
*fftw-3.1.3 (20 Oct 2008)
diff --git a/sci-libs/fftw/fftw-3.1.2-r1.ebuild b/sci-libs/fftw/fftw-3.2.ebuild
index e4c4bcad25e6..a3556fe09eae 100644
--- a/sci-libs/fftw/fftw-3.1.2-r1.ebuild
+++ b/sci-libs/fftw/fftw-3.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.1.2-r1.ebuild,v 1.4 2008/08/28 13:49:20 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/fftw/fftw-3.2.ebuild,v 1.1 2008/11/24 11:02:05 bicatali Exp $
inherit flag-o-matic eutils toolchain-funcs autotools fortran
@@ -32,9 +32,9 @@ pkg_setup() {
src_unpack() {
unpack ${A}
cd "${S}"
- epatch "${FILESDIR}"/${P}-configure.ac.patch
epatch "${FILESDIR}"/${P}-openmp.patch
epatch "${FILESDIR}"/${P}-as-needed.patch
+ epatch "${FILESDIR}"/${P}-cppflags.patch
# fix info file
sed -e 's/Texinfo documentation system/Libraries/' \
@@ -57,16 +57,16 @@ src_compile() {
if use openmp; then
myconfcommon="${myconfcommon}
- --enable-threads
- --with-openmp"
+ --disable-threads
+ --enable-openmp"
elif use threads; then
myconfcommon="${myconfcommon}
--enable-threads
- --without-openmp"
+ --disable-openmp"
else
myconfcommon="${myconfcommon}
--disable-threads
- --without-openmp"
+ --disable-openmp"
fi
local myconfsingle=""
local myconfdouble=""
diff --git a/sci-libs/fftw/files/fftw-3.2-as-needed.patch b/sci-libs/fftw/files/fftw-3.2-as-needed.patch
new file mode 100644
index 000000000000..c991b20f2396
--- /dev/null
+++ b/sci-libs/fftw/files/fftw-3.2-as-needed.patch
@@ -0,0 +1,36 @@
+--- Makefile.am.orig 2008-11-19 10:05:22.000000000 +0100
++++ Makefile.am 2008-11-19 10:06:56.000000000 +0100
+@@ -37,6 +37,13 @@
+ if SMP
+ if COMBINED_THREADS
+ COMBINED_THREADLIBS=threads/libfftw3@PREC_SUFFIX@_threads.la
++else
++lib_LTLIBRARIES += libfftw3@PREC_SUFFIX@_threads.la
++libfftw3@PREC_SUFFIX@_threads_la_SOURCES =
++libfftw3@PREC_SUFFIX@_threads_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
++libfftw3@PREC_SUFFIX@_threads_la_LIBADD = \
++ libfftw3@PREC_SUFFIX@.la \
++ threads/libfftw3@PREC_SUFFIX@_threads.la
+ endif
+ endif
+
+--- threads/Makefile.am.orig 2008-11-19 10:03:43.000000000 +0100
++++ threads/Makefile.am 2008-11-19 10:05:13.000000000 +0100
+@@ -2,11 +2,7 @@
+ -I$(top_srcdir)/rdft -I$(top_srcdir)/api
+
+ if SMP
+-if COMBINED_THREADS
+ noinst_LTLIBRARIES = libfftw3@PREC_SUFFIX@_threads.la
+-else
+-lib_LTLIBRARIES = libfftw3@PREC_SUFFIX@_threads.la
+-endif
+ endif
+
+ # pkgincludedir = $(includedir)/fftw3@PREC_SUFFIX@
+@@ -16,4 +12,5 @@
+ openmp.c threads.h dft-vrank-geq1.c ct.c rdft-vrank-geq1.c hc2hc.c \
+ vrank-geq1-rdft2.c f77api.c f77funcs.h
+
++libfftw3@PREC_SUFFIX@_threads_la_LIBADD = $(THREADLIBS)
+ libfftw3@PREC_SUFFIX@_threads_la_LDFLAGS = -version-info @SHARED_VERSION_INFO@
diff --git a/sci-libs/fftw/files/fftw-3.2-cppflags.patch b/sci-libs/fftw/files/fftw-3.2-cppflags.patch
new file mode 100644
index 000000000000..4d9a1b01c028
--- /dev/null
+++ b/sci-libs/fftw/files/fftw-3.2-cppflags.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2008-11-19 09:57:26.000000000 +0100
++++ configure.ac 2008-11-19 09:59:08.000000000 +0100
+@@ -264,6 +264,8 @@
+ fi
+ fi
+ AC_SUBST(SIMD_CFLAGS)
++# pass simd flags to preprocessor/compiler for proper intrinsics detection.
++CPPFLAGS="$CPPFLAGS $SIMD_CFLAGS"
+
+ dnl Checks for header files.
+ AC_HEADER_STDC
diff --git a/sci-libs/fftw/files/fftw-3.2-openmp.patch b/sci-libs/fftw/files/fftw-3.2-openmp.patch
new file mode 100644
index 000000000000..254b9a05a28b
--- /dev/null
+++ b/sci-libs/fftw/files/fftw-3.2-openmp.patch
@@ -0,0 +1,28 @@
+--- configure.ac.orig 2008-11-19 09:57:26.000000000 +0100
++++ configure.ac 2008-11-19 09:59:08.000000000 +0100
+@@ -435,10 +437,10 @@
+ AC_ARG_WITH(combined-threads, [AC_HELP_STRING([--with-combined-threads],[combine threads into main libfftw3])], with_combined_threads=$withval, with_combined_threads=no)
+
+ if test "$enable_openmp"x != nox; then
+- AX_OPENMP([THREADLIBS=" "
++ AX_OPENMP([THREADLIBS="$OPENMP_LIBS"
+ AC_DEFINE(USING_OPENMP_THREADS, 1, [Define if we have and are using OpenMP multithreading directives])
+ CFLAGS="$CFLAGS $OPENMP_CFLAGS"],
+- [AC_MSG_ERROR([don't know how to enable OpenMP])])
++ [AC_MSG_WARN([don't know how to enable OpenMP, reverting to POSIX threads])])
+ fi
+
+ dnl Check for threads library...
+--- m4/ax_openmp.m4.orig 2008-07-10 11:33:17.361562576 +0100
++++ m4/ax_openmp.m4 2008-07-10 12:05:14.280159723 +0100
+@@ -59,6 +59,10 @@
+ else
+ if test "x$ax_cv_[]_AC_LANG_ABBREV[]_openmp" != "xnone"; then
+ OPENMP_[]_AC_LANG_PREFIX[]FLAGS=$ax_cv_[]_AC_LANG_ABBREV[]_openmp
++ OPENMP_LIBS=" "
++ if test "x$ax_cv_[]_AC_LANG_ABBREV[]_openmp" = "x-fopenmp"; then
++ OPENMP_LIBS="-lgomp"
++ fi
+ fi
+ m4_default([$1], [AC_DEFINE(HAVE_OPENMP,1,[Define if OpenMP is enabled])])
+ fi