summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Dittrich <markusle@gentoo.org>2008-10-08 22:50:58 +0000
committerMarkus Dittrich <markusle@gentoo.org>2008-10-08 22:50:58 +0000
commitf7b696a854b5d1fe75e219a791a5030e4fb25601 (patch)
tree6cfcaf6af166d551890d7940161c737c1b3cbf7f /sci-libs
parentVersion bump to 1.4.8_pre2 (diff)
downloadgentoo-2-f7b696a854b5d1fe75e219a791a5030e4fb25601.tar.gz
gentoo-2-f7b696a854b5d1fe75e219a791a5030e4fb25601.tar.bz2
gentoo-2-f7b696a854b5d1fe75e219a791a5030e4fb25601.zip
Version bump.
(Portage version: 2.2_rc11/cvs/Linux 2.6.26-SENTINEL-2 i686)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/itpp/ChangeLog7
-rw-r--r--sci-libs/itpp/itpp-4.0.6.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/sci-libs/itpp/ChangeLog b/sci-libs/itpp/ChangeLog
index af34e16ac2b6..a5f394041f38 100644
--- a/sci-libs/itpp/ChangeLog
+++ b/sci-libs/itpp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sci-libs/itpp
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.82 2008/07/30 22:24:45 markusle Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/ChangeLog,v 1.83 2008/10/08 22:50:58 markusle Exp $
+
+*itpp-4.0.6 (08 Oct 2008)
+
+ 08 Oct 2008; Markus Dittrich <markusle@gentoo.org> +itpp-4.0.6.ebuild:
+ Version bump.
*itpp-4.0.5 (30 Jul 2008)
diff --git a/sci-libs/itpp/itpp-4.0.6.ebuild b/sci-libs/itpp/itpp-4.0.6.ebuild
new file mode 100644
index 000000000000..d699f0e9a7c1
--- /dev/null
+++ b/sci-libs/itpp/itpp-4.0.6.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/itpp/itpp-4.0.6.ebuild,v 1.1 2008/10/08 22:50:58 markusle Exp $
+
+inherit fortran flag-o-matic
+
+# we need this to prevent itpp's specialized debug lib
+# (built with USE="debug" set) from being stripped
+RESTRICT="strip"
+
+DESCRIPTION="C++ library of mathematical, signal processing and communication classes and functions"
+LICENSE="GPL-2"
+HOMEPAGE="http://itpp.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="blas debug doc fftw lapack minimal"
+
+RDEPEND="!minimal? ( fftw? ( >=sci-libs/fftw-3.0.0 ) )
+ blas? ( virtual/blas
+ lapack? ( virtual/lapack ) )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen
+ virtual/latex-base )"
+
+pkg_setup() {
+ # lapack can only be used in conjunction with blas
+ if use lapack && ! use blas; then
+ die "USE=lapack requires USE=blas to be set"
+ fi
+}
+
+src_compile() {
+ # turn off performance critical debug code
+ append-flags -DNDEBUG
+
+ # make sure that -g is stripped always since we use
+ # RESTRICT=strip. If debug info is needed please enable
+ # the debug use flag and link against the debug *.so
+ filter-flags -g
+
+ local blas_conf="--without-blas"
+ local lapack_conf="--without-lapack"
+ if use blas; then
+ if use lapack; then
+ blas_conf="--with-blas=$(pkg-config lapack --libs)"
+ lapack_conf="--with-lapack"
+ else
+ blas_conf="--with-blas=$(pkg-config blas --libs)"
+ fi
+ fi
+
+ local fftw_conf="--without-fft";
+ if use fftw;
+ then
+ fftw_conf="--with-fft=-lfftw3"
+ fi
+
+ local myconf="--docdir=/usr/share/doc/${P}"
+ if use minimal; then
+ myconf="${myconf} --disable-comm --disable-fixed --disable-optim --disable-protocol --disable-signal --disable-srccode"
+ fi
+
+ econf $(use_enable doc html-doc) \
+ $(use_enable debug) \
+ "${blas_conf}" \
+ "${lapack_conf}" \
+ "${fftw_conf}" \
+ ${myconf} \
+ || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make install DESTDIR="${D}" || die "make install failed"
+ dodoc AUTHORS ChangeLog ChangeLog-2007 ChangeLog-2006 \
+ ChangeLog-2005 INSTALL NEWS NEWS-3.10 NEWS-3.99 README TODO \
+ || die "failed to install docs"
+}