summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2009-09-15 08:39:44 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2009-09-15 08:39:44 +0000
commitff7f4ad6fa7244f7b5b1fcd0f78cc771f40a902f (patch)
tree9308f13d868f90acce58b0782478073b92f3d357 /sci-libs
parentIntroduce back older version which does not break kopete... (diff)
downloadgentoo-2-ff7f4ad6fa7244f7b5b1fcd0f78cc771f40a902f.tar.gz
gentoo-2-ff7f4ad6fa7244f7b5b1fcd0f78cc771f40a902f.tar.bz2
gentoo-2-ff7f4ad6fa7244f7b5b1fcd0f78cc771f40a902f.zip
Fix mulitilib issues per bug #284929.
(Portage version: 2.2_rc38/cvs/Linux i686)
Diffstat (limited to 'sci-libs')
-rw-r--r--sci-libs/indilib/ChangeLog6
-rw-r--r--sci-libs/indilib/files/0.6-multilib.patch21
-rw-r--r--sci-libs/indilib/indilib-0.6.ebuild3
3 files changed, 28 insertions, 2 deletions
diff --git a/sci-libs/indilib/ChangeLog b/sci-libs/indilib/ChangeLog
index c37a30e4a7d9..ac17813ddbad 100644
--- a/sci-libs/indilib/ChangeLog
+++ b/sci-libs/indilib/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sci-libs/indilib
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/ChangeLog,v 1.6 2009/09/07 11:03:07 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/ChangeLog,v 1.7 2009/09/15 08:39:44 scarabeus Exp $
+
+ 15 Sep 2009; Tomáš Chvátal <scarabeus@gentoo.org>
+ +files/0.6-multilib.patch, indilib-0.6.ebuild:
+ Fix mulitilib issues per bug #284929.
07 Sep 2009; Tomáš Chvátal <scarabeus@gentoo.org> indilib-0.6.ebuild,
metadata.xml:
diff --git a/sci-libs/indilib/files/0.6-multilib.patch b/sci-libs/indilib/files/0.6-multilib.patch
new file mode 100644
index 000000000000..3f7ab720f2fb
--- /dev/null
+++ b/sci-libs/indilib/files/0.6-multilib.patch
@@ -0,0 +1,21 @@
+diff -urN libindi0-0.6.old/CMakeLists.txt libindi0-0.6/CMakeLists.txt
+--- libindi0-0.6.old/CMakeLists.txt 2008-11-18 10:45:06.000000000 +0100
++++ libindi0-0.6/CMakeLists.txt 2009-09-15 10:35:17.000000000 +0200
+@@ -96,7 +96,7 @@
+ ######## INDI Static Library #########
+ ######################################
+ add_library(indidriver STATIC ${indimain_SRCS})
+-install(TARGETS indidriver ARCHIVE DESTINATION lib${LIB_POSTFIX})
++install(TARGETS indidriver ARCHIVE DESTINATION lib${LIB_SUFFIX})
+
+ ######################################
+ ######## INDI Shared Library #########
+@@ -114,7 +114,7 @@
+ target_link_libraries(indi ${FLI_LIBRARIES})
+ endif(FLI_FOUND)
+
+-install(TARGETS indi LIBRARY DESTINATION lib${LIB_POSTFIX})
++install(TARGETS indi LIBRARY DESTINATION lib${LIB_SUFFIX})
+ set_target_properties(indi PROPERTIES VERSION ${INDI_VERSION} SOVERSION ${INDI_SOVERSION})
+
+ #####################################
diff --git a/sci-libs/indilib/indilib-0.6.ebuild b/sci-libs/indilib/indilib-0.6.ebuild
index cd9511c698c7..44a425aa0d89 100644
--- a/sci-libs/indilib/indilib-0.6.ebuild
+++ b/sci-libs/indilib/indilib-0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/indilib-0.6.ebuild,v 1.2 2009/09/07 11:03:07 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/sci-libs/indilib/indilib-0.6.ebuild,v 1.3 2009/09/15 08:39:44 scarabeus Exp $
EAPI="2"
@@ -32,6 +32,7 @@ S="${WORKDIR}/${MY_P/_/-}"
PATCHES=(
"${FILESDIR}"/${PV}-fix_symlink.patch
+ "${FILESDIR}"/${PV}-multilib.patch
)
src_configure() {